forked from msys2/MINGW-packages
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
- Loading branch information
Showing
1 changed file
with
38 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,38 @@ | ||
diff -urN scotch-v7.0.5_orig/src/esmumps/CMakeLists.txt scotch-v7.0.5/src/esmumps/CMakeLists.txt | ||
--- scotch-v7.0.5_orig/src/esmumps/CMakeLists.txt 2024-08-13 11:00:50.000000000 +0200 | ||
+++ scotch-v7.0.5/src/esmumps/CMakeLists.txt 2024-10-16 20:20:58.763952500 +0200 | ||
@@ -130,6 +130,7 @@ | ||
NAMESPACE SCOTCH:: | ||
DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/scotch) | ||
|
||
+set_target_properties(esmumps PROPERTIES OUTPUT_NAME esmumps${NAME_SUFFIX}) | ||
install(TARGETS esmumps | ||
COMPONENT libscotch | ||
EXPORT esmumpsTargets | ||
@@ -164,6 +165,7 @@ | ||
NAMESPACE SCOTCH:: | ||
DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/scotch) | ||
|
||
+set_target_properties(ptesmumps PROPERTIES OUTPUT_NAME ptesmumps${NAME_SUFFIX}) | ||
install(TARGETS ptesmumps | ||
COMPONENT libptscotch | ||
EXPORT ptesmumpsTargets | ||
diff -urN scotch-v7.0.5_orig/src/libscotch/CMakeLists.txt scotch-v7.0.5/src/libscotch/CMakeLists.txt | ||
--- scotch-v7.0.5_orig/src/libscotch/CMakeLists.txt 2024-08-13 11:00:50.000000000 +0200 | ||
+++ scotch-v7.0.5/src/libscotch/CMakeLists.txt 2024-10-16 20:22:07.519574200 +0200 | ||
@@ -822,6 +822,7 @@ | ||
set(TARGETS_LIST "scotch;scotcherr;scotcherrexit") | ||
|
||
foreach(_target ${TARGETS_LIST}) | ||
+ set_target_properties(${_target} PROPERTIES OUTPUT_NAME ${_target}${NAME_SUFFIX}) | ||
install(EXPORT ${_target}Targets | ||
COMPONENT libscotch | ||
FILE ${_target}Targets.cmake | ||
@@ -836,6 +837,7 @@ | ||
PUBLIC_HEADER DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}) | ||
|
||
if (BUILD_PTSCOTCH) | ||
+ set_target_properties(pt${_target} PROPERTIES OUTPUT_NAME pt${_target}${NAME_SUFFIX}) | ||
install(EXPORT pt${_target}Targets | ||
COMPONENT libptscotch | ||
FILE pt${_target}Targets.cmake |