Skip to content

Commit

Permalink
new package: python-trame
Browse files Browse the repository at this point in the history
  • Loading branch information
3rav authored Sep 2, 2024
1 parent a52c50d commit cf24001
Showing 1 changed file with 34 additions and 0 deletions.
34 changes: 34 additions & 0 deletions mingw-w64-python-trame/PKGBUILD
Original file line number Diff line number Diff line change
@@ -0,0 +1,34 @@
# Maintainer: Brzegowy Rafał <[email protected]>

_realname=trame
pkgbase=mingw-w64-python-${_realname}
pkgname=("${MINGW_PACKAGE_PREFIX}-python-${_realname}")
pkgver=3.6.3
pkgrel=1
pkgdesc='A Python 3 Library for Building the Genetic Algorithm and Training Machine Learning Algoithms (mingw-w64)'
arch=('any')
mingw_arch=('mingw64' 'ucrt64' 'clang64')
url="https://github.com/Kitware/${_realname}"
license=('Apache-2.0')
#depends=("${MINGW_PACKAGE_PREFIX}-python-trame-server"
# "${MINGW_PACKAGE_PREFIX}-python-trame-client")
makedepends=("${MINGW_PACKAGE_PREFIX}-python-build"
"${MINGW_PACKAGE_PREFIX}-python-installer"
"${MINGW_PACKAGE_PREFIX}-python-setuptools"
"${MINGW_PACKAGE_PREFIX}-python-wheel")
source=("https://github.com/Kitware/${_realname}/releases/download/v${pkgver}/${_realname}-${pkgver}.tar.gz")
sha256sums=('09c1193eee3a2b1ed5a3dc46db75d8ee1cd1f8da66e4614d583f0ecf02705fc0')

build() {
cp -r "${_realname}-${pkgver}" "python-build-${MSYSTEM}" && cd "python-build-${MSYSTEM}"

${MINGW_PREFIX}/bin/python -m build --wheel --skip-dependency-check --no-isolation
}

package() {
cd "${srcdir}/python-build-${MSYSTEM}"

MSYS2_ARG_CONV_EXCL="--prefix=" \
${MINGW_PREFIX}/bin/python -m installer --prefix=${MINGW_PREFIX} \
--destdir="${pkgdir}" dist/*.whl
}

0 comments on commit cf24001

Please sign in to comment.