-
Notifications
You must be signed in to change notification settings - Fork 69
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
- Loading branch information
Showing
1 changed file
with
9 additions
and
6 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,18 +1,18 @@ | ||
# | ||
# Copyright (c) 2018-2020 Nick Peng ([email protected]) | ||
# Copyright (c) 2018-2023 Nick Peng ([email protected]) | ||
# This is free software, licensed under the GNU General Public License v3. | ||
# | ||
|
||
include $(TOPDIR)/rules.mk | ||
|
||
PKG_NAME:=smartdns | ||
PKG_VERSION:=1.2022.38.1 | ||
PKG_VERSION:=1.2023.42 | ||
PKG_RELEASE:=1 | ||
|
||
PKG_SOURCE_PROTO:=git | ||
PKG_SOURCE_URL:=https://www.github.com/pymumu/smartdns.git | ||
PKG_SOURCE_VERSION:=9bc857f628299573c7eca0833229d9812b1c1de4 | ||
PKG_MIRROR_HASH:=a202b765e6ce8355335c80214819add3ed72a82426b033d7d5adf1448b415063 | ||
PKG_SOURCE_VERSION:=ed102cda03c56e9c63040d33d4a391b56491493e | ||
PKG_MIRROR_HASH:=366e98b92c3d22844ff5fc52c35f65c3b01e1b92fc9dc14c474823f0cc3ed11a | ||
|
||
PKG_MAINTAINER:=Nick Peng <[email protected]> | ||
PKG_LICENSE:=GPL-3.0-or-later | ||
|
@@ -36,18 +36,21 @@ endef | |
define Package/smartdns/description | ||
SmartDNS is a local DNS server which accepts DNS query requests from local network clients, | ||
gets DNS query results from multiple upstream DNS servers concurrently, and returns the fastest IP to clients. | ||
Unlike dnsmasq's all-servers, smartdns returns the fastest IP. | ||
Unlike dnsmasq's all-servers, smartdns returns the fastest IP, and encrypt DNS queries with DoT or DoH. | ||
endef | ||
|
||
define Package/smartdns/conffiles | ||
/etc/config/smartdns | ||
/etc/smartdns/address.conf | ||
/etc/smartdns/blacklist-ip.conf | ||
/etc/smartdns/custom.conf | ||
/etc/smartdns/domain-block.list | ||
/etc/smartdns/domain-forwarding.list | ||
endef | ||
|
||
define Package/smartdns/install | ||
$(INSTALL_DIR) $(1)/usr/sbin $(1)/etc/config $(1)/etc/init.d $(1)/etc/smartdns | ||
$(INSTALL_DIR) $(1)/usr/sbin $(1)/etc/config $(1)/etc/init.d | ||
$(INSTALL_DIR) $(1)/etc/smartdns $(1)/etc/smartdns/domain-set $(1)/etc/smartdns/conf.d/ | ||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/smartdns $(1)/usr/sbin/smartdns | ||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/package/openwrt/files/etc/init.d/smartdns $(1)/etc/init.d/smartdns | ||
$(INSTALL_CONF) $(PKG_BUILD_DIR)/package/openwrt/address.conf $(1)/etc/smartdns/address.conf | ||
|