Skip to content

Commit

Permalink
pypi-zipp: Autospec creation for update from version 3.10.0 to versio…
Browse files Browse the repository at this point in the history
…n 3.11.0

Jason R. Coombs (16):
      GHA pretty env (#67)
      Add 3.12 to compatibility list.
      Pin mypy to '<0.990' due to realpython/pytest-mypy#141
      Remove the hyperlink for the Python versions badge. The PyPI badge is a better anchor for the hyperlink.
      Apply explicit_package_bases for mypy and unpin the version. Ref python/mypy#14057.
      Add Python 3.12 to matrix. Only test 3.8-3.10 on Linux.
      Disable flake8 on Python 3.12. Workaround for tholo/pytest-flake8#87.
      Remove unused import.
      Re-implement glob directly, adding compatibility for older Pythons and avoids platform-specific concerns.
      Add docstring to __eq__, covering NotImplemented types.
      Add test capturing empty glob pattern.
      Use PurePosixPath for relative paths within a zip file. Fixes failing test on Windows. Added test for relative paths with subdirectories.
      Remove constraint that the result of relative_to is a pathlib object. Instead, assert that its string value resolves to the expected value.
      Reimplement relative_to using posixpath primitives.
      Move inline comment to docstring and expand org.
      Update changelog.

Julian Berman (1):
      Teach zipp.Path some additional pathlib.Path methods.

Zach Burnett (1):
      rename `.readthedocs.yml` to `.readthedocs.yaml` (RTD docs indicate that `.readthedocs.yml` will be deprecated) (#68)
  • Loading branch information
fenrus75 committed Nov 27, 2022
1 parent 783db41 commit 3762b19
Show file tree
Hide file tree
Showing 6 changed files with 18 additions and 18 deletions.
2 changes: 1 addition & 1 deletion Makefile
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
PKG_NAME := pypi-zipp
URL = https://files.pythonhosted.org/packages/8d/d7/1bd1e0a5bc95a27a6f5c4ee8066ddfc5b69a9ec8d39ab11a41a804ec8f0d/zipp-3.10.0.tar.gz
URL = https://files.pythonhosted.org/packages/8e/b3/8b16a007184714f71157b1a71bbe632c5d66dd43bc8152b3c799b13881e1/zipp-3.11.0.tar.gz
ARCHIVES =

include ../common/Makefile.common
4 changes: 3 additions & 1 deletion options.conf
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
[package]
name = pypi-zipp
url = https://files.pythonhosted.org/packages/8d/d7/1bd1e0a5bc95a27a6f5c4ee8066ddfc5b69a9ec8d39ab11a41a804ec8f0d/zipp-3.10.0.tar.gz
url = https://files.pythonhosted.org/packages/8e/b3/8b16a007184714f71157b1a71bbe632c5d66dd43bc8152b3c799b13881e1/zipp-3.11.0.tar.gz
archives =
giturl = https://github.com/jaraco/zipp/
domain =
Expand Down Expand Up @@ -35,6 +35,8 @@ insecure_build = false
keepstatic = false
# do not require autostart subpackage
no_autostart = false
# do not use the replacement pattern for file matching
no_glob = false
# do not generate debuginfo for this package
nodebug = false
# disable stripping binaries
Expand Down
24 changes: 11 additions & 13 deletions pypi-zipp.spec
Original file line number Diff line number Diff line change
Expand Up @@ -3,10 +3,10 @@
# Generated by: autospec.py
#
Name : pypi-zipp
Version : 3.10.0
Release : 54
URL : https://files.pythonhosted.org/packages/8d/d7/1bd1e0a5bc95a27a6f5c4ee8066ddfc5b69a9ec8d39ab11a41a804ec8f0d/zipp-3.10.0.tar.gz
Source0 : https://files.pythonhosted.org/packages/8d/d7/1bd1e0a5bc95a27a6f5c4ee8066ddfc5b69a9ec8d39ab11a41a804ec8f0d/zipp-3.10.0.tar.gz
Version : 3.11.0
Release : 55
URL : https://files.pythonhosted.org/packages/8e/b3/8b16a007184714f71157b1a71bbe632c5d66dd43bc8152b3c799b13881e1/zipp-3.11.0.tar.gz
Source0 : https://files.pythonhosted.org/packages/8e/b3/8b16a007184714f71157b1a71bbe632c5d66dd43bc8152b3c799b13881e1/zipp-3.11.0.tar.gz
Summary : Backport of pathlib-compatible object wrapper for zip files
Group : Development/Tools
License : MIT
Expand All @@ -24,9 +24,7 @@ BuildRequires : pypi-virtualenv

%description
.. image:: https://img.shields.io/pypi/v/zipp.svg
:target: `PyPI link`_
.. image:: https://img.shields.io/pypi/pyversions/zipp.svg
:target: `PyPI link`_
:target: https://pypi.org/project/zipp

%package license
Summary: license components for the pypi-zipp package.
Expand Down Expand Up @@ -56,18 +54,18 @@ python3 components for the pypi-zipp package.


%prep
%setup -q -n zipp-3.10.0
cd %{_builddir}/zipp-3.10.0
%setup -q -n zipp-3.11.0
cd %{_builddir}/zipp-3.11.0
pushd ..
cp -a zipp-3.10.0 buildavx2
cp -a zipp-3.11.0 buildavx2
popd

%build
export http_proxy=http://127.0.0.1:9/
export https_proxy=http://127.0.0.1:9/
export no_proxy=localhost,127.0.0.1,0.0.0.0
export LANG=C.UTF-8
export SOURCE_DATE_EPOCH=1666631561
export SOURCE_DATE_EPOCH=1669552879
export GCC_IGNORE_WERROR=1
export AR=gcc-ar
export RANLIB=gcc-ranlib
Expand All @@ -79,8 +77,8 @@ export CXXFLAGS="$CXXFLAGS -O3 -ffat-lto-objects -flto=auto "
export MAKEFLAGS=%{?_smp_mflags}
python3 -m build --wheel --skip-dependency-check --no-isolation
pushd ../buildavx2/
export CFLAGS="$CFLAGS -m64 -march=x86-64-v3 -Wl,-z,x86-64-v3 -msse2avx"
export CXXFLAGS="$CXXFLAGS -m64 -march=x86-64-v3 -Wl,-z,x86-64-v3 -msse2avx "
export CFLAGS="$CFLAGS -m64 -march=x86-64-v3 -Wl,-z,x86-64-v3 "
export CXXFLAGS="$CXXFLAGS -m64 -march=x86-64-v3 -Wl,-z,x86-64-v3 "
export FFLAGS="$FFLAGS -m64 -march=x86-64-v3 -Wl,-z,x86-64-v3 "
export FCFLAGS="$FCFLAGS -m64 -march=x86-64-v3 "
export LDFLAGS="$LDFLAGS -m64 -march=x86-64-v3 "
Expand Down
2 changes: 1 addition & 1 deletion release
Original file line number Diff line number Diff line change
@@ -1 +1 @@
54
55
2 changes: 1 addition & 1 deletion upstream
Original file line number Diff line number Diff line change
@@ -1 +1 @@
017268ef95e7da55ca11e695b63cda797d7a64be/zipp-3.10.0.tar.gz
3f6c57b68f3b9165586ea7cce96fc2540b0078ec/zipp-3.11.0.tar.gz
2 changes: 1 addition & 1 deletion versions
Original file line number Diff line number Diff line change
@@ -1 +1 @@
3.10.0
3.11.0

0 comments on commit 3762b19

Please sign in to comment.