-
Notifications
You must be signed in to change notification settings - Fork 20
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
- Loading branch information
Showing
2 changed files
with
14 additions
and
13 deletions.
There are no files selected for viewing
Submodule luci-app-pcap-dnsproxy
updated
6 files
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,7 +1,7 @@ | ||
include $(TOPDIR)/rules.mk | ||
|
||
PKG_NAME:=fantastic-packages-feeds | ||
PKG_VERSION:=20241201 | ||
PKG_VERSION:=2025???? | ||
PKG_RELEASE:=1 | ||
|
||
PKG_MAINTAINER:=Anya Lin <[email protected]> | ||
|
@@ -15,7 +15,7 @@ include $(INCLUDE_DIR)/package.mk | |
define Package/$(PKG_NAME) | ||
SECTION:=base | ||
CATEGORY:=Base system | ||
DEPENDS:=+fantastic-keyring +opkg | ||
DEPENDS:=+fantastic-keyring +apk | ||
TITLE:=Installer for fantastic-packages feeds | ||
PKGARCH:=all | ||
endef | ||
|
@@ -51,33 +51,34 @@ else | |
ARCH_PACKAGES=$$DISTRIB_ARCH | ||
fi | ||
if [ "$$VERSION_NUMBER" = "SNAPSHOT" ]; then | ||
BRANCH="24.10" | ||
BRANCH="25.??" | ||
[ "$$REVISION" -lt ????? ] && BRANCH="24.10" | ||
[ "$$REVISION" -lt 28158 ] && BRANCH="23.05" | ||
[ "$$REVISION" -lt 23069 ] && BRANCH="22.03" | ||
[ "$$REVISION" -lt 19302 ] && BRANCH="21.02" | ||
# https://archive.openwrt.org/releases/**/version.buildinfo | ||
# r?????-?????????? 25.??.?-rc1 | ||
# r28158-d276b4c91a 24.10.0-rc1 | ||
# r23069-e2701e0f33 23.05.0-rc1 | ||
# r19302-df622768da 22.03.0-rc1 | ||
# r16122-c2139eef27 21.02.0-rc2 | ||
else | ||
BRANCH=$$(echo $$VERSION_NUMBER | awk -F '.' -v OFS='.' '{print $$1,$$2}') | ||
fi | ||
if ! grep -q fantastic_packages_ "$$IPKG_INSTROOT/etc/opkg/customfeeds.conf"; then | ||
BASE_URL="https://fantastic-packages.github.io/packages/releases" | ||
BASE_URL="https://fantastic-packages.github.io/packages/releases" | ||
if ! grep -q "$$BASE_URL" "$$IPKG_INSTROOT/etc/apk/repositories.d/customfeeds.list"; then | ||
BASE_URL="$$BASE_URL/$$BRANCH/packages/$$ARCH_PACKAGES" | ||
cat <<- EOF >> "$$IPKG_INSTROOT/etc/opkg/customfeeds.conf" | ||
src/gz fantastic_packages_packages $$BASE_URL/packages | ||
src/gz fantastic_packages_luci $$BASE_URL/luci | ||
src/gz fantastic_packages_special $$BASE_URL/special | ||
cat <<- EOF >> "$$IPKG_INSTROOT/etc/apk/repositories.d/customfeeds.list" | ||
$$BASE_URL/packages/packages.adb | ||
$$BASE_URL/luci/packages.adb | ||
$$BASE_URL/special/packages.adb | ||
EOF | ||
fi | ||
exit 0 | ||
endef | ||
|
||
define Package/$(PKG_NAME)/prerm | ||
#!/bin/sh | ||
sed -i "/fantastic_packages_/d" "$$IPKG_INSTROOT/etc/opkg/customfeeds.conf" | ||
BASE_URL="https://fantastic-packages.github.io/packages/releases" | ||
sed -i "/$$BASE_URL/d" "$$IPKG_INSTROOT/etc/apk/repositories.d/customfeeds.list" | ||
exit 0 | ||
endef | ||
|
||
|