-
Notifications
You must be signed in to change notification settings - Fork 0
/
Copy path53_K진수 출력.cpp
88 lines (65 loc) · 1.27 KB
/
53_K진수 출력.cpp
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
/*
53.K진수 출력
10진수 N이 입력되면 K진수로 변환하여 출력하는 프로그램을
작성하세요.스택 자료구조를 사용하시기 바랍니다.
▣ 입력설명
첫 번째 줄에 10진수 N(10 <= N <= 1, 000)과 K(2, 5, 8, 16)
가 주어진다.
▣ 출력설명
K진수를 출력한다.
▣ 입력예제 1
11 2
▣ 출력예제 1
1011
▣ 입력예제 2
31 16
▣ 출력예제 2
1F
*/
#include <iostream>
using namespace std;
#define MAX_STACK_SIZE 1000
int stack[MAX_STACK_SIZE];
int top = -1;
bool IsEmpty() {
if (top < 0)
return true;
else
return false;
}
bool IsFull() {
if (top >= MAX_STACK_SIZE - 1)
return true;
else
return false;
}
void push(int value) {
if (IsFull() == true)
printf("스택이 가득 찼습니다.");
else
stack[++top] = value;
}
int pop() {
if (IsEmpty() == true)
printf("스택이 비었습니다.");
else
return stack[top--];
}
int main() {
int N, K;
scanf("%d %d", &N, &K);
while(N>=K)
{
push(N % K);
N = N/ K;
}
push(N % K);
while(!IsEmpty())
{
if(K!=16)
printf("%d", pop());
else
printf("%X", pop());
}
}
// class로 stack 구현!