-
Notifications
You must be signed in to change notification settings - Fork 0
/
Copy path1datatypes.cpp
41 lines (30 loc) · 868 Bytes
/
1datatypes.cpp
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
/*Input Format
Input consists of the following space-separated values: int, long, char, float, and double, respectively.
Output Format
Print each element on a new line in the same order it was received as input. Note that the floating point value should be correct up to 3 decimal places and the double to 9 decimal places.
Sample Input
3 12345678912345 a 334.23 14049.30493
Sample Output
3
12345678912345
a
334.230
14049.304930000 */
#include <iostream>
#include <cstdio>
#include <iomanip>
using namespace std;
int main() {
// Complete the code.
int a;
long b;
char c;
float d;
double e;
cin>>a>>b>>c>>d>>e;
cout<<a<<"\n"<<b<<"\n"<<c<<"\n";
cout<<fixed<<setprecision(3)<<d<<"\n";
cout<<fixed<<setprecision(9)<<e<<"\n";
return 0;
}
//here including the header file <iomanip> is imp to run setprecision function