-
Notifications
You must be signed in to change notification settings - Fork 5
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
x86: fix build for up_squared boards
Signed-off-by: Naveen Saini <[email protected]>
- Loading branch information
Showing
1 changed file
with
32 additions
and
6 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,4 +1,4 @@ | ||
From 770ab47f542366cecd56dc35037947679eacc5f0 Mon Sep 17 00:00:00 2001 | ||
From 90d5e7c9c6037a030d5c0bfa4ae298da66eaf35e Mon Sep 17 00:00:00 2001 | ||
From: Naveen Saini <[email protected]> | ||
Date: Thu, 12 Sep 2024 21:05:09 +0800 | ||
Subject: [PATCH] x86: fix efi binary generation issue in cross compilation env | ||
|
@@ -9,11 +9,13 @@ Upstream-Status: Inappropriate [Cross-compilation specific] | |
|
||
Signed-off-by: Naveen Saini <[email protected]> | ||
--- | ||
arch/x86/zefi/zefi.py | 5 ++++- | ||
boards/intel/adl/CMakeLists.txt | 1 + | ||
boards/intel/ehl/CMakeLists.txt | 1 + | ||
boards/intel/rpl/CMakeLists.txt | 1 + | ||
4 files changed, 7 insertions(+), 1 deletion(-) | ||
arch/x86/zefi/zefi.py | 5 ++++- | ||
boards/intel/adl/CMakeLists.txt | 1 + | ||
boards/intel/ehl/CMakeLists.txt | 1 + | ||
boards/intel/rpl/CMakeLists.txt | 1 + | ||
boards/up-bridge-the-gap/up_squared/CMakeLists.txt | 1 + | ||
boards/up-bridge-the-gap/up_squared_pro_7000/CMakeLists.txt | 1 + | ||
6 files changed, 9 insertions(+), 1 deletion(-) | ||
|
||
diff --git a/arch/x86/zefi/zefi.py b/arch/x86/zefi/zefi.py | ||
index 99c188ecd08..1cd86a21cd4 100755 | ||
|
@@ -67,6 +69,30 @@ diff --git a/boards/intel/rpl/CMakeLists.txt b/boards/intel/rpl/CMakeLists.txt | |
index 36ddcdf9d13..4cb244a777d 100644 | ||
--- a/boards/intel/rpl/CMakeLists.txt | ||
+++ b/boards/intel/rpl/CMakeLists.txt | ||
@@ -8,6 +8,7 @@ set_property(GLOBAL APPEND PROPERTY extra_post_build_commands | ||
-o ${CMAKE_OBJCOPY} | ||
-i ${ZEPHYR_BASE}/include | ||
-f ${PROJECT_BINARY_DIR}/${CONFIG_KERNEL_BIN_NAME}.elf | ||
+ -s ${SYSROOT_DIR} | ||
$<$<BOOL:${CMAKE_VERBOSE_MAKEFILE}>:--verbose> | ||
WORKING_DIRECTORY ${PROJECT_BINARY_DIR} | ||
) | ||
diff --git a/boards/up-bridge-the-gap/up_squared/CMakeLists.txt b/boards/up-bridge-the-gap/up_squared/CMakeLists.txt | ||
index ddfd93807ff..8dfe7aa9cec 100644 | ||
--- a/boards/up-bridge-the-gap/up_squared/CMakeLists.txt | ||
+++ b/boards/up-bridge-the-gap/up_squared/CMakeLists.txt | ||
@@ -11,6 +11,7 @@ set_property(GLOBAL APPEND PROPERTY extra_post_build_commands | ||
-o ${CMAKE_OBJCOPY} | ||
-i ${ZEPHYR_BASE}/include | ||
-f ${PROJECT_BINARY_DIR}/${CONFIG_KERNEL_BIN_NAME}.elf | ||
+ -s ${SYSROOT_DIR} | ||
$<$<BOOL:${CMAKE_VERBOSE_MAKEFILE}>:--verbose> | ||
WORKING_DIRECTORY ${PROJECT_BINARY_DIR} | ||
) | ||
diff --git a/boards/up-bridge-the-gap/up_squared_pro_7000/CMakeLists.txt b/boards/up-bridge-the-gap/up_squared_pro_7000/CMakeLists.txt | ||
index 36ddcdf9d13..4cb244a777d 100644 | ||
--- a/boards/up-bridge-the-gap/up_squared_pro_7000/CMakeLists.txt | ||
+++ b/boards/up-bridge-the-gap/up_squared_pro_7000/CMakeLists.txt | ||
@@ -8,6 +8,7 @@ set_property(GLOBAL APPEND PROPERTY extra_post_build_commands | ||
-o ${CMAKE_OBJCOPY} | ||
-i ${ZEPHYR_BASE}/include | ||
|