-
Notifications
You must be signed in to change notification settings - Fork 0
/
Copy pathbasic_报时助手.java
80 lines (78 loc) · 2.72 KB
/
basic_报时助手.java
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
package LanQiao.BasicExercise;
import java.util.Scanner;
/**
* @Auther: zhaodong
* @Date: 2019/1/25 20:45
* @Description:
*/
public class basic_报时助手 {
/**
* 基础练习 报时助手
* 描述
*
* 给定当前的时间,请用英文的读法将它读出来。
*
* 时间用时h和分m表示,在英文的读法中,读一个时间的方法是:
*
* 如果m为0,则将时读出来,然后加上“o'clock”,如3:00读作“three o'clock”。
*
* 如果m不为0,则将时读出来,然后将分读出来,如5:30读作“five thirty”。
*
* 时和分的读法使用的是英文数字的读法,其中0~20读作:
*
* 0:zero, 1: one, 2:two, 3:three, 4:four, 5:five, 6:six, 7:seven, 8:eight, 9:nine, 10:ten, 11:eleven, 12:twelve, 13:thirteen, 14:fourteen, 15:fifteen, 16:sixteen, 17:seventeen, 18:eighteen, 19:nineteen, 20:twenty。
*
* 30读作thirty,40读作forty,50读作fifty。
*
* 对于大于20小于60的数字,首先读整十的数,然后再加上个位数。如31首先读30再加1的读法,读作“thirty one”。
*
* 按上面的规则21:54读作“twenty one fifty four”,9:07读作“nine seven”,0:15读作“zero fifteen”。
*
*
* 输入
*
* 输入描述:
*
* 输入包含两个非负整数h和m,表示时间的时和分。非零的数字前没有前导0。h小于24,m小于60。
*
* 输入样例:
*
* 0 15
*
*
* 输出
*
* 输出描述:
*
* 输出时间时刻的英文。
*
* 输出样例:
*
* zero fifteen
*
* 思路: 模拟
* @param args
*/
public static void main(String[] args) {
Scanner cin = new Scanner(System.in);
int h, m;
h = cin.nextInt();
m = cin.nextInt();
String[] arr = {"zero", "one", "two", "three", "four", "five", "six", "seven", "eight", "nine", "ten", "eleven", "twelve", "thirteen",
"fourteen", "fifteen", "sixteen", "seventeen", "eighteen", "nineteen", "twenty", "twenty one", "twenty two", "twenty three"};
System.out.print(arr[h]+" ");
if (m == 0) System.out.print("o'clock");
int t = m % 10;
m = m / 10;
switch (m) {
case 2: System.out.print("twenty ");break;
case 3: System.out.print("thirty ");break;
case 4: System.out.print("forty ");break;
case 5: System.out.print("fifty ");break;
default: break;
}
if (m == 0 && t != 0) System.out.print(arr[t]);
if (m == 1) System.out.print(arr[t + 10]);
if (m != 0 && m != 1 && t != 0) System.out.print(arr[t]);
}
}