Skip to content

Commit 237bd5a

Browse files
rabonekomadonuko
andauthored
fix: starship (#1742) (#1756)
(cherry picked from commit 2cda505) Co-authored-by: madomado <[email protected]>
1 parent 059ca9e commit 237bd5a

File tree

2 files changed

+15
-10
lines changed

2 files changed

+15
-10
lines changed

anda/langs/rust/starship/rust-starship.spec

+11-6
Original file line numberDiff line numberDiff line change
@@ -1,11 +1,12 @@
1+
%global build_rustflags %build_rustflags -C link-arg=-fuse-ld=mold
12
# Generated by rust2rpm 26
2-
#bcond_without check
3+
#cond_without check
34

45
%global crate starship
56

67
Name: rust-starship
78
Version: 1.20.1
8-
Release: 1%?dist
9+
Release: %autorelease
910
Summary: Minimal, blazing-fast, and infinitely customizable prompt for any shell! ☄🌌️
1011

1112
License: ISC
@@ -17,7 +18,7 @@ Patch: starship-fix-metadata-auto.diff
1718
BuildRequires: cargo-rpm-macros >= 24
1819
BuildRequires: anda-srpm-macros
1920
BuildRequires: cmake
20-
BuildRequires: pkgconfig
21+
BuildRequires: mold
2122
BuildRequires: git-core
2223

2324
%global _description %{expand:
@@ -28,13 +29,13 @@ shell! ☄🌌️.}
2829

2930
%package -n %{crate}
3031
Summary: %{summary}
31-
License: ISC
32+
License: ((Apache-2.0 OR MIT) AND BSD-3-Clause) AND (0BSD OR MIT OR Apache-2.0) AND Apache-2.0 AND (Apache-2.0 OR BSL-1.0) AND (Apache-2.0 OR MIT) AND (Apache-2.0 WITH LLVM-exception OR Apache-2.0 OR MIT) AND (BSD-2-Clause OR Apache-2.0 OR MIT) AND (BSD-2-Clause OR MIT OR Apache-2.0) AND BSD-3-Clause AND (CC0-1.0 OR MIT-0 OR Apache-2.0) AND ISC AND MIT AND (MIT AND Apache-2.0) AND (MIT OR Apache-2.0) AND (MIT OR Apache-2.0 OR Zlib) AND (MIT OR Zlib OR Apache-2.0) AND MPL-2.0 AND Unlicense AND (Unlicense OR MIT) AND Zlib AND (Zlib OR Apache-2.0 OR MIT)
3233

3334
%description -n %{crate} %{_description}
3435

3536
%files -n %{crate}
3637
%license LICENSE
37-
#license LICENSE.dependencies
38+
%license LICENSE.dependencies
3839
%doc README.md
3940
%{_bindir}/starship
4041

@@ -48,6 +49,8 @@ This package contains library source intended for building other packages which
4849
use the "%{crate}" crate.
4950

5051
%files devel
52+
%license %{crate_instdir}/LICENSE
53+
%doc %{crate_instdir}/README.md
5154
%{crate_instdir}/
5255

5356
%package -n %{name}+default-devel
@@ -175,7 +178,9 @@ use the "starship-battery" feature of the "%{crate}" crate.
175178
%cargo_prep_online
176179

177180
%build
178-
%cargo_build
181+
%dnl %cargo_build
182+
%{cargo_license_summary_online}
183+
%{cargo_license_online} > LICENSE.dependencies
179184

180185
%install
181186
%cargo_install

anda/langs/rust/starship/starship-fix-metadata-auto.diff

+4-4
Original file line numberDiff line numberDiff line change
@@ -1,14 +1,14 @@
1-
--- starship-1.19.0/Cargo.toml 1970-01-01T00:00:01+00:00
2-
+++ starship-1.19.0/Cargo.toml 2024-05-16T10:47:19.540098+00:00
3-
@@ -263,18 +263,3 @@
1+
--- starship-1.20.1/Cargo.toml 1970-01-01T00:00:01+00:00
2+
+++ starship-1.20.1/Cargo.toml 2024-07-28T16:46:48.656009+00:00
3+
@@ -271,18 +271,3 @@
44
]
55
default-features = false
66

77
-[target."cfg(windows)".dependencies.deelevate]
88
-version = "0.2.0"
99
-
1010
-[target."cfg(windows)".dependencies.windows]
11-
-version = "0.56.0"
11+
-version = "0.58.0"
1212
-features = [
1313
- "Win32_Foundation",
1414
- "Win32_UI_Shell",

0 commit comments

Comments
 (0)