-
-
Notifications
You must be signed in to change notification settings - Fork 25
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Browse files
Browse the repository at this point in the history
(cherry picked from commit 28f53f3) Co-authored-by: madomado <[email protected]>
- Loading branch information
Showing
3 changed files
with
55 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,8 @@ | ||
project pkg { | ||
rpm { | ||
spec = "gamescope-session-steam.spec" | ||
} | ||
labels { | ||
nightly = 1 | ||
} | ||
} |
40 changes: 40 additions & 0 deletions
40
anda/games/gamescope-session-steam/gamescope-session-steam.spec
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,40 @@ | ||
%define debug_package %nil | ||
|
||
%global commit 015e09825d4f9a2dfdbc20fc2711e2dcee2af68a | ||
%global shortcommit %(c=%{commit}; echo ${c:0:7}) | ||
%global commit_date 20240719 | ||
|
||
Name: gamescope-session-steam | ||
Version: %commit_date.%shortcommit | ||
Release: 1%?dist | ||
Summary: gamescope-session-steam | ||
License: MIT | ||
URL: https://github.com/ChimeraOS/gamescope-session-steam | ||
Source0: %url/archive/%commit.tar.gz | ||
|
||
%description | ||
%summary. | ||
|
||
%prep | ||
%autosetup -n %name-%commit | ||
|
||
%build | ||
|
||
%install | ||
mkdir -p %buildroot | ||
cp -r usr %buildroot/ | ||
|
||
%files | ||
%license LICENSE | ||
%_bindir/steamos-polkit-helpers/ | ||
%_bindir/jupiter-biosupdate | ||
%_bindir/steam-http-loader | ||
%_bindir/steamos-select-branch | ||
%_bindir/steamos-session-select | ||
%_bindir/steamos-update | ||
%_datadir/applications/gamescope-mimeapps.list | ||
%_datadir/applications/steam_http_loader.desktop | ||
%_datadir/gamescope-session-plus/sessions.d/steam | ||
%_datadir/polkit-1/actions/org.chimeraos.update.policy | ||
%_datadir/wayland-sessions/gamescope-session-steam.desktop | ||
%_datadir/wayland-sessions/gamescope-session.desktop |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,7 @@ | ||
if filters.contains("nightly") { | ||
rpm.global("commit", gh_commit("ChimeraOS/gamescope-session-steam")); | ||
if rpm.changed() { | ||
rpm.release(); | ||
rpm.global("commit_date", date()); | ||
} | ||
} |