-
-
Notifications
You must be signed in to change notification settings - Fork 25
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
- Loading branch information
Showing
3 changed files
with
55 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,8 @@ | ||
project pkg { | ||
rpm { | ||
spec = "stardust-comet.spec" | ||
} | ||
labels { | ||
nightly = 1 | ||
} | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,40 @@ | ||
%global commit afbf6109398794791ffb30317712d742143fd08a | ||
%global commit_date 20240831 | ||
%global shortcommit %(c=%{commit}; echo ${c:0:7}) | ||
%global debug_package %{nil} | ||
%define __os_install_post %{nil} | ||
|
||
Name: stardust-comet | ||
Version: %commit_date.%shortcommit | ||
Release: 1%?dist | ||
Summary: Annotate things in Stardust. | ||
URL: https://github.com/StardustXR/comet | ||
Source0: https://github.com/StardustXR/comet/archive/%commit/comet-%commit.tar.gz | ||
License: MIT | ||
BuildRequires: cargo cmake anda-srpm-macros cargo-rpm-macros mold | ||
Requires: libgcc glibc | ||
|
||
Provides: comet | ||
Conflicts: comet | ||
|
||
%description | ||
Annotate things in Stardust | ||
|
||
%prep | ||
%autosetup -n comet-%commit | ||
%cargo_prep_online | ||
|
||
%build | ||
%cargo_build | ||
|
||
%install | ||
%cargo_install | ||
|
||
%files | ||
%_bindir/comet | ||
%license LICENSE | ||
%doc README.md | ||
|
||
%changelog | ||
* Sat Sep 7 2024 Owen-sz <[email protected]> | ||
- Package StardustXR comet |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,7 @@ | ||
if filters.contains("nightly") { | ||
rpm.global("commit", gh_commit("StardustXR/comet")); | ||
if rpm.changed() { | ||
rpm.release(); | ||
rpm.global("commit_date", date()); | ||
} | ||
} |