Skip to content

Commit

Permalink
fix(update): zed-preview (#1935)
Browse files Browse the repository at this point in the history
* fix(update): zed-preview

Signed-off-by: madomado <[email protected]>

* fix spec

Signed-off-by: madomado <[email protected]>

* Update zed-preview.spec

Signed-off-by: madomado <[email protected]>

* yeah just don't remove -pre then

Signed-off-by: madomado <[email protected]>

* other tidying

Signed-off-by: madomado <[email protected]>

* oopsie

Signed-off-by: madomado <[email protected]>

---------

Signed-off-by: madomado <[email protected]>
  • Loading branch information
madonuko authored Aug 18, 2024
1 parent d07757e commit 6759bdf
Show file tree
Hide file tree
Showing 2 changed files with 4 additions and 5 deletions.
1 change: 0 additions & 1 deletion anda/devs/zed/preview/update.rhai
Original file line number Diff line number Diff line change
@@ -1,7 +1,6 @@
let releases = "https://api.github.com/repos/zed-industries/zed/releases".get().json_arr();
for release in releases {
let tag = release.tag_name;
tag.pop(4); // remove the "-pre" suffix
tag.crop(1); // remove "v"
rpm.global("ver", tag);
break;
Expand Down
8 changes: 4 additions & 4 deletions anda/devs/zed/preview/zed-preview.spec
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
%bcond_with check

%global ver 0.149.1
%global ver 0.149.1-pre
# Exclude input files from mangling
%global __brp_mangle_shebangs_exclude_from ^/usr/src/.*$
# Use Mold as the linker
Expand All @@ -10,13 +10,13 @@
%global app_id dev.zed.Zed-Preview

Name: zed-preview
Version: %ver
Version: %(echo %ver | sed 's/-/~/')
Release: pre1%?dist
Summary: Zed is a high-performance, multiplayer code editor

License: MIT
URL: https://zed.dev/
Source0: https://github.com/zed-industries/zed/archive/refs/tags/v%{ver}-pre.tar.gz
Source0: https://github.com/zed-industries/zed/archive/refs/tags/v%{ver}.tar.gz

Conflicts: zed
Provides: zed
Expand Down Expand Up @@ -44,7 +44,7 @@ BuildRequires: vulkan-loader
Code at the speed of thought - Zed is a high-performance, multiplayer code editor from the creators of Atom and Tree-sitter.

%prep
%autosetup -n %{crate}-%{ver}-pre -p1
%autosetup -n %{crate}-%{ver} -p1
%cargo_prep_online

export DO_STARTUP_NOTIFY="true"
Expand Down

0 comments on commit 6759bdf

Please sign in to comment.