Skip to content

Commit 81708d8

Browse files
Add klassy (#1059) (#1063)
* Create klassy.spec Signed-off-by: Dipta Biswas <[email protected]> * Create anda.hcl for klassy Signed-off-by: Dipta Biswas <[email protected]> * Create update.rhai for klassy Signed-off-by: Dipta Biswas <[email protected]> --------- Signed-off-by: Dipta Biswas <[email protected]> (cherry picked from commit d52c2ed) Co-authored-by: Dipta Biswas <[email protected]>
1 parent 28db2a2 commit 81708d8

File tree

3 files changed

+134
-0
lines changed

3 files changed

+134
-0
lines changed

anda/themes/klassy/anda.hcl

+6
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,6 @@
1+
project "pkg" {
2+
arches = ["x86_64", "aarch64"]
3+
rpm {
4+
spec = "klassy.spec"
5+
}
6+
}

anda/themes/klassy/klassy.spec

+123
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,123 @@
1+
Name: klassy
2+
3+
%global forgeurl https://github.com/paulmcauley/%{name}
4+
%global tag 6.0.breeze6.0.2
5+
%global date 20240314
6+
%forgemeta
7+
8+
Version: %{tag}
9+
Release: %autorelease
10+
Summary: Window Decoration, Application Style and Global Theme plugin for recent versions of the KDE Plasma desktop.
11+
License: GPL-2.0-or-later
12+
Group: System/GUI/KDE
13+
URL: %{forgeurl}
14+
Source: %{forgesource}
15+
16+
Obsoletes: classikstyles <= %{version}
17+
Obsoletes: classik <= %{version}
18+
19+
BuildRequires: cmake >= 3.16
20+
BuildRequires: extra-cmake-modules >= 5.102.0
21+
22+
BuildRequires: kf5-rpm-macros
23+
BuildRequires: kf5-filesystem
24+
25+
BuildRequires: kf6-rpm-macros
26+
BuildRequires: kf6-filesystem
27+
28+
BuildRequires: cmake(Qt5Widgets)
29+
BuildRequires: cmake(Qt5DBus)
30+
BuildRequires: cmake(Qt5Quick)
31+
BuildRequires: cmake(Qt5X11Extras)
32+
33+
BuildRequires: cmake(Qt6Core)
34+
BuildRequires: cmake(Qt6Gui)
35+
BuildRequires: cmake(Qt6Widgets)
36+
BuildRequires: cmake(Qt6DBus)
37+
BuildRequires: cmake(Qt6Quick)
38+
BuildRequires: cmake(Qt6Svg)
39+
BuildRequires: cmake(Qt6Xml)
40+
41+
BuildRequires: cmake(KF5CoreAddons)
42+
BuildRequires: cmake(KF5Config)
43+
BuildRequires: cmake(KF5ConfigWidgets)
44+
BuildRequires: cmake(KF5FrameworkIntegration)
45+
BuildRequires: cmake(KF5GuiAddons)
46+
BuildRequires: cmake(KF5I18n)
47+
BuildRequires: cmake(KF5IconThemes)
48+
BuildRequires: cmake(KF5KCMUtils)
49+
BuildRequires: cmake(KF5Kirigami2)
50+
BuildRequires: cmake(KF5Package)
51+
BuildRequires: cmake(KF5Plasma)
52+
BuildRequires: cmake(KF5Wayland)
53+
BuildRequires: cmake(KF5WindowSystem)
54+
55+
BuildRequires: cmake(KF6CoreAddons)
56+
BuildRequires: cmake(KF6ColorScheme)
57+
BuildRequires: cmake(KF6Config)
58+
BuildRequires: cmake(KF6ConfigWidgets)
59+
BuildRequires: cmake(KF6FrameworkIntegration)
60+
BuildRequires: cmake(KF6GuiAddons)
61+
BuildRequires: cmake(KF6I18n)
62+
BuildRequires: cmake(KF6IconThemes)
63+
BuildRequires: cmake(KF6KCMUtils)
64+
BuildRequires: cmake(KF6KirigamiPlatform)
65+
BuildRequires: cmake(KF6Package)
66+
BuildRequires: cmake(KF6WindowSystem)
67+
68+
BuildRequires: cmake(KDecoration2)
69+
BuildRequires: cmake(Plasma)
70+
BuildRequires: cmake(Plasma5Support)
71+
72+
BuildRequires: pkgconfig(x11-xcb)
73+
BuildRequires: pkgconfig(xcb)
74+
75+
%description
76+
Klassy (formerly ClassiK/ClassikStyles) is a highly customizable binary Window Decoration, Application Style and Global Theme plugin for recent versions of the KDE Plasma desktop. Initially taking inspiration from the iconography of KDE 1, the Klassy defaults are an attempt to create a usable and appealing look for the modern Plasma desktop.
77+
78+
%prep
79+
%forgeautosetup -p1
80+
81+
%build
82+
%cmake
83+
%cmake_build
84+
85+
%install
86+
%cmake_install
87+
88+
%files
89+
%license LICENSES/*.txt
90+
91+
%{_bindir}/%{name}-settings
92+
93+
%{_libdir}/cmake/Klassy/
94+
95+
%{_libdir}/libklassycommon5.so.*
96+
%{_libdir}/libklassycommon6.so.*
97+
98+
%{_kf5_qtplugindir}/styles/klassy5.so
99+
%{_kf6_qtplugindir}/styles/klassy6.so
100+
101+
%{_kf6_qtplugindir}/kstyle_config/klassystyleconfig.so
102+
%{_kf6_qtplugindir}/org.kde.kdecoration2/org.kde.klassy.so
103+
%{_kf6_qtplugindir}/org.kde.kdecoration2.kcm/kcm_klassydecoration.so
104+
%{_kf6_qtplugindir}/org.kde.kdecoration2.kcm/klassydecoration/presets/
105+
106+
%{_kf6_datadir}/applications/kcm_klassydecoration.desktop
107+
%{_kf6_datadir}/applications/klassystyleconfig.desktop
108+
%{_kf6_datadir}/applications/klassy-settings.desktop
109+
110+
%{_kf6_datadir}/color-schemes/Klassy*.colors
111+
112+
%{_datadir}/icons/hicolor/
113+
%{_datadir}/icons/%{name}/
114+
%{_datadir}/icons/%{name}-dark/
115+
116+
%{_kf6_datadir}/kstyle/themes/%{name}.themerc
117+
118+
%{_kf6_datadir}/plasma/layout-templates/org.kde.klassy.*
119+
%{_kf6_datadir}/plasma/look-and-feel/org.kde.klassy*
120+
121+
%changelog
122+
%autochangelog
123+

anda/themes/klassy/update.rhai

+5
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,5 @@
1+
rpm.global("tag", gh("paulmcauley/klassy"));
2+
if rpm.changed() {
3+
rpm.global("date", date()); // remove if we don't need the `date` macro
4+
rpm.release();
5+
}

0 commit comments

Comments
 (0)