From c14dabec55db4257f1de65a19529556910e3fc4e Mon Sep 17 00:00:00 2001
From: madomado <madonuko@outlook.com>
Date: Thu, 16 May 2024 21:01:23 +0800
Subject: [PATCH] add: tuxclocker

---
 anda/apps/tuxclocker/anda.hcl        |  5 ++++
 anda/apps/tuxclocker/tuxclocker.spec | 42 ++++++++++++++++++++++++++++
 anda/apps/tuxclocker/update.rhai     |  1 +
 3 files changed, 48 insertions(+)
 create mode 100644 anda/apps/tuxclocker/anda.hcl
 create mode 100644 anda/apps/tuxclocker/tuxclocker.spec
 create mode 100644 anda/apps/tuxclocker/update.rhai

diff --git a/anda/apps/tuxclocker/anda.hcl b/anda/apps/tuxclocker/anda.hcl
new file mode 100644
index 0000000000..9989eae358
--- /dev/null
+++ b/anda/apps/tuxclocker/anda.hcl
@@ -0,0 +1,5 @@
+project pkg {
+  rpm {
+    spec = "tuxclocker.spec"
+  }
+}
diff --git a/anda/apps/tuxclocker/tuxclocker.spec b/anda/apps/tuxclocker/tuxclocker.spec
new file mode 100644
index 0000000000..94a0d2d3e2
--- /dev/null
+++ b/anda/apps/tuxclocker/tuxclocker.spec
@@ -0,0 +1,42 @@
+Name:           tuxclocker
+Version:        1.5.1
+Release:        1%?dist
+Summary:        Qt overclocking tool for GNU/Linux 
+License:        GPL-3.0
+URL:            https://github.com/Lurkki14/tuxclocker
+# boost qt5-qtbase qt5-qtcharts
+Requires:       hicolor-icon-theme
+BuildRequires:  git-core meson hwdata qt5-qttools gettext anda-srpm-macros
+BuildRequires:  boost-devel qt5-qtbase-devel qt5-qtcharts-devel libdrm-devel libXNVCtrl-devel openssl-devel
+Recommends:     xorg-x11-drv-nvidia libdrm libXNVCtrl hwdata
+
+%description
+TuxClocker is a hardware controlling and monitoring program.
+TuxClocker consists of a DBus daemon and a Qt GUI that uses the daemon.
+
+%prep
+git clone --recursive %url .
+git checkout %version
+
+%build
+%meson
+%meson_build
+
+%install
+%meson_install
+
+%files
+%doc README.md
+%license LICENSE
+%_bindir/tuxclocker-qt
+%_bindir/tuxclockerd
+%_libdir/libtuxclocker.so
+%_libdir/tuxclocker/
+%_datadir/applications/tuxclocker.desktop
+%_datadir/dbus-1/system-services/org.tuxclocker.service
+%_datadir/dbus-1/system.d/org.tuxclocker.conf
+%_datadir/locale/*/LC_MESSAGES/tuxclocker.mo
+%_iconsdir/hicolor/scalable/apps/tuxclocker-logo.svg
+
+%changelog
+%autochangelog
diff --git a/anda/apps/tuxclocker/update.rhai b/anda/apps/tuxclocker/update.rhai
new file mode 100644
index 0000000000..c9c48ad0cf
--- /dev/null
+++ b/anda/apps/tuxclocker/update.rhai
@@ -0,0 +1 @@
+rpm.version(gh("Lurkki14/tuxclocker"));