Skip to content

Commit

Permalink
Update kirkstone to 2024.6.0 release (#33)
Browse files Browse the repository at this point in the history
* Update EVerest to 2024.6.0
* Only symlink poetry when it does not exist already
* Fix naming of everestpy.so on target

---------

Signed-off-by: Kai-Uwe Hermann <[email protected]>
  • Loading branch information
hikinggrass authored Jul 16, 2024
1 parent b7bf224 commit f927393
Show file tree
Hide file tree
Showing 9 changed files with 65 additions and 31 deletions.
2 changes: 1 addition & 1 deletion recipes-backports/python/python3-poetry-core_1.4.0.bb
Original file line number Diff line number Diff line change
Expand Up @@ -29,7 +29,7 @@ S = "${WORKDIR}/poetry_core-${PV}"

# FIXME (aw): because in kirkstone poetry install itself by using itself
do_compile:prepend () {
ln -s ${S}/src/poetry ${S}/poetry
test -L ${S}/poetry || ln -s ${S}/src/poetry ${S}/poetry
}

SRC_URI += "file://deterministic.patch"
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"

SRC_URI = "git://github.com/EVerest/everest-utils.git;branch=main;protocol=https"

SRCREV = "425bec953e1fe61a5260fbf83d4bfadf90412996"
SRCREV = "dc09ddf8b21987311eaaf53e9a8f2f35e7974a49"

S = "${WORKDIR}/git"

Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -3,12 +3,13 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"

SRC_URI = "git://github.com/EVerest/everest-cmake.git;branch=main;protocol=https"

SRCREV = "089c1da9697a9118b8d3fc932e3a2cba3873b85a"
SRCREV = "4805f09542e58f4d17202277527d6326fbcd27c3"

S = "${WORKDIR}/git"

do_install() {
install -d ${D}/usr/lib/cmake/everest-cmake
cp -a --no-preserve=ownership ${S}/*.cmake ${D}/usr/lib/cmake/everest-cmake/
cp -a --no-preserve=ownership ${S}/3rd_party ${D}/usr/lib/cmake/everest-cmake/
cp -a --no-preserve=ownership ${S}/assets ${D}/usr/lib/cmake/everest-cmake/
}
Original file line number Diff line number Diff line change
@@ -1,17 +1,17 @@
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"

SRC_URI = "git://github.com/EVerest/everest-core.git;branch=main;protocol=https \
SRC_URI = "git://github.com/EVerest/everest-core.git;branch=release/2024.6.0;protocol=https \
file://everest.service \
"

S = "${WORKDIR}/git"

SRCREV = "1f9433d9720fed232b8e4df321eaeb33a6baa04f"
SRCREV = "e9d8f3912d9e834823c8ce6776148a8490a29f54"

do_compile[network] = "1"

inherit cmake pkgconfig systemd
inherit cmake pkgconfig systemd python3native

DEPENDS = " \
everest-cmake \
Expand All @@ -30,19 +30,26 @@ DEPENDS = " \
libslac \
libevent \
libevse-security \
libcbv2g \
mbedtls \
openv2g \
curl \
sqlitecpp \
"

RDEPENDS:${PN} += "openv2g libevent mbedtls"
RDEPENDS:${PN} += "libevent mbedtls"

INSANE_SKIP:${PN} = "already-stripped useless-rpaths arch file-rdeps"

FILES:${PN} += "${datadir}/everest/*"

EXTRA_OECMAKE += "-DDISABLE_EDM=ON -DNO_FETCH_CONTENT=ON -DEVEREST_ENABLE_RUN_SCRIPT_GENERATION=OFF"
EXTRA_OECMAKE += " \
-DDISABLE_EDM=ON \
-DNO_FETCH_CONTENT=ON \
-DEVEREST_ENABLE_RUN_SCRIPT_GENERATION=OFF \
-Deverest-core_INSTALL_EV_CLI_IN_PYTHON_VENV=OFF \
-Deverest-core_USE_PYTHON_VENV=OFF \
-DEV_SETUP_PYTHON_EXECUTABLE_USE_PYTHON_VENV=OFF \
"

SYSTEMD_SERVICE:${PN} = "everest.service"

Expand Down
Original file line number Diff line number Diff line change
@@ -0,0 +1,23 @@
From a1e233f076b1578f028b2d23b672d9c1195683c3 Mon Sep 17 00:00:00 2001
From: Kai-Uwe Hermann <[email protected]>
Date: Tue, 9 Jul 2024 14:46:00 +0200
Subject: [PATCH] Set PYTHON_MODULE_EXTENSION to .so to avoid polluting it with
host arch

Signed-off-by: Kai-Uwe Hermann <[email protected]>
---
CMakeLists.txt | 1 +
1 file changed, 1 insertion(+)

diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9c0b86c..da8678d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -121,6 +121,7 @@ endif()

# everest python wrapper
if (EVEREST_ENABLE_PY_SUPPORT)
+ set(PYTHON_MODULE_EXTENSION ".so")
add_subdirectory(everestpy)
endif()

Original file line number Diff line number Diff line change
@@ -1,16 +1,17 @@
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"

SRC_URI = "git://github.com/EVerest/everest-framework.git;branch=main;protocol=https"
SRC_URI = "git://github.com/EVerest/everest-framework.git;branch=main;protocol=https \
file://0001-Set-PYTHON_MODULE_EXTENSION-to-.so-to-avoid-pollutin.patch \
"

inherit python3native
inherit cmake
inherit pkgconfig

S = "${WORKDIR}/git"

# tag v0.14.0
SRCREV = "1f8bce3405a5bf38d55ac3048de8346054bf5398"
SRCREV = "06a22c26d52e92f97d199f063801413b7f3ee206"

# FIXME (aw): due to nodejs dependency
do_configure[network] = "1"
Expand Down
20 changes: 20 additions & 0 deletions recipes-core/everest/libcbv2g_0.2.0.bb
Original file line number Diff line number Diff line change
@@ -0,0 +1,20 @@
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"

SRC_URI = "git://github.com/EVerest/libcbv2g.git;branch=main;protocol=https \
"

inherit cmake

S = "${WORKDIR}/git"

# tag 0.2.0
SRCREV = "ec437e6060e30bfa2850139c87a10c3f61f546a0"

DEPENDS = "\
everest-cmake \
"

# FILES:${PN} += "${datadir}/everest/*"

EXTRA_OECMAKE += "-DDISABLE_EDM=ON -DCB_V2G_INSTALL=ON -DCB_V2G_BUILD_TESTS=OFF"
Original file line number Diff line number Diff line change
Expand Up @@ -8,8 +8,7 @@ inherit cmake

S = "${WORKDIR}/git"

# tag 0.12.0
SRCREV = "9a19d29bd780d65c3ff15951427bf53e8fe33b88"
SRCREV = "10e194b4c83b510ade985ef4ef53a5683d079773"

DEPENDS = "\
everest-cmake \
Expand Down
17 changes: 0 additions & 17 deletions recipes-core/openv2g/openv2g_2023.3.0.bb

This file was deleted.

0 comments on commit f927393

Please sign in to comment.