-
Notifications
You must be signed in to change notification settings - Fork 12
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
refactor: optimising state manager and wasm runtime module (#111)
* refactor: remove unwanted methods inside ssb client and clear clippy warnings * fix: create new type `Event` to use in publish event method and pass missing fields * chore: add state manager to the context & optimize wasm runtime and state manager * refactor: fix spelling mistakes, format Cargo.toml and remove unwanted files * chore: remove all print statements and log instead * fix: change corestorage db name in consumer to fix conflicts * chore: remove event type in ssb client publish event * fix: remove unwanted comments * fix: remove duplicate dependencies * chore: fix locking issue while running workflow * chore: remove all hardcoded values and create constant value * fix: remove unwanted spaces * fix: change the consumer implementation to sync first before waiting for invite
- Loading branch information
1 parent
4539344
commit ae4427e
Showing
18 changed files
with
389 additions
and
405 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,11 @@ | ||
|
||
pub const FOLLOW_LIST_KEY: &str = "follow_list"; | ||
pub const FOLLOW_LIST_KEY: &str = "follow_list"; | ||
pub const HTTP_SERVER_ADDRESS: &str = "127.0.0.1:8080"; | ||
pub const DEFAULT_CONSUMER_IP: &str = "0.0.0.0"; | ||
pub const DEFAULT_PRODUCER_IP: &str = "0.0.0.0"; | ||
pub const DEFAULT_PUB_IP: &str = "0.0.0.0"; | ||
pub const DEFAULT_PUB_PORT: &str = "8013"; | ||
pub const DEFAULT_CONSUMER_PORT: &str = "8014"; | ||
pub const DEFAULT_PRODUCER_PORT: &str = "8015"; | ||
pub const DEFAULT_CONSUMER_SECRET_DIR: &str = "scripts/secret/consumer_secret"; | ||
pub const DEFAULT_PRODUCER_SECRET_DIR: &str = "scripts/secret/producer_secret"; | ||
pub const DEFAULT_PUB_SECRET_DIR: &str = "scripts/secret/pubs_secret"; |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Oops, something went wrong.