Skip to content

Commit

Permalink
Merge branch 'openwrt-22.03' of https://github.com/openwrt/packages i…
Browse files Browse the repository at this point in the history
…nto 22.03
  • Loading branch information
Lienol committed Mar 14, 2024
2 parents b4e3da2 + e4958a3 commit 3a1837f
Show file tree
Hide file tree
Showing 17 changed files with 55 additions and 302 deletions.
6 changes: 3 additions & 3 deletions admin/syslog-ng/Makefile
Original file line number Diff line number Diff line change
@@ -1,8 +1,8 @@
include $(TOPDIR)/rules.mk

PKG_NAME:=syslog-ng
PKG_VERSION:=4.4.0
PKG_RELEASE:=$(AUTORELEASE)
PKG_VERSION:=4.6.0
PKG_RELEASE:=1

PKG_MAINTAINER:=Josef Schlehofer <[email protected]>
PKG_LICENSE:=LGPL-2.1-or-later GPL-2.0-or-later
Expand All @@ -11,7 +11,7 @@ PKG_CPE_ID:=cpe:/a:balabit:syslog-ng

PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/syslog-ng/syslog-ng/releases/download/$(PKG_NAME)-$(PKG_VERSION)/
PKG_HASH:=583b147f3ec17fbc2dbbf31aafb1e3966237d7541313de5b41ea885dc16d932e
PKG_HASH:=b69e3360dfb96a754a4e1cbead4daef37128b1152a23572356db4ab64a475d4f

PKG_BUILD_PARALLEL:=1
PKG_INSTALL:=1
Expand Down
19 changes: 7 additions & 12 deletions admin/syslog-ng/files/syslog-ng.conf
Original file line number Diff line number Diff line change
@@ -1,10 +1,7 @@
#############################################################################
# OpenWrt syslog-ng.conf specific file
# which collects all local logs into a single file called /var/log/messages.
# More details about these settings can be found here:
# https://www.syslog-ng.com/technical-documents/list/syslog-ng-open-source-edition
# Collect all local logs into a single file /var/log/messages.
# See https://www.syslog-ng.com/technical-documents/list/syslog-ng-open-source-edition

@version: 4.4
@version: 4.6
@include "scl.conf"

options {
Expand All @@ -13,7 +10,7 @@ options {
keep_hostname(yes); # Enable or disable hostname rewriting.
log_fifo_size(256); # The number of messages that the output queue can store.
log_msg_size(1024); # Maximum length of a message in bytes.
stats_freq(0); # The period between two STATS messages (sent by syslog-ng, containing statistics about dropped logs) in seconds.
stats(freq(0)); # The period between two STATS messages (sent by syslog-ng, containing statistics about dropped logs) in seconds.
flush_lines(0); # How many lines are flushed to a destination at a time.
use_fqdn(no); # Add Fully Qualified Domain Name instead of short hostname.
};
Expand Down Expand Up @@ -43,7 +40,7 @@ source s_network {
};

source kernel {
file("/proc/kmsg" program_override("kernel"));
file("/proc/kmsg" program_override("kernel"));
};

destination messages {
Expand All @@ -53,15 +50,13 @@ destination messages {
log {
source(src);
source(net);
source(kernel);
source(kernel);
destination(messages);

# uncomment this line to open port 514 to receive messages
#source(s_network);
};

#
# Finally, include any user settings last so that s/he can override or
# Include any user settings last so that s/he can override or
# supplement all "canned" settings inherited from the distribution.
#
@include "/etc/syslog-ng.d/" # Put any customization files in this directory
6 changes: 3 additions & 3 deletions net/apfree-wifidog/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -8,13 +8,13 @@
include $(TOPDIR)/rules.mk

PKG_NAME:=apfree-wifidog
PKG_VERSION:=6.08.1950
PKG_VERSION:=7.02.1977
PKG_RELEASE:=1

PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/liudf0716/apfree-wifidog.git
PKG_SOURCE_VERSION:=$(PKG_VERSION)
PKG_MIRROR_HASH:=1fb8f80970b29e7af382c6d35cb23ee6eb932483579ce9497e21ce0fb65a381f
PKG_MIRROR_HASH:=f43786523099f90c46c4e7bf99b4bb3c705113939f5348f7136a13b346aed529

PKG_MAINTAINER:=Dengfeng Liu <[email protected]>
PKG_LICENSE:=GPL-3.0-or-later
Expand All @@ -27,7 +27,7 @@ define Package/apfree-wifidog
SUBMENU:=Captive Portals
SECTION:=net
CATEGORY:=Network
DEPENDS:=+zlib +libjson-c +libevent2 +libevent2-openssl +libuci
DEPENDS:=+zlib +libjson-c +libevent2 +libevent2-openssl +libuci +openssl-util +libnetfilter-queue
TITLE:=Apfree's wireless captive portal solution
URL:=https://github.com/liudf0716/apfree_wifidog
endef
Expand Down
51 changes: 27 additions & 24 deletions net/apfree-wifidog/files/wifidogx.init
Original file line number Diff line number Diff line change
@@ -1,52 +1,53 @@
#!/bin/sh /etc/rc.common
# Copyright (C) 2018 Dengfeng Liu

. /lib/functions/network.sh

START=99

USE_PROCD=1
NAME=wifidogx
PROG=/usr/bin/${NAME}
CONFIGFILE=/tmp/wifidogx.conf

service_trigger() {
procd_add_reload_trigger ${NAME}
}

prepare_wifidog_conf() {

[ -f ${CONFIGFILE} ] && rm -f ${CONFIGFILE}

network_get_device external_interface wan

uci_validate_section ${NAME} ${NAME} common \
'enabled:bool:0' \
'gateway_id:string' \
'gateway_interface:string:br-lan' \
'external_interface:string:external_interface' \
'auth_server_hostname:string' \
'auth_server_port:port:443' \
'auth_server_path:string:/wifidog/' \
'check_interval:integer:60' \
'client_timeout:integer:5' \
'js_filter:bool:1' \
'wired_passed:bool:1' \
'apple_cna:bool:0' \
'channel_path:string' \
'trusted_domains:string' \
'trusted_macs:string' \
'js_filter:bool:1'

# if gateway_id is not set, get it from br-lan
if [ -z "$gateway_id" ]; then
gateway_id=$(sed -e 's/://g' /sys/class/net/${gateway_interface}/address)
# convert to upper case
gateway_id=$(echo $gateway_id | tr '[a-z]' '[A-Z]')
# uci add gateway_id to config file
uci set ${NAME}.common.gateway_id=$gateway_id
uci commit ${NAME}
fi

# if channel_path is not set, set it to apfree
if [ -z "$channel_path" ]; then
channel_path=apfree
uci set ${NAME}.common.channel_path=$channel_path
uci commit ${NAME}
fi

# set above variables to config file
echo "GatewayID $gateway_id" > ${CONFIGFILE}
echo "GatewayInterface $gateway_interface" >> ${CONFIGFILE}
echo "ExternalInterface $external_interface" >> ${CONFIGFILE}
echo "AuthServer {
Hostname $auth_server_hostname
HTTPPort $auth_server_port
Expand All @@ -57,33 +58,31 @@ prepare_wifidog_conf() {
echo "JsFilter $js_filter" >> ${CONFIGFILE}
echo "WiredPassed $wired_passed" >> ${CONFIGFILE}
echo "BypassAppleCNA $apple_cna" >> ${CONFIGFILE}
}

init_config() {

prepare_wifidog_conf

if [ ! -f ${CONFIGFILE} ]; then
echo "no wifidogx.conf, exit..." >&2
exit
# if has trusted_domains, add it to config file
if [ ! -z "$trusted_domains" ]; then
echo "TrustedDomains $trusted_domains" >> ${CONFIGFILE}
fi
# if has trusted_macs, add it to config file
if [ ! -z "$trusted_macs" ]; then
echo "TrustedMACList $trusted_macs" >> ${CONFIGFILE}
fi
}

start_service() {
config_load $NAME

init_config
prepare_wifidog_conf

[ "$enabled" -eq 0 ] && {
echo "wifidogx is disabled, exit..." >&2
exit 0
return
}

procd_open_instance
# -f: run in foreground
procd_set_param command $PROG -c $CONFIGFILE -f -d 0
procd_set_param respawn # respawn automatically if something died
procd_set_param file $CONFIGFILE
procd_set_param file /etc/config/wifidogx
procd_close_instance
}

Expand All @@ -94,4 +93,8 @@ status_service() {
reload_service() {
stop
start
}
}

service_triggers() {
procd_add_reload_trigger "${NAME}"
}
10 changes: 5 additions & 5 deletions net/https-dns-proxy/Makefile
Original file line number Diff line number Diff line change
@@ -1,14 +1,14 @@
include $(TOPDIR)/rules.mk

PKG_NAME:=https-dns-proxy
PKG_VERSION:=2023-10-25
PKG_RELEASE:=5
PKG_VERSION:=2023-11-19
PKG_RELEASE:=1

PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/aarond10/https_dns_proxy/
PKG_SOURCE_DATE:=$(PKG_VERSION)
PKG_SOURCE_VERSION:=977341a4e35a37ee454e97e82caf4276b1b4961a
PKG_MIRROR_HASH:=8622846f1038ac05436a48d9b36a07c516cbb6504ce68e7ee8c5529788fac39b
PKG_SOURCE_VERSION:=489c57efd46983e688579974a2ab7aeaa7df8d83
PKG_MIRROR_HASH:=6c8e0e158dfbfde29b1c22f1a1c90a7deae540111c26daac13c8fbb5a49081a5

PKG_MAINTAINER:=Stan Grishin <[email protected]>
PKG_LICENSE:=MIT
Expand All @@ -24,7 +24,7 @@ define Package/https-dns-proxy
CATEGORY:=Network
TITLE:=DNS Over HTTPS Proxy
URL:=https://docs.openwrt.melmac.net/https-dns-proxy/
DEPENDS:=+libcares +libcurl +libev +ca-bundle +jsonfilter
DEPENDS:=+libcares +libcurl +libev +ca-bundle +jsonfilter +resolveip
DEPENDS+=+!BUSYBOX_DEFAULT_GREP:grep
DEPENDS+=+!BUSYBOX_DEFAULT_SED:sed
CONFLICTS:=https_dns_proxy
Expand Down
2 changes: 1 addition & 1 deletion net/https-dns-proxy/files/etc/init.d/https-dns-proxy
Original file line number Diff line number Diff line change
Expand Up @@ -135,7 +135,7 @@ boot() {
ubus -t 30 wait_for network.interface 2>/dev/null
on_boot_trigger=1
rc_procd start_service 'on_boot' && service_started 'on_boot'
is_resolver_working || { rc_procd stop_service 'on_boot' && service_stopped 'on_boot'; }
is_resolver_working || { rc_procd stop_service 'on_failed_health_check' && service_stopped 'on_failed_health_check'; }
}

start_instance() {
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -5,7 +5,7 @@
return SW_VERSION;
#else
- return "2023.10.10-atLeast"; // update date sometimes, like 1-2 times a year
+ return "2023-10-25-5"; // update date sometimes, like 1-2 times a year
+ return "2023-11-19-1"; // update date sometimes, like 1-2 times a year
#endif
}

4 changes: 2 additions & 2 deletions net/knot/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk

PKG_NAME:=knot
PKG_VERSION:=3.3.4
PKG_VERSION:=3.3.5
PKG_RELEASE:=1

PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://secure.nic.cz/files/knot-dns/
PKG_HASH:=2a771b43ce96b6b48d53b29f2086528732e6ac067bc71a3be934f859d1302fc0
PKG_HASH:=0e0bf04319581280660e8e62ab04be64a7d632331e40fc9c87e76861305db3ad

PKG_MAINTAINER:=Daniel Salzman <[email protected]>
PKG_LICENSE:=GPL-3.0 LGPL-2.0 0BSD BSD-3-Clause OLDAP-2.8
Expand Down
4 changes: 2 additions & 2 deletions net/natmap/Makefile
Original file line number Diff line number Diff line change
@@ -1,12 +1,12 @@
include $(TOPDIR)/rules.mk

PKG_NAME:=natmap
PKG_VERSION:=20240126
PKG_VERSION:=20240303
PKG_RELEASE:=1

PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/heiher/natmap/releases/download/$(PKG_VERSION)
PKG_HASH:=7d8b3fe5c29dfe30271197b8ea1f78af292830483aefb1ccc21a3ec05f74627b
PKG_HASH:=d7b7a1ba2fc8dbd471ed88757fa6fc7c7e2d83f9f44c8f62661e9809d386d163

PKG_MAINTAINER:=Richard Yu <[email protected]>, Ray Wang <[email protected]>
PKG_LICENSE:=MIT
Expand Down
57 changes: 0 additions & 57 deletions net/ntpclient/Makefile

This file was deleted.

23 changes: 0 additions & 23 deletions net/ntpclient/files/ntpclient.config

This file was deleted.

Loading

0 comments on commit 3a1837f

Please sign in to comment.