Skip to content

Commit

Permalink
www-apps/freshrss: add 1.26.0
Browse files Browse the repository at this point in the history
Signed-off-by: Anders Larsson <[email protected]>
  • Loading branch information
anders-larsson committed Feb 23, 2025
1 parent 50b124d commit 987cb9d
Show file tree
Hide file tree
Showing 2 changed files with 62 additions and 0 deletions.
2 changes: 2 additions & 0 deletions www-apps/freshrss/Manifest
Original file line number Diff line number Diff line change
@@ -1,6 +1,8 @@
DIST freshrss-1.24.3.tar.gz 4403538 BLAKE2B f944f36256c59790938588491385b91de6a8af602bdb51731c7c76c816a4536855b7ed27a5595b4f825d2b7420a58feb17a0b7b8343b198bf8ae1a5ecb8705ba SHA512 757f37fd51d63b56735c54d7ee2a5bd76c8e55b8e4d6b16767b9f99581142dd11987eb4256b114ebb012bfba93acf3d9189ca4fa9c0fbf66bdd4048d12ea8bf6
DIST freshrss-1.25.0.tar.gz 4488412 BLAKE2B b995404a2979aa2e92a03ce316f6405c3bc476daf1a0c2f9ccb6a7c2e274ff934721dca7771adee7ff7aefed0349febcc80581cdb7dbc56334c8ff72626f443f SHA512 e3882227ce422c8d1c38bcf557e29219153fc2bf2829df3ddd6c716c6ee75b6d44849f65b9a15fbdaf3542a78f11f26442893a8b561825b7b1ac8ee50ab93266
DIST freshrss-1.26.0.tar.gz 4536771 BLAKE2B 73c3886bfaf64e1e3c5205200d1aae471964390e528357e1953862e423096f8c86348b2d8d120a4b4f903b7a4947883a6e19f4710ed47ec1a88708a41c4af00e SHA512 81826c7a21640951f2778afddca767b31e05ff9c741838eca8477814444d1699388e8e4d257549cc88ca4f9d7e95971c7dd16072aff10f4f69251f3f7057d8e6
EBUILD freshrss-1.24.3.ebuild 1554 BLAKE2B 03c75c5f4f8dfa834370dc9095b5b375e69d0f7cd9ec780aa47c1899b2dfc2fdbced6c72dacea86293ec0a4bb9b1304236d60199f04f97b44a3a7a2d55cc8a55 SHA512 44387f64d84238aea7b09705292f6d444deb521bf2dd47f42e5bf56f7f0779097d4544dccc41aa37ebad6b33e22e1e68ce9898459ac2ff4fce4475388fc2ca98
EBUILD freshrss-1.25.0.ebuild 1554 BLAKE2B 03c75c5f4f8dfa834370dc9095b5b375e69d0f7cd9ec780aa47c1899b2dfc2fdbced6c72dacea86293ec0a4bb9b1304236d60199f04f97b44a3a7a2d55cc8a55 SHA512 44387f64d84238aea7b09705292f6d444deb521bf2dd47f42e5bf56f7f0779097d4544dccc41aa37ebad6b33e22e1e68ce9898459ac2ff4fce4475388fc2ca98
EBUILD freshrss-1.26.0.ebuild 1554 BLAKE2B cd016c23d0d39d3ba0c4162791b2b2db2ebe2e7849991e142411ddd6fd2a28d649baf6628ea22231b86ddb9ca67853a6d484e68bdb14712c86fc388bd1a1d1cf SHA512 7722ca27c329a28452ec24b2296db8b6024ac70f89e686cc9233242291b93ef7b30a4adb77d620a87035943ecbf91769bbe59648b5642588eb3d13a1eb1d56dc
EBUILD freshrss-9999.ebuild 1554 BLAKE2B 03c75c5f4f8dfa834370dc9095b5b375e69d0f7cd9ec780aa47c1899b2dfc2fdbced6c72dacea86293ec0a4bb9b1304236d60199f04f97b44a3a7a2d55cc8a55 SHA512 44387f64d84238aea7b09705292f6d444deb521bf2dd47f42e5bf56f7f0779097d4544dccc41aa37ebad6b33e22e1e68ce9898459ac2ff4fce4475388fc2ca98
MISC metadata.xml 569 BLAKE2B f78e94f7f98dfae2ba56af32c4f2693b7effbead51f620224e2a19dc73a6fb56ca29296bcbf87034ad3d03653dfd4d5460bcbbba4192a14437ed1c0dae0628aa SHA512 04bed1f4fc1b60bfe8de05889027142926f1c813ef7ef3c64978acf381263662b76a5587ce5172c818c0ac5419764af237b4c956653ab32cfdb2882476e49efb
60 changes: 60 additions & 0 deletions www-apps/freshrss/freshrss-1.26.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,60 @@
# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit webapp vcs-snapshot

if [[ ${PV} = 9999 ]]; then
inherit git-r3
fi

DESCRIPTION="FreshRSS - a free, self-hostable aggregator"
HOMEPAGE="https://freshrss.org/"
LICENSE="AGPL-3"

if [[ ${PV} = 9999 ]]; then
EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
EGIT_BOOTSTRAP=""
else
SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi

IUSE="mysql sqlite postgres +gmp +unicode +iconv +zip +zlib"

# DOM is enabled by flag xml
# XML is enabled by simplexml
# mbstring is enabled by unicode
DEPEND="
dev-lang/php[curl,xml,simplexml,session,ctype,pdo,mysql?,sqlite?,postgres?,gmp?,unicode?,iconv?,zip?,zlib?]
virtual/httpd-php:*
"

RDEPEND="${DEPEND}"

need_httpd_cgi # From webapp.eclass

src_install() {
webapp_src_preinst

# freshrss 1.21.0 and newer checks if it can write to index.html in several
# directories. Every time webapp-config runs it reinstalls these files with
# the webserver user as their owner. RSS feed refresh script fails to run
# if PHP user cannot write to the required files causing the refresh to fail.
# Introduced by https://github.com/FreshRSS/FreshRSS/pull/4780.
for file in \
data/index.html \
data/cache/index.html \
data/users/index.html \
data/favicons/index.html \
data/tokens/index.html; do
rm -f $file
done

insinto "/${MY_HTDOCSDIR}"
doins -r *

webapp_serverowned -R "${MY_HTDOCSDIR}/data"
webapp_src_install
}

0 comments on commit 987cb9d

Please sign in to comment.