Skip to content

Commit

Permalink
Merge branch 'openwrt:main' into mx4300-dev
Browse files Browse the repository at this point in the history
  • Loading branch information
arix00 authored Oct 25, 2024
2 parents 5e79e77 + d7ed4c7 commit 464f60e
Show file tree
Hide file tree
Showing 131 changed files with 307 additions and 410 deletions.
4 changes: 2 additions & 2 deletions include/kernel-6.6
Original file line number Diff line number Diff line change
@@ -1,2 +1,2 @@
LINUX_VERSION-6.6 = .57
LINUX_KERNEL_HASH-6.6.57 = 66ce426ef96f99b8e1ef7ac72e780c730ef8b970f7aa5708501c4274d7abb7b3
LINUX_VERSION-6.6 = .58
LINUX_KERNEL_HASH-6.6.58 = e7df81e588d70fab5ec3ec3bb04ac53d51f0860fc3b1ec45e0a4167a026899db
4 changes: 3 additions & 1 deletion include/package-pack.mk
Original file line number Diff line number Diff line change
Expand Up @@ -339,10 +339,12 @@ else
$(FAKEROOT) $(STAGING_DIR_HOST)/bin/apk mkpkg \
--info "name:$(1)$$(ABIV_$(1))" \
--info "version:$(VERSION)" \
--info "description: $$(strip $$(Package/$(1)/description))" \
--info "description:$$(strip $$(Package/$(1)/description))" \
--info "arch:$(PKGARCH)" \
--info "license:$(LICENSE)" \
--info "origin:$(SOURCE)" \
--info "url:$(URL)" \
--info "maintainer:$(MAINTAINER)" \
--info "provides:$$(foreach prov,$$(filter-out $(1)$$(ABIV_$(1)),$(PROVIDES)$$(if $$(ABIV_$(1)), \
$(1) $(foreach provide,$(PROVIDES),$(provide)$$(ABIV_$(1))))),$$(prov)=$(VERSION) )" \
--script "post-install:$$(ADIR_$(1))/post-install" \
Expand Down
4 changes: 2 additions & 2 deletions package/libs/mbedtls/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -8,13 +8,13 @@
include $(TOPDIR)/rules.mk

PKG_NAME:=mbedtls
PKG_VERSION:=3.6.1
PKG_VERSION:=3.6.2
PKG_RELEASE:=1
PKG_BUILD_FLAGS:=no-mips16 gc-sections no-lto

PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL=https://github.com/Mbed-TLS/$(PKG_NAME)/releases/download/$(PKG_NAME)-$(PKG_VERSION)
PKG_HASH:=fc8bef0991b43629b7e5319de6f34f13359011105e08e3e16eed3a9fe6ffd3a3
PKG_HASH:=8b54fb9bcf4d5a7078028e0520acddefb7900b3e66fec7f7175bb5b7d85ccdca

PKG_LICENSE:=GPL-2.0-or-later
PKG_LICENSE_FILES:=LICENSE
Expand Down
1 change: 1 addition & 0 deletions target/linux/apm821xx/config-6.6
Original file line number Diff line number Diff line change
Expand Up @@ -100,6 +100,7 @@ CONFIG_GENERIC_IRQ_SHOW_LEVEL=y
CONFIG_GENERIC_ISA_DMA=y
CONFIG_GENERIC_MSI_IRQ=y
CONFIG_GENERIC_PCI_IOMAP=y
CONFIG_GENERIC_PHY=y
CONFIG_GENERIC_SMP_IDLE_THREAD=y
CONFIG_GENERIC_STRNCPY_FROM_USER=y
CONFIG_GENERIC_STRNLEN_USER=y
Expand Down
1 change: 0 additions & 1 deletion target/linux/apm821xx/nand/config-default
Original file line number Diff line number Diff line change
Expand Up @@ -2,7 +2,6 @@ CONFIG_AT803X_PHY=y
CONFIG_BCH=y
CONFIG_CRYPTO_HASH_INFO=y
CONFIG_CRYPTO_ZSTD=y
CONFIG_GENERIC_PHY=y
CONFIG_GRO_CELLS=y
CONFIG_HWMON=y
CONFIG_MTD_NAND_CORE=y
Expand Down
1 change: 0 additions & 1 deletion target/linux/apm821xx/sata/config-default
Original file line number Diff line number Diff line change
Expand Up @@ -15,7 +15,6 @@ CONFIG_EXT4_FS=y
CONFIG_F2FS_FS=y
CONFIG_FREEZER=y
CONFIG_FW_CACHE=y
CONFIG_GENERIC_PHY=y
CONFIG_GPIO_74XX_MMIO=y
CONFIG_GPIO_GENERIC=y
CONFIG_GPIO_GENERIC_PLATFORM=y
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -191,15 +191,15 @@ Signed-off-by: Jonathan Bell <[email protected]>
static void macb_init_buffers(struct macb *bp)
{
struct macb_queue *queue;
@@ -969,6 +985,7 @@ static int macb_mii_init(struct macb *bp
@@ -977,6 +993,7 @@ static int macb_mii_init(struct macb *bp
bp->mii_bus->write = &macb_mdio_write_c22;
bp->mii_bus->read_c45 = &macb_mdio_read_c45;
bp->mii_bus->write_c45 = &macb_mdio_write_c45;
+ bp->mii_bus->reset = &macb_mdio_reset;
snprintf(bp->mii_bus->id, MII_BUS_ID_SIZE, "%s-%x",
bp->pdev->name, bp->pdev->id);
bp->mii_bus->priv = bp;
@@ -1640,6 +1657,11 @@ static int macb_rx(struct macb_queue *qu
@@ -1648,6 +1665,11 @@ static int macb_rx(struct macb_queue *qu

macb_init_rx_ring(queue);
queue_writel(queue, RBQP, queue->rx_ring_dma);
Expand All @@ -211,7 +211,7 @@ Signed-off-by: Jonathan Bell <[email protected]>

macb_writel(bp, NCR, ctrl | MACB_BIT(RE));

@@ -1940,8 +1962,9 @@ static irqreturn_t macb_interrupt(int ir
@@ -1948,8 +1970,9 @@ static irqreturn_t macb_interrupt(int ir
queue_writel(queue, ISR, MACB_BIT(TCOMP) |
MACB_BIT(TXUBR));

Expand All @@ -222,7 +222,7 @@ Signed-off-by: Jonathan Bell <[email protected]>
wmb(); // ensure softirq can see update
}

@@ -2394,6 +2417,11 @@ static netdev_tx_t macb_start_xmit(struc
@@ -2402,6 +2425,11 @@ static netdev_tx_t macb_start_xmit(struc
skb_tx_timestamp(skb);

spin_lock_irq(&bp->lock);
Expand All @@ -234,7 +234,7 @@ Signed-off-by: Jonathan Bell <[email protected]>
macb_writel(bp, NCR, macb_readl(bp, NCR) | MACB_BIT(TSTART));
spin_unlock_irq(&bp->lock);

@@ -2768,6 +2796,37 @@ static void macb_configure_dma(struct ma
@@ -2776,6 +2804,37 @@ static void macb_configure_dma(struct ma
}
}

Expand Down Expand Up @@ -272,7 +272,7 @@ Signed-off-by: Jonathan Bell <[email protected]>
static void macb_init_hw(struct macb *bp)
{
u32 config;
@@ -2796,6 +2855,11 @@ static void macb_init_hw(struct macb *bp
@@ -2804,6 +2863,11 @@ static void macb_init_hw(struct macb *bp
if (bp->caps & MACB_CAPS_JUMBO)
bp->rx_frm_len_mask = MACB_RX_JFRMLEN_MASK;

Expand All @@ -284,7 +284,7 @@ Signed-off-by: Jonathan Bell <[email protected]>
macb_configure_dma(bp);

/* Enable RX partial store and forward and set watermark */
@@ -3157,6 +3221,52 @@ static void gem_get_ethtool_strings(stru
@@ -3165,6 +3229,52 @@ static void gem_get_ethtool_strings(stru
}
}

Expand Down Expand Up @@ -337,7 +337,7 @@ Signed-off-by: Jonathan Bell <[email protected]>
static struct net_device_stats *macb_get_stats(struct net_device *dev)
{
struct macb *bp = netdev_priv(dev);
@@ -3749,6 +3859,8 @@ static const struct ethtool_ops macb_eth
@@ -3757,6 +3867,8 @@ static const struct ethtool_ops macb_eth
};

static const struct ethtool_ops gem_ethtool_ops = {
Expand All @@ -346,7 +346,7 @@ Signed-off-by: Jonathan Bell <[email protected]>
.get_regs_len = macb_get_regs_len,
.get_regs = macb_get_regs,
.get_wol = macb_get_wol,
@@ -3758,6 +3870,8 @@ static const struct ethtool_ops gem_etht
@@ -3766,6 +3878,8 @@ static const struct ethtool_ops gem_etht
.get_ethtool_stats = gem_get_ethtool_stats,
.get_strings = gem_get_ethtool_strings,
.get_sset_count = gem_get_sset_count,
Expand All @@ -355,7 +355,7 @@ Signed-off-by: Jonathan Bell <[email protected]>
.get_link_ksettings = macb_get_link_ksettings,
.set_link_ksettings = macb_set_link_ksettings,
.get_ringparam = macb_get_ringparam,
@@ -5054,6 +5168,11 @@ static int macb_probe(struct platform_de
@@ -5062,6 +5176,11 @@ static int macb_probe(struct platform_de
}
}
}
Expand All @@ -367,7 +367,7 @@ Signed-off-by: Jonathan Bell <[email protected]>
spin_lock_init(&bp->lock);

/* setup capabilities */
@@ -5109,6 +5228,21 @@ static int macb_probe(struct platform_de
@@ -5117,6 +5236,21 @@ static int macb_probe(struct platform_de
else
bp->phy_interface = interface;

Expand All @@ -389,7 +389,7 @@ Signed-off-by: Jonathan Bell <[email protected]>
/* IP specific init */
err = init(pdev);
if (err)
@@ -5185,6 +5319,19 @@ static int macb_remove(struct platform_d
@@ -5193,6 +5327,19 @@ static int macb_remove(struct platform_d
return 0;
}

Expand All @@ -409,7 +409,7 @@ Signed-off-by: Jonathan Bell <[email protected]>
static int __maybe_unused macb_suspend(struct device *dev)
{
struct net_device *netdev = dev_get_drvdata(dev);
@@ -5399,6 +5546,7 @@ static const struct dev_pm_ops macb_pm_o
@@ -5407,6 +5554,7 @@ static const struct dev_pm_ops macb_pm_o
static struct platform_driver macb_driver = {
.probe = macb_probe,
.remove = macb_remove,
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -43,7 +43,7 @@ Subject: [PATCH] net/usb/qmi_wwan: add MeigLink modem support

#define QUECTEL_VENDOR_ID 0x2c7c
/* These Quectel products use Quectel's vendor ID */
@@ -1158,6 +1163,11 @@ static const struct usb_device_id option
@@ -1159,6 +1164,11 @@ static const struct usb_device_id option
{ USB_DEVICE(QUALCOMM_VENDOR_ID, 0x0023)}, /* ONYX 3G device */
{ USB_DEVICE(QUALCOMM_VENDOR_ID, 0x9000), /* SIMCom SIM5218 */
.driver_info = NCTRL(0) | NCTRL(1) | NCTRL(2) | NCTRL(3) | RSVD(4) },
Expand All @@ -55,7 +55,7 @@ Subject: [PATCH] net/usb/qmi_wwan: add MeigLink modem support
/* Quectel products using Qualcomm vendor ID */
{ USB_DEVICE(QUALCOMM_VENDOR_ID, QUECTEL_PRODUCT_UC15)},
{ USB_DEVICE(QUALCOMM_VENDOR_ID, QUECTEL_PRODUCT_UC20),
@@ -1199,6 +1209,11 @@ static const struct usb_device_id option
@@ -1200,6 +1210,11 @@ static const struct usb_device_id option
.driver_info = ZLP },
{ USB_DEVICE(QUECTEL_VENDOR_ID, QUECTEL_PRODUCT_BG96),
.driver_info = RSVD(4) },
Expand Down
1 change: 1 addition & 0 deletions target/linux/mpc85xx/config-6.6
Original file line number Diff line number Diff line change
Expand Up @@ -165,6 +165,7 @@ CONFIG_MTD_NAND_ECC=y
CONFIG_MTD_NAND_ECC_SW_HAMMING=y
CONFIG_MTD_RAW_NAND=y
CONFIG_MTD_SPI_NOR=y
CONFIG_MTD_SPLIT_FIRMWARE=y
# CONFIG_MVME2500 is not set
CONFIG_NEED_PER_CPU_KM=y
CONFIG_NEED_SG_DMA_LENGTH=y
Expand Down
1 change: 0 additions & 1 deletion target/linux/mpc85xx/p1010/config-default
Original file line number Diff line number Diff line change
Expand Up @@ -8,7 +8,6 @@ CONFIG_MEMORY=y
CONFIG_MTD_CFI=y
CONFIG_MTD_NAND_FSL_IFC=y
CONFIG_MTD_PHYSMAP=y
CONFIG_MTD_SPLIT_FIRMWARE=y
CONFIG_MTD_SPLIT_TPLINK_FW=y
CONFIG_MTD_SPLIT_UIMAGE_FW=y
CONFIG_MTD_UBI=y
Expand Down
1 change: 0 additions & 1 deletion target/linux/mpc85xx/p1020/config-default
Original file line number Diff line number Diff line change
Expand Up @@ -27,7 +27,6 @@ CONFIG_MSM460=y
CONFIG_MTD_CFI=y
CONFIG_MTD_NAND_FSL_ELBC=y
CONFIG_MTD_PHYSMAP=y
CONFIG_MTD_SPLIT_FIRMWARE=y
CONFIG_MTD_SPLIT_FIT_FW=y
CONFIG_MTD_SPLIT_UIMAGE_FW=y
CONFIG_MTD_UBI=y
Expand Down
1 change: 0 additions & 1 deletion target/linux/mpc85xx/p2020/config-default
Original file line number Diff line number Diff line change
Expand Up @@ -15,7 +15,6 @@ CONFIG_MPC85xx_RDB=y
CONFIG_MTD_CFI=y
CONFIG_MTD_NAND_FSL_ELBC=y
CONFIG_MTD_PHYSMAP=y
CONFIG_MTD_SPLIT_FIRMWARE=y
CONFIG_MTD_SPLIT_FIT_FW=y
CONFIG_MUTEX_SPIN_ON_OWNER=y
CONFIG_NEED_DMA_MAP_STATE=y
Expand Down
8 changes: 8 additions & 0 deletions target/linux/ramips/dts/mt7620a.dtsi
Original file line number Diff line number Diff line change
Expand Up @@ -140,6 +140,8 @@

interrupt-parent = <&intc>;
interrupts = <6>;
interrupt-controller;
#interrupt-cells = <2>;

gpio-controller;
#gpio-cells = <2>;
Expand All @@ -156,6 +158,8 @@

interrupt-parent = <&intc>;
interrupts = <6>;
interrupt-controller;
#interrupt-cells = <2>;

gpio-controller;
#gpio-cells = <2>;
Expand All @@ -174,6 +178,8 @@

interrupt-parent = <&intc>;
interrupts = <6>;
interrupt-controller;
#interrupt-cells = <2>;

gpio-controller;
#gpio-cells = <2>;
Expand All @@ -192,6 +198,8 @@

interrupt-parent = <&intc>;
interrupts = <6>;
interrupt-controller;
#interrupt-cells = <2>;

gpio-controller;
#gpio-cells = <2>;
Expand Down
8 changes: 8 additions & 0 deletions target/linux/ramips/dts/mt7620n.dtsi
Original file line number Diff line number Diff line change
Expand Up @@ -95,6 +95,8 @@

interrupt-parent = <&intc>;
interrupts = <6>;
interrupt-controller;
#interrupt-cells = <2>;

gpio-controller;
#gpio-cells = <2>;
Expand All @@ -111,6 +113,8 @@

interrupt-parent = <&intc>;
interrupts = <6>;
interrupt-controller;
#interrupt-cells = <2>;

gpio-controller;
#gpio-cells = <2>;
Expand All @@ -129,6 +133,8 @@

interrupt-parent = <&intc>;
interrupts = <6>;
interrupt-controller;
#interrupt-cells = <2>;

gpio-controller;
#gpio-cells = <2>;
Expand All @@ -147,6 +153,8 @@

interrupt-parent = <&intc>;
interrupts = <6>;
interrupt-controller;
#interrupt-cells = <2>;

gpio-controller;
#gpio-cells = <2>;
Expand Down
3 changes: 1 addition & 2 deletions target/linux/ramips/dts/mt7628an_minew_g1-c.dts
Original file line number Diff line number Diff line change
Expand Up @@ -17,8 +17,7 @@
};

keys {
compatible = "gpio-keys-polled";
poll-interval = <20>;
compatible = "gpio-keys";

reset {
label = "reset";
Expand Down
15 changes: 15 additions & 0 deletions target/linux/ramips/dts/rt2880.dtsi
Original file line number Diff line number Diff line change
Expand Up @@ -87,6 +87,11 @@
gpio-controller;
#gpio-cells = <2>;

interrupt-parent = <&intc>;
interrupts = <6>;
interrupt-controller;
#interrupt-cells = <2>;

ngpios = <24>;
ralink,register-map = [ 00 04 08 0c
20 24 28 2c
Expand All @@ -100,6 +105,11 @@
gpio-controller;
#gpio-cells = <2>;

interrupt-parent = <&intc>;
interrupts = <6>;
interrupt-controller;
#interrupt-cells = <2>;

ngpios = <16>;
ralink,register-map = [ 00 04 08 0c
10 14 18 1c
Expand All @@ -115,6 +125,11 @@
gpio-controller;
#gpio-cells = <2>;

interrupt-parent = <&intc>;
interrupts = <6>;
interrupt-controller;
#interrupt-cells = <2>;

ngpios = <32>;
ralink,register-map = [ 00 04 08 0c
10 14 18 1c
Expand Down
3 changes: 1 addition & 2 deletions target/linux/ramips/dts/rt2880_airlink101_ar670w.dts
Original file line number Diff line number Diff line change
Expand Up @@ -76,8 +76,7 @@
};

keys {
compatible = "gpio-keys-polled";
poll-interval = <100>;
compatible = "gpio-keys";

wps {
label = "wps";
Expand Down
3 changes: 1 addition & 2 deletions target/linux/ramips/dts/rt2880_airlink101_ar725w.dts
Original file line number Diff line number Diff line change
Expand Up @@ -87,8 +87,7 @@
};

keys {
compatible = "gpio-keys-polled";
poll-interval = <100>;
compatible = "gpio-keys";

wps {
label = "wps";
Expand Down
3 changes: 1 addition & 2 deletions target/linux/ramips/dts/rt2880_asus_rt-n15.dts
Original file line number Diff line number Diff line change
Expand Up @@ -75,8 +75,7 @@
};

keys {
compatible = "gpio-keys-polled";
poll-interval = <100>;
compatible = "gpio-keys";

wps {
label = "wps";
Expand Down
3 changes: 1 addition & 2 deletions target/linux/ramips/dts/rt2880_belkin_f5d8235-v1.dts
Original file line number Diff line number Diff line change
Expand Up @@ -113,8 +113,7 @@
};

keys {
compatible = "gpio-keys-polled";
poll-interval = <100>;
compatible = "gpio-keys";

wps {
label = "wps";
Expand Down
3 changes: 1 addition & 2 deletions target/linux/ramips/dts/rt2880_buffalo_wli-tx4-ag300n.dts
Original file line number Diff line number Diff line change
Expand Up @@ -69,8 +69,7 @@
};

keys {
compatible = "gpio-keys-polled";
poll-interval = <100>;
compatible = "gpio-keys";

wps {
label = "wps";
Expand Down
Loading

0 comments on commit 464f60e

Please sign in to comment.