Skip to content

Commit

Permalink
Merge pull request #56 from lindsayad/leverage-actual-mfem-installation
Browse files Browse the repository at this point in the history
Do includes/libraries based more off a traditional installation
  • Loading branch information
alexanderianblair authored Dec 20, 2024
2 parents 48724ae + a31c2d4 commit 2de76d6
Show file tree
Hide file tree
Showing 9 changed files with 22 additions and 24 deletions.
2 changes: 1 addition & 1 deletion include/equation_systems/equation_system.h
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
#pragma once
#include "../common/pfem_extras.hpp"
#include "mfem/miniapps/common/pfem_extras.hpp"
#include "boundary_conditions.h"
#include "MFEMContainers.h"
#include "MFEMKernel.h"
Expand Down
2 changes: 1 addition & 1 deletion include/integrators/ScaleIntegrator.h
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
#pragma once
#include "MFEMGeneralUserObject.h"
#include "../common/pfem_extras.hpp"
#include "mfem/miniapps/common/pfem_extras.hpp"

namespace platypus
{
Expand Down
10 changes: 5 additions & 5 deletions include/problem/MFEMProblem.h
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
#pragma once
#include <map>
#include "../common/pfem_extras.hpp"
#include "mfem/miniapps/common/pfem_extras.hpp"
#include "ExternalProblem.h"
#include "MFEMProblemData.h"
#include "MFEMMesh.h"
Expand All @@ -22,12 +22,12 @@ class MFEMProblem : public ExternalProblem
static InputParameters validParams();

MFEMProblem(const InputParameters & params);
virtual ~MFEMProblem(){};
virtual ~MFEMProblem() {}

virtual void initialSetup() override;
virtual void externalSolve() override{};
virtual bool nlConverged(const unsigned int nl_sys_num) override { return true; };
virtual void syncSolutions(Direction direction) override{};
virtual void externalSolve() override {}
virtual bool nlConverged(const unsigned int) override { return true; }
virtual void syncSolutions(Direction) override {}

/**
* Overwritten mesh() method from base MooseMesh to retrieve the correct mesh type, in this case
Expand Down
6 changes: 3 additions & 3 deletions include/problem_operators/problem_operator.h
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
#pragma once
#include "../common/pfem_extras.hpp"
#include "mfem/miniapps/common/pfem_extras.hpp"
#include "MFEMProblemData.h"
#include "problem_operator_interface.h"

Expand All @@ -15,7 +15,7 @@ class ProblemOperator : public mfem::Operator, public ProblemOperatorInterface
void SetGridFunctions() override;

virtual void Solve(mfem::Vector & X) {}
void Mult(const mfem::Vector & x, mfem::Vector & y) const override {}
void Mult(const mfem::Vector &, mfem::Vector &) const override {}
};

} // namespace platypus
} // namespace platypus
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
#pragma once
#include "../common/pfem_extras.hpp"
#include "mfem/miniapps/common/pfem_extras.hpp"
#include "time_domain_problem_operator.h"
#include "problem_operator_interface.h"
#include "equation_system_interface.h"
Expand Down Expand Up @@ -42,4 +42,4 @@ class TimeDomainEquationSystemProblemOperator : public TimeDomainProblemOperator
std::shared_ptr<platypus::TimeDependentEquationSystem> _equation_system{nullptr};
};

} // namespace platypus
} // namespace platypus
6 changes: 3 additions & 3 deletions include/problem_operators/time_domain_problem_operator.h
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
#pragma once
#include "../common/pfem_extras.hpp"
#include "mfem/miniapps/common/pfem_extras.hpp"
#include "MFEMProblemData.h"
#include "problem_operator_interface.h"

Expand All @@ -18,7 +18,7 @@ class TimeDomainProblemOperator : public mfem::TimeDependentOperator,

void SetGridFunctions() override;

void ImplicitSolve(const double dt, const mfem::Vector & X, mfem::Vector & dX_dt) override {}
void ImplicitSolve(const double, const mfem::Vector &, mfem::Vector &) override {}
};

} // namespace platypus
} // namespace platypus
12 changes: 5 additions & 7 deletions platypus.mk
Original file line number Diff line number Diff line change
@@ -1,11 +1,9 @@
MFEM_DIR :=$(APPLICATION_DIR)/../mfem/build
MFEM_DIR ?= $(APPLICATION_DIR)/../mfem/installed

include $(MFEM_DIR)/config/config.mk
MFEM_INCLUDES := -I$(MFEM_INC_DIR)/config -I$(MFEM_DIR)/ -I$(MFEM_DIR)/../miniapps/common $(MFEM_INCFLAGS)
MFEM_LIBS := -L$(MFEM_DIR) -lmfem -lrt -L$(MFEM_DIR)/miniapps/common -lmfem-common $(MFEM_LIB)
include $(MFEM_DIR)/share/mfem/config.mk

ADDITIONAL_INCLUDES += $(MFEM_INCLUDES)
ADDITIONAL_LIBS += -Wl, $(MFEM_LIBS) ${MFEM_EXT_LIBS}
ADDITIONAL_INCLUDES += $(MFEM_INCFLAGS)
ADDITIONAL_LIBS += $(MFEM_LIBS) -lmfem-common

$(info ADDITIONAL_INCLUDES = $(ADDITIONAL_INCLUDES));
$(info ADDITIONAL_LIBS = $(ADDITIONAL_LIBS));
$(info ADDITIONAL_LIBS = $(ADDITIONAL_LIBS));
2 changes: 1 addition & 1 deletion src/bcs/MFEMBoundaryCondition.C
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
#include "MFEMBoundaryCondition.h"
#include "mesh_extras.hpp"
#include "mfem/miniapps/common/mesh_extras.hpp"

InputParameters
MFEMBoundaryCondition::validParams()
Expand Down
2 changes: 1 addition & 1 deletion unit/src/MFEMEssentialBCTest.C
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
#include "mfem-common.hpp"
#include "mfem/miniapps/common/mfem-common.hpp"
#include "MFEMObjectUnitTest.h"
#include "MFEMScalarDirichletBC.h"
#include "MFEMScalarFunctionDirichletBC.h"
Expand Down

0 comments on commit 2de76d6

Please sign in to comment.