Skip to content
This repository has been archived by the owner on Mar 3, 2023. It is now read-only.

Commit

Permalink
v4.20 - new upstream release
Browse files Browse the repository at this point in the history
  • Loading branch information
barnumbirr committed Oct 19, 2021
1 parent ef4a605 commit 64eb997
Show file tree
Hide file tree
Showing 8 changed files with 44 additions and 45 deletions.
59 changes: 25 additions & 34 deletions .github/workflows/main.yml
Original file line number Diff line number Diff line change
@@ -1,53 +1,44 @@
name: Build i3-gaps Debian packages
name: Build and release packages

on:
push:
tags:
- "*"
- '*'

env:
DEBIAN_STABLE: bullseye
PKG_NAME: i3-gaps

jobs:
build:
runs-on: ubuntu-latest
steps:
- uses: actions/checkout@v1
- name: Checkout
uses: actions/checkout@v2

- name: Build packages
run: |
set -xe
mkdir -p assets
./build.sh -i debian:buster-slim
rename.ul .deb _debian_buster.deb target/i3-gaps_*.deb
mv -n target/i3-gaps_*.deb assets/
./build.sh -i debian:${{ env.DEBIAN_STABLE }}-slim
rename.ul .deb _${{ env.DEBIAN_STABLE }}.deb target/${{ env.PKG_NAME }}_*.deb
mv -n target/${{ env.PKG_NAME }}_*.deb assets/
./build.sh -i debian:testing-slim
rename.ul .deb _debian_testing.deb target/i3-gaps_*.deb
mv -n target/i3-gaps_*.deb assets/
rename.ul .deb _testing.deb target/${{ env.PKG_NAME }}_*.deb
mv -n target/${{ env.PKG_NAME }}_*.deb assets/
./build.sh -i debian:unstable-slim
rename.ul .deb _debian_unstable.deb target/i3-gaps_*.deb
mv -n target/i3-gaps_*.deb assets/
- name: Create release
id: create_release
uses: actions/create-release@v1
env:
GITHUB_TOKEN: ${{ secrets.GITHUB_TOKEN }}
rename.ul .deb _unstable.deb target/${{ env.PKG_NAME }}_*.deb
mv -n target/${{ env.PKG_NAME }}_*.deb assets/
- name: Set Release Version
run: echo "RELEASE_VERSION=${GITHUB_REF##*/}" >> $GITHUB_ENV

- name: Build packages
uses: "marvinpinto/[email protected]"
with:
tag_name: ${{ github.ref }}
release_name: ${{ github.ref }}
draft: false
repo_token: "${{ secrets.GITHUB_TOKEN }}"
automatic_release_tag: ${{ env.RELEASE_VERSION }}
prerelease: false
- name: Upload packages
env:
GITHUB_TOKEN: ${{ secrets.GITHUB_TOKEN }}
ID: ${{ steps.create_release.outputs.id }}
run: |
set -xe
for asset in assets/*
do
UPLOAD_URL="https://uploads.github.com/repos/$GITHUB_REPOSITORY/releases/$ID/assets"
curl \
-X POST \
-H "Authorization: token $GITHUB_TOKEN" \
-H "Content-Type: application/octet-stream" \
--data-binary @"$asset" \
"${UPLOAD_URL}?name=$(basename $asset)"
done
files: assets/*.deb
2 changes: 1 addition & 1 deletion LICENSE
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
BSD 3-Clause License

Copyright (c) 2020, Martin Simon
Copyright (c) 2020-2021, Martin Simon
All rights reserved.

Redistribution and use in source and binary forms, with or without
Expand Down
9 changes: 4 additions & 5 deletions README.md
Original file line number Diff line number Diff line change
Expand Up @@ -7,14 +7,14 @@ This repository contains the source to build a Debian package for [i3-gaps](http
If you have [Docker](https://www.docker.com/) installed locally, just run the following:

```bash
user@hostname$ ./build.sh
$ ./build.sh
```
By default this will build i3-gaps 4.19.1 on Debian Buster.
By default this will build i3-gaps 4.20 on Debian Bullseye.

If you want to customize the build at runtime, use the following:

```bash
user@hostname$ ./build.sh -i debian:unstable-slim -v 4.16.1
$ ./build.sh -i debian:unstable-slim -v 4.16.1
```
Don't forget to update `debian/changelog` so your package is generated with the correct version.

Expand All @@ -30,7 +30,7 @@ To publish a new package version to Github, follow these steps:
```
BSD 3-Clause License
Copyright (c) 2020, Martin Simon
Copyright (c) 2020-2021, Martin Simon
All rights reserved.
Redistribution and use in source and binary forms, with or without
Expand Down Expand Up @@ -59,7 +59,6 @@ OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
```


## References

* [Airblader/i3](https://github.com/Airblader/i3)
Expand Down
4 changes: 2 additions & 2 deletions build.sh
Original file line number Diff line number Diff line change
Expand Up @@ -2,9 +2,9 @@

set -eu

IMAGE="debian:buster-slim"
IMAGE="debian:bullseye-slim"
TARGET="$(dirname "$0" | xargs realpath)"
VERSION="4.19.1"
VERSION="4.20"

while getopts "v:i:h" opt
do
Expand Down
9 changes: 9 additions & 0 deletions debian/changelog
Original file line number Diff line number Diff line change
@@ -1,3 +1,12 @@
i3-gaps (4.20-1) unstable; urgency=medium

* New upstream release
* Bullseye is now stable
* Update debhelper
* Improve Debian version and package name handling in Github Action

-- Martin Simon <[email protected]> Tue, 19 Oct 2021 00:00:00 +0000

i3-gaps (4.19.1-1) unstable; urgency=medium

* Version 4.19.1
Expand Down
2 changes: 1 addition & 1 deletion debian/compat
Original file line number Diff line number Diff line change
@@ -1 +1 @@
11
12
2 changes: 1 addition & 1 deletion debian/control
Original file line number Diff line number Diff line change
Expand Up @@ -4,7 +4,7 @@ Priority: extra
Maintainer: Martin Simon <[email protected]>
Build-Depends:
asciidoc (>= 8.4.4),
debhelper (>= 11),
debhelper (>= 12),
docbook-xml,
libcairo2-dev (>= 1.14.4),
libev-dev (>= 1:4.04),
Expand Down
2 changes: 1 addition & 1 deletion debian/copyright
Original file line number Diff line number Diff line change
Expand Up @@ -7,7 +7,7 @@ Copyright: 2009 Michael Stapelberg
License: BSD-3-clause

Files: debian/*
Copyright: 2020 Martin Simon <[email protected]>
Copyright: 2020-2021 Martin Simon <[email protected]>
License: BSD-3-clause

License: BSD-3-clause
Expand Down

0 comments on commit 64eb997

Please sign in to comment.