Install Nix
curl --proto '=https' --tlsv1.2 -sSf -L https://install.determinate.systems/nix | sh -s -- install
Install Direnv
nix -v flake install nixpkgs#direnv
Hook Direnv to your shell, e.g.
# For bash
echo 'eval "$(direnv hook bash)"' >> ~/.bashrc
source ~/.bashrc
# For zsh
echo 'eval "$(direnv hook zsh)"' >> ~/.zshrc
source ~/.zshrc
Enable direnv for the local copy of the repo
direnv allow
Get Rusty!