Skip to content

Commit

Permalink
net-p2p/ipfs-desktop-bin: new package, add 0.39.0
Browse files Browse the repository at this point in the history
Signed-off-by: Dawn Xu <[email protected]>
  • Loading branch information
Dawn-Xu-helloworld committed Oct 25, 2024
1 parent bdfd630 commit dd496c3
Show file tree
Hide file tree
Showing 3 changed files with 75 additions and 0 deletions.
1 change: 1 addition & 0 deletions net-p2p/ipfs-desktop-bin/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST ipfs-desktop-0.39.0-linux-amd64.deb 126937128 BLAKE2B 53ab176bb87a81cef9e9e5b968ff8ed2207be691aa19ce95cd45664590cea3a6ce071b67b67883bf3de1cb7e2b4a1fad4df8c64e5590dc8f06f46dd2fc66d543 SHA512 200bbf5289a0f1b091afd6ea102303aba9831da2fb926bb7adf5c22099cf5cee68ae1c533de81c1a11ab7af837fc4609d7caf60b97361ceedc7a2220423ac3e5
59 changes: 59 additions & 0 deletions net-p2p/ipfs-desktop-bin/ipfs-desktop-bin-0.39.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,59 @@
# Copyright 2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8
inherit desktop xdg unpacker optfeature
DESCRIPTION="A desktop client for IPFS. The IPFS's Native Application"
HOMEPAGE="https://github.com/ipfs-shipyard/ipfs-desktop"
SRC_URI="https://github.com/ipfs/ipfs-desktop/releases/download/v${PV}/ipfs-desktop-${PV}-linux-amd64.deb"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64"

DEPEND="
x11-libs/gtk+:3
x11-libs/libnotify
dev-libs/nss
x11-libs/libXScrnSaver
x11-libs/libXtst
x11-misc/xdg-utils
app-accessibility/at-spi2-core
sys-apps/util-linux
app-crypt/libsecret
"
RDEPEND="${DEPEND}"
S="${WORKDIR}"

src_prepare(){
default
unpacker "${S}/usr/share/doc/ipfs-desktop/changelog.gz"
# to prevent ipfs-desktop install build-in ipfs exe into /usr/local/bin or ${HOME}/.local/bin
# sed -i "s/^binpaths=\(.*\)$/binpaths=\'\/usr\/bin\'/" "${S}/opt/IPFS Desktop/resources/app.asar.unpacked/node_modules/kubo/kubo/install.sh"
}
src_install(){
# clean up build-in kubo
insinto "/opt"
doins -r "${S}/opt/IPFS Desktop"
dosym -r "/opt/IPFS Desktop/ipfs-desktop" "/usr/bin/ipfs-desktop"
domenu "${S}/usr/share/applications/ipfs-desktop.desktop"
dodoc "${S}/changelog"
insinto "/usr/share"
# doins -r "${S}/usr/share/icons"
local size
for size in 16 24 32 48 64 128 256 512; do
doicon -s ${size} "${S}/usr/share/icons/hicolor/${size}x${size}/apps/ipfs-desktop.png"
done
fperms +x "/opt/IPFS Desktop/ipfs-desktop"
fperms +x "/opt/IPFS Desktop/chrome-sandbox"
fperms +x "/opt/IPFS Desktop/chrome_crashpad_handler"
fperms +x "/opt/IPFS Desktop/resources/app.asar.unpacked/node_modules/kubo/kubo/ipfs"
}

pkg_postinst(){
xdg_pkg_postinst
optfeature "cli interface" net-p2p/kubo
}
pkg_postrm(){
xdg_pkg_postrm
}
15 changes: 15 additions & 0 deletions net-p2p/ipfs-desktop-bin/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>[email protected]</email>
<name>Dawn Xu</name>
</maintainer>
<upstream>
<remote-id type = "github">ipfs/ipfs-desktop</remote-id>
<maintainer>
<name>ipfs</name>
<email>[email protected]</email>
</maintainer>
</upstream>
</pkgmetadata>

0 comments on commit dd496c3

Please sign in to comment.