Skip to content

Commit

Permalink
hyperspace-corestore: init at 6.15.9
Browse files Browse the repository at this point in the history
  • Loading branch information
alejandrosame committed Dec 30, 2023
1 parent 8d5507c commit 48f40f6
Show file tree
Hide file tree
Showing 2 changed files with 4,195 additions and 0 deletions.
48 changes: 48 additions & 0 deletions pkgs/by-name/corestore/dream2.nix
Original file line number Diff line number Diff line change
@@ -0,0 +1,48 @@
{
lib,
config,
dream2nix,
...
}: rec {
name = "corestore-${version}";
version = "6.15.9";

imports = [
dream2nix.modules.dream2nix.nodejs-package-lock-v3
dream2nix.modules.dream2nix.nodejs-granular-v3
];

mkDerivation = {
src = config.deps.fetchFromGitHub {
owner = "holepunchto";
repo = "corestore";
rev = "v${version}";
sha256 = "sha256-18FKwP0XHoq/F8oF8BCLlul/Xb30sd0iOWuiKkzpPLI=";
};

doCheck = true;
checkPhase = ''
npm run test
'';

meta = with lib; {
description = "A simple corestore that wraps a random-access-storage module";
homepage = "https://github.com/holepunchto/corestore";
license = licenses.mit;
};
};

deps = {nixpkgs, ...}: {
inherit
(nixpkgs)
fetchFromGitHub
stdenv
;

npm = nixpkgs.nodejs_16.pkgs.npm;
};

nodejs-package-lock-v3 = {
packageLockFile = ./package-lock.json;
};
}
Loading

0 comments on commit 48f40f6

Please sign in to comment.