Skip to content

Commit

Permalink
frr: fix compilation with GCC14
Browse files Browse the repository at this point in the history
Fixes:
zebra/zebra_netns_notify.c: In function 'zebra_ns_ready_read':
zebra/zebra_netns_notify.c:265:40: error: implicit declaration of function 'basename' [-Wimplicit-function-declaration]
  265 |         if (strmatch(VRF_DEFAULT_NAME, basename(netnspath))) {
      |                                        ^~~~~~~~

Signed-off-by: Georgi Valkov <[email protected]>
  • Loading branch information
httpstorm committed May 27, 2024
1 parent 68d40e6 commit 38b6496
Show file tree
Hide file tree
Showing 2 changed files with 11 additions and 1 deletion.
2 changes: 1 addition & 1 deletion net/frr/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=frr
PKG_VERSION:=9.0.0
PKG_RELEASE:=2
PKG_RELEASE:=3
PKG_SOURCE_DATE:=2023-08-12

PKG_SOURCE:=$(PKG_NAME)-$(PKG_SOURCE_DATE).tar.gz
Expand Down
10 changes: 10 additions & 0 deletions net/frr/patches/100-gcc-14-compatibility.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,10 @@
--- a/zebra/zebra_netns_notify.c
+++ b/zebra/zebra_netns_notify.c
@@ -14,6 +14,7 @@
#include <sched.h>
#endif
#include <dirent.h>
+#include <libgen.h>
#include <sys/inotify.h>
#include <sys/stat.h>

0 comments on commit 38b6496

Please sign in to comment.