Skip to content

Commit

Permalink
busybox: update to 1.37.0
Browse files Browse the repository at this point in the history
Add config support for the new getfattr applet and refresh patches.

Signed-off-by: Rui Salvaterra <[email protected]>
  • Loading branch information
rsalvaterra committed Sep 27, 2024
1 parent a4c95f1 commit 839d76e
Show file tree
Hide file tree
Showing 7 changed files with 16 additions and 8 deletions.
3 changes: 3 additions & 0 deletions package/utils/busybox/Config-defaults.in
Original file line number Diff line number Diff line change
Expand Up @@ -2186,6 +2186,9 @@ config BUSYBOX_DEFAULT_RX
config BUSYBOX_DEFAULT_SEEDRNG
bool
default n
config BUSYBOX_DEFAULT_GETFATTR
bool
default n
config BUSYBOX_DEFAULT_SETFATTR
bool
default n
Expand Down
6 changes: 3 additions & 3 deletions package/utils/busybox/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -5,14 +5,14 @@
include $(TOPDIR)/rules.mk

PKG_NAME:=busybox
PKG_VERSION:=1.36.1
PKG_RELEASE:=2
PKG_VERSION:=1.37.0
PKG_RELEASE:=1
PKG_FLAGS:=essential

PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://www.busybox.net/downloads \
http://sources.buildroot.net
PKG_HASH:=b8cc24c9574d809e7279c3be349795c5d5ceb6fdf19ca709f80cde50e47de314
PKG_HASH:=3311dff32e746499f4df0d5df04d7eb396382d7e108bb9250e7b519b837043a4

PKG_BUILD_DEPENDS:=BUSYBOX_CONFIG_PAM:libpam
PKG_BUILD_PARALLEL:=1
Expand Down
5 changes: 5 additions & 0 deletions package/utils/busybox/config/miscutils/Config.in
Original file line number Diff line number Diff line change
Expand Up @@ -711,6 +711,11 @@ config BUSYBOX_CONFIG_SEEDRNG
Seed the kernel RNG from seed files, meant to be called
once during startup, once during shutdown, and optionally
at some periodic interval in between.
config BUSYBOX_CONFIG_GETFATTR
bool "getfattr (12.3 kb)"
default BUSYBOX_DEFAULT_GETFATTR
help
Get extended attributes on files
config BUSYBOX_CONFIG_SETFATTR
bool "setfattr (3.7 kb)"
default BUSYBOX_DEFAULT_SETFATTR
Expand Down
4 changes: 2 additions & 2 deletions package/utils/busybox/patches/200-udhcpc_reduce_msgs.patch
Original file line number Diff line number Diff line change
@@ -1,14 +1,14 @@
--- a/networking/udhcp/dhcpc.c
+++ b/networking/udhcp/dhcpc.c
@@ -722,6 +722,7 @@ static int bcast_or_ucast(struct dhcp_pa
@@ -711,6 +711,7 @@ static int bcast_or_ucast(struct dhcp_pa
static NOINLINE int send_discover(uint32_t requested)
{
struct dhcp_packet packet;
+ static int msgs = 0;

/* Fill in: op, htype, hlen, cookie, chaddr fields,
* xid field, message type option:
@@ -736,6 +737,7 @@ static NOINLINE int send_discover(uint32
@@ -725,6 +726,7 @@ static NOINLINE int send_discover(uint32
*/
add_client_options(&packet);

Expand Down
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
--- a/networking/udhcp/dhcpc.c
+++ b/networking/udhcp/dhcpc.c
@@ -1384,6 +1384,12 @@ int udhcpc_main(int argc UNUSED_PARAM, c
@@ -1374,6 +1374,12 @@ int udhcpc_main(int argc UNUSED_PARAM, c
struct pollfd pfds[2];
struct dhcp_packet packet;

Expand Down
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
--- a/networking/libiproute/iplink.c
+++ b/networking/libiproute/iplink.c
@@ -683,7 +683,7 @@ static int do_add_or_delete(char **argv,
@@ -953,7 +953,7 @@ static int do_add_or_delete(char **argv,
}
xrtnl_open(&rth);
ll_init_map(&rth);
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -29,7 +29,7 @@ Forwarded: http://lists.busybox.net/pipermail/busybox/2022-October/089911.html
---
--- a/networking/nslookup.c
+++ b/networking/nslookup.c
@@ -978,6 +978,10 @@ int nslookup_main(int argc UNUSED_PARAM,
@@ -1370,6 +1370,10 @@ int nslookup_main(int argc UNUSED_PARAM,
}
}

Expand Down

0 comments on commit 839d76e

Please sign in to comment.