Skip to content

Commit

Permalink
zephyr-kernel: Include efi binary generation fix for Raptor Lake too
Browse files Browse the repository at this point in the history
Extend patch to include efi binary generation issue fix
for x86 Raptor Lake board too.

Signed-off-by: Naveen Saini <[email protected]>
  • Loading branch information
saininav committed May 15, 2023
1 parent 5fde315 commit b0173e0
Showing 1 changed file with 16 additions and 3 deletions.
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
From bad26e63d47b638fc1c0b268faf5cee9738efc35 Mon Sep 17 00:00:00 2001
From 60b4dc4214ee645833eff109ff04d4849219fd4e Mon Sep 17 00:00:00 2001
From: Naveen Saini <[email protected]>
Date: Thu, 28 Jul 2022 14:15:11 +0800
Subject: [PATCH] x86: fix efi binary generation issue in cross compilation env
Expand All @@ -12,11 +12,12 @@ Signed-off-by: Naveen Saini <[email protected]>
arch/x86/zefi/zefi.py | 5 ++++-
boards/x86/ehl_crb/CMakeLists.txt | 1 +
boards/x86/qemu_x86/CMakeLists.txt | 1 +
boards/x86/rpl_crb/CMakeLists.txt | 1 +
boards/x86/up_squared/CMakeLists.txt | 1 +
4 files changed, 7 insertions(+), 1 deletion(-)
5 files changed, 8 insertions(+), 1 deletion(-)

diff --git a/arch/x86/zefi/zefi.py b/arch/x86/zefi/zefi.py
index 1e95958bff..b356198aa6 100755
index 99c188ecd0..1cd86a21cd 100755
--- a/arch/x86/zefi/zefi.py
+++ b/arch/x86/zefi/zefi.py
@@ -109,8 +109,10 @@ def build_elf(elf_file, include_dirs):
Expand Down Expand Up @@ -63,6 +64,18 @@ index 8d227f8b26..a5d6480bc3 100644
$<$<BOOL:${CMAKE_VERBOSE_MAKEFILE}>:--verbose>
WORKING_DIRECTORY ${PROJECT_BINARY_DIR}
)
diff --git a/boards/x86/rpl_crb/CMakeLists.txt b/boards/x86/rpl_crb/CMakeLists.txt
index 8bd6e36099..7316f23759 100644
--- a/boards/x86/rpl_crb/CMakeLists.txt
+++ b/boards/x86/rpl_crb/CMakeLists.txt
@@ -7,6 +7,7 @@ set_property(GLOBAL APPEND PROPERTY extra_post_build_commands
-i ${ZEPHYR_BASE}/include
$<$<BOOL:${CONFIG_LEGACY_INCLUDE_PATH}>:${ZEPHYR_BASE}/include/zephyr>
-f ${PROJECT_BINARY_DIR}/${CONFIG_KERNEL_BIN_NAME}.elf
+ -s ${SYSROOT_DIR}
$<$<BOOL:${CMAKE_VERBOSE_MAKEFILE}>:--verbose>
WORKING_DIRECTORY ${PROJECT_BINARY_DIR}
)
diff --git a/boards/x86/up_squared/CMakeLists.txt b/boards/x86/up_squared/CMakeLists.txt
index b867282d60..43cd081b21 100644
--- a/boards/x86/up_squared/CMakeLists.txt
Expand Down

0 comments on commit b0173e0

Please sign in to comment.