-
Notifications
You must be signed in to change notification settings - Fork 5
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
x86: Refresh patch to include efi fix for up_squared board
Include fix for generating efi binary file for the up_squared board, which was missed in v3.5 upgrade. Signed-off-by: Naveen Saini <[email protected]>
- Loading branch information
Showing
1 changed file
with
19 additions
and
6 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,4 +1,4 @@ | ||
From 67971b0be2230c2a691561e55a023b59c66bad87 Mon Sep 17 00:00:00 2001 | ||
From 25cf09358eebde64474cbf0759974e2087d4dcc6 Mon Sep 17 00:00:00 2001 | ||
From: Naveen Saini <[email protected]> | ||
Date: Tue, 31 Oct 2023 16:57:31 +0800 | ||
Subject: [PATCH] x86: fix efi binary generation issue in cross compilation env | ||
|
@@ -9,11 +9,12 @@ Upstream-Status: Inappropriate [Cross-compilation specific] | |
|
||
Signed-off-by: Naveen Saini <[email protected]> | ||
--- | ||
arch/x86/zefi/zefi.py | 5 ++++- | ||
boards/x86/intel_adl/CMakeLists.txt | 1 + | ||
boards/x86/intel_ehl/CMakeLists.txt | 1 + | ||
boards/x86/intel_rpl/CMakeLists.txt | 1 + | ||
4 files changed, 7 insertions(+), 1 deletion(-) | ||
arch/x86/zefi/zefi.py | 5 ++++- | ||
boards/x86/intel_adl/CMakeLists.txt | 1 + | ||
boards/x86/intel_ehl/CMakeLists.txt | 1 + | ||
boards/x86/intel_rpl/CMakeLists.txt | 1 + | ||
boards/x86/up_squared/CMakeLists.txt | 1 + | ||
5 files changed, 8 insertions(+), 1 deletion(-) | ||
|
||
diff --git a/arch/x86/zefi/zefi.py b/arch/x86/zefi/zefi.py | ||
index 99c188ecd0..1cd86a21cd 100755 | ||
|
@@ -67,6 +68,18 @@ diff --git a/boards/x86/intel_rpl/CMakeLists.txt b/boards/x86/intel_rpl/CMakeLis | |
index 2dc5afcc32..7981e576f2 100644 | ||
--- a/boards/x86/intel_rpl/CMakeLists.txt | ||
+++ b/boards/x86/intel_rpl/CMakeLists.txt | ||
@@ -6,6 +6,7 @@ set_property(GLOBAL APPEND PROPERTY extra_post_build_commands | ||
-o ${CMAKE_OBJCOPY} | ||
-i ${ZEPHYR_BASE}/include | ||
-f ${PROJECT_BINARY_DIR}/${CONFIG_KERNEL_BIN_NAME}.elf | ||
+ -s ${SYSROOT_DIR} | ||
$<$<BOOL:${CMAKE_VERBOSE_MAKEFILE}>:--verbose> | ||
WORKING_DIRECTORY ${PROJECT_BINARY_DIR} | ||
) | ||
diff --git a/boards/x86/up_squared/CMakeLists.txt b/boards/x86/up_squared/CMakeLists.txt | ||
index 2dc5afcc32..7981e576f2 100644 | ||
--- a/boards/x86/up_squared/CMakeLists.txt | ||
+++ b/boards/x86/up_squared/CMakeLists.txt | ||
@@ -6,6 +6,7 @@ set_property(GLOBAL APPEND PROPERTY extra_post_build_commands | ||
-o ${CMAKE_OBJCOPY} | ||
-i ${ZEPHYR_BASE}/include | ||
|