Skip to content

Commit

Permalink
obconf-qt: Backport fix for invalid conversion from xmlError
Browse files Browse the repository at this point in the history
Signed-off-by: Rob Woolley <[email protected]>
  • Loading branch information
robwoolley authored and schnitzeltony committed May 18, 2024
1 parent c38fbea commit 8238b83
Show file tree
Hide file tree
Showing 2 changed files with 36 additions and 1 deletion.
Original file line number Diff line number Diff line change
@@ -0,0 +1,34 @@
Fix invalid conversion from xmlError

src/obconf-qt.cpp: In function 'int main(int, char**)':
src/obconf-qt.cpp:233:36: error: invalid conversion from 'const xmlError*' {aka 'const _xmlError*'} to 'xmlErrorPtr' {aka '_xmlError*'} [-fpermissive]

Upstream-Status: Backport[https://github.com/lxqt/obconf-qt/commit/9fc5e566ea6559c27238c9dd5ae914b767f6c251]

Signed-off-by: Rob Woolley <[email protected]>

From 9fc5e566ea6559c27238c9dd5ae914b767f6c251 Mon Sep 17 00:00:00 2001
From: Tsu Jan <[email protected]>
Date: Sun, 14 Jan 2024 14:28:24 +0330
Subject: [PATCH] Fixed compilation

Fixes https://github.com/lxqt/obconf-qt/issues/224
---
CHANGELOG | 4 ++++
CMakeLists.txt | 2 +-
src/obconf-qt.cpp | 2 +-
3 files changed, 6 insertions(+), 2 deletions(-)

diff --git a/src/obconf-qt.cpp b/src/obconf-qt.cpp
index e07c236..0d5b442 100644
--- a/src/obconf-qt.cpp
+++ b/src/obconf-qt.cpp
@@ -230,7 +230,7 @@ int main(int argc, char** argv) {

/* look for parsing errors */
{
- xmlErrorPtr e = xmlGetLastError();
+ const xmlError *e = xmlGetLastError();

if(e) {
QString message = QObject::tr("Error while parsing the Openbox configuration file. Your configuration file is not valid XML.\n\nMessage: %1")
3 changes: 2 additions & 1 deletion recipes-lxqt/obconf-qt/obconf-qt.bb
Original file line number Diff line number Diff line change
Expand Up @@ -6,7 +6,8 @@ inherit lxqt qt5-translation pkgconfig

DEPENDS += "qtx11extras openbox"

SRC_URI += "file://0001-finding-sed-does-not-work-and-is-not-neccessary.patch"
SRC_URI += "file://0001-finding-sed-does-not-work-and-is-not-neccessary.patch \
file://Fix-invalid-conversion-from-xmlError.patch"
SRCREV = "b8d486b8be0e66570a80489c3e9084ce143ffa42"
PV = "0.16.2"

Expand Down

0 comments on commit 8238b83

Please sign in to comment.