-
Notifications
You must be signed in to change notification settings - Fork 32
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
obconf-qt: Backport fix for invalid conversion from xmlError
Signed-off-by: Rob Woolley <[email protected]>
- Loading branch information
1 parent
c38fbea
commit 8238b83
Showing
2 changed files
with
36 additions
and
1 deletion.
There are no files selected for viewing
34 changes: 34 additions & 0 deletions
34
recipes-lxqt/obconf-qt/files/Fix-invalid-conversion-from-xmlError.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,34 @@ | ||
Fix invalid conversion from xmlError | ||
|
||
src/obconf-qt.cpp: In function 'int main(int, char**)': | ||
src/obconf-qt.cpp:233:36: error: invalid conversion from 'const xmlError*' {aka 'const _xmlError*'} to 'xmlErrorPtr' {aka '_xmlError*'} [-fpermissive] | ||
|
||
Upstream-Status: Backport[https://github.com/lxqt/obconf-qt/commit/9fc5e566ea6559c27238c9dd5ae914b767f6c251] | ||
|
||
Signed-off-by: Rob Woolley <[email protected]> | ||
|
||
From 9fc5e566ea6559c27238c9dd5ae914b767f6c251 Mon Sep 17 00:00:00 2001 | ||
From: Tsu Jan <[email protected]> | ||
Date: Sun, 14 Jan 2024 14:28:24 +0330 | ||
Subject: [PATCH] Fixed compilation | ||
|
||
Fixes https://github.com/lxqt/obconf-qt/issues/224 | ||
--- | ||
CHANGELOG | 4 ++++ | ||
CMakeLists.txt | 2 +- | ||
src/obconf-qt.cpp | 2 +- | ||
3 files changed, 6 insertions(+), 2 deletions(-) | ||
|
||
diff --git a/src/obconf-qt.cpp b/src/obconf-qt.cpp | ||
index e07c236..0d5b442 100644 | ||
--- a/src/obconf-qt.cpp | ||
+++ b/src/obconf-qt.cpp | ||
@@ -230,7 +230,7 @@ int main(int argc, char** argv) { | ||
|
||
/* look for parsing errors */ | ||
{ | ||
- xmlErrorPtr e = xmlGetLastError(); | ||
+ const xmlError *e = xmlGetLastError(); | ||
|
||
if(e) { | ||
QString message = QObject::tr("Error while parsing the Openbox configuration file. Your configuration file is not valid XML.\n\nMessage: %1") |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters