Skip to content

Commit

Permalink
u-boot-iot2050: Add patch to restore up to 3 USB storag devices
Browse files Browse the repository at this point in the history
Also pending upstream.

Signed-off-by: Jan Kiszka <[email protected]>
  • Loading branch information
jan-kiszka authored and BaochengSu committed Oct 23, 2023
1 parent 51b3c0b commit e1ccc56
Show file tree
Hide file tree
Showing 2 changed files with 36 additions and 0 deletions.
Original file line number Diff line number Diff line change
@@ -0,0 +1,35 @@
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
From: Jan Kiszka <[email protected]>
Date: Sun, 22 Oct 2023 17:09:33 +0200
Subject: [PATCH] iot2050: Allow for more than 1 USB storage device

This was lost in refactoring while some users of the IOT2050 expect it
to work: Make sure that up to 3 USB storage devices are probed.

Fixes: 53873974a4b0 ("include: armv7: Enable distroboot across all configs")
Signed-off-by: Jan Kiszka <[email protected]>
Reviewed-by: Heinrich Schuchardt <[email protected]>
---
include/configs/iot2050.h | 9 +++++++++
1 file changed, 9 insertions(+)

diff --git a/include/configs/iot2050.h b/include/configs/iot2050.h
index 4968722d18f..94a9c767882 100644
--- a/include/configs/iot2050.h
+++ b/include/configs/iot2050.h
@@ -15,6 +15,15 @@

#include <configs/ti_armv7_common.h>

+/* allow up to 3 USB storage devices */
+#ifdef CONFIG_CMD_USB
+#undef BOOT_TARGET_USB
+#define BOOT_TARGET_USB(func) \
+ func(USB, usb, 0) \
+ func(USB, usb, 1) \
+ func(USB, usb, 2)
+#endif
+
/*
* This defines all MMC devices, even if the basic variant has no mmc1.
* The non-supported device will be removed from the boot targets during
1 change: 1 addition & 0 deletions recipes-bsp/u-boot/u-boot-iot2050_2023.10.bb
Original file line number Diff line number Diff line change
Expand Up @@ -16,6 +16,7 @@ SRC_URI += " \
file://0002-tools-iot2050-sign-fw.sh-Make-localization-of-tools-.patch \
file://0003-board-siemens-iot2050-Fix-logical-bug-in-PG1-PG2-det.patch \
file://0004-board-siemens-iot2050-Fix-M.2-detection.patch \
file://0005-iot2050-Allow-for-more-than-1-USB-storage-device.patch \
"

SRC_URI[sha256sum] = "e00e6c6f014e046101739d08d06f328811cebcf5ae101348f409cbbd55ce6900"
Expand Down

0 comments on commit e1ccc56

Please sign in to comment.