-
-
Notifications
You must be signed in to change notification settings - Fork 3.2k
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
enhance(recoll): configure without --disable-python-module
Added Python support to recoll package
- Loading branch information
Showing
2 changed files
with
80 additions
and
2 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,77 @@ | ||
diff --git src/python/recoll/pyrclextract.cpp src/python/recoll/pyrclextract.cpp | ||
index 96325856..f6040848 100644 | ||
--- src/python/recoll/pyrclextract.cpp | ||
+++ src/python/recoll/pyrclextract.cpp | ||
@@ -16,9 +16,9 @@ | ||
*/ | ||
|
||
|
||
-#include <Python.h> | ||
-#include <structmember.h> | ||
-#include <bytearrayobject.h> | ||
+#include <@TERMUX_PREFIX@/include/python3.10/Python.h> | ||
+#include <@TERMUX_PREFIX@/include/python3.10/structmember.h> | ||
+#include <@TERMUX_PREFIX@/include/python3.10/bytearrayobject.h> | ||
|
||
#include <string> | ||
#include <memory> | ||
diff --git src/python/recoll/pyrecoll.cpp src/python/recoll/pyrecoll.cpp | ||
index 18df550b..0cb42b91 100644 | ||
--- src/python/recoll/pyrecoll.cpp | ||
+++ src/python/recoll/pyrecoll.cpp | ||
@@ -15,9 +15,9 @@ | ||
* 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA. | ||
*/ | ||
|
||
-#include <Python.h> | ||
-#include <structmember.h> | ||
-#include <bytesobject.h> | ||
+#include <@TERMUX_PREFIX@/include/python3.10/Python.h> | ||
+#include <@TERMUX_PREFIX@/include/python3.10/structmember.h> | ||
+#include <@TERMUX_PREFIX@/include/python3.10/bytesobject.h> | ||
|
||
#include <string> | ||
#include <iostream> | ||
diff --git src/python/recoll/pyrecoll.h src/python/recoll/pyrecoll.h | ||
index 8d6403f8..8b3cd7a3 100644 | ||
--- src/python/recoll/pyrecoll.h | ||
+++ src/python/recoll/pyrecoll.h | ||
@@ -19,7 +19,7 @@ | ||
|
||
/* Shared definitions for pyrecoll.cpp and pyrclextract.cpp */ | ||
|
||
-#include <Python.h> | ||
+#include <@TERMUX_PREFIX@/include/python3.10/Python.h> | ||
|
||
#include <memory> | ||
#include <string> | ||
diff --git src/python/recoll/pyresultstore.cpp src/python/recoll/pyresultstore.cpp | ||
index 45ee01a3..b4a77deb 100644 | ||
--- src/python/recoll/pyresultstore.cpp | ||
+++ src/python/recoll/pyresultstore.cpp | ||
@@ -15,9 +15,9 @@ | ||
* 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA. | ||
*/ | ||
|
||
-#include <Python.h> | ||
-#include <structmember.h> | ||
-#include <bytesobject.h> | ||
+#include <@TERMUX_PREFIX@/include/python3.10/Python.h> | ||
+#include <@TERMUX_PREFIX@/include/python3.10/structmember.h> | ||
+#include <@TERMUX_PREFIX@/include/python3.10/bytesobject.h> | ||
|
||
#include <string> | ||
#include <iostream> | ||
diff --git src/python/recoll/setup.py.in src/python/recoll/setup.py.in | ||
index 0409cb9d..7812ebce 100644 | ||
--- src/python/recoll/setup.py.in | ||
+++ src/python/recoll/setup.py.in | ||
@@ -18,7 +18,7 @@ if "CYGWIN" in os.environ: | ||
else: | ||
libraries = ['recoll'] | ||
|
||
-extra_compile_args = ['-std=c++11'] | ||
+extra_compile_args = ['-std=c++11', '-fPIC'] | ||
|
||
VERSION = open(os.path.join(top, "RECOLL-VERSION.txt")).read().strip() | ||
|