-
-
Notifications
You must be signed in to change notification settings - Fork 25
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
(cherry picked from commit fe3a5a9)
- Loading branch information
Showing
2 changed files
with
46 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,6 @@ | ||
project pkg { | ||
arches = ["x86_64"] | ||
rpm { | ||
spec = "codium-marketplace.spec" | ||
} | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,40 @@ | ||
# ref: https://aur.archlinux.org/cgit/aur.git/tree/PKGBUILD?h=vscodium-marketplace | ||
|
||
Name: codium-marketplace | ||
Version: 1.65.0 | ||
Release: 1%?dist | ||
Summary: Enable vscode marketplace in vscodium | ||
License: MIT | ||
BuildArch: noarch | ||
URL: https://marketplace.visualstudio.com/vscode | ||
Requires: codium sed | ||
|
||
%description | ||
This package replaces the default marketplace (https://open-vsx.org/) | ||
to the official one used by vscode. | ||
|
||
%posttrans | ||
if [ $1 -gt 1 ]; then # update/install | ||
sed -i -e 's/^[[:blank:]]*"serviceUrl":.*/ "serviceUrl": "https:\/\/marketplace.visualstudio.com\/_apis\/public\/gallery",/' \ | ||
-e '/^[[:blank:]]*"cacheUrl/d' \ | ||
-e '/^[[:blank:]]*"serviceUrl/a\ "cacheUrl": "https:\/\/vscode.blob.core.windows.net\/gallery\/index",' \ | ||
-e 's/^[[:blank:]]*"itemUrl":.*/ "itemUrl": "https:\/\/marketplace.visualstudio.com\/items"/' \ | ||
-e '/^[[:blank:]]*"linkProtectionTrustedDomains/d' \ | ||
/usr/share/codium/resources/app/product.json || true | ||
fi | ||
|
||
%preun | ||
sed -i -e 's/^[[:blank:]]*"serviceUrl":.*/ "serviceUrl": "https:\/\/open-vsx.org\/vscode\/gallery",/' \ | ||
-e '/^[[:blank:]]*"cacheUrl/d' \ | ||
-e 's/^[[:blank:]]*"itemUrl":.*/ "itemUrl": "https:\/\/open-vsx.org\/vscode\/item"/' \ | ||
-e '/^[[:blank:]]*"linkProtectionTrustedDomains/d' \ | ||
-e '/^[[:blank:]]*"documentationUrl/i\ "linkProtectionTrustedDomains": ["https://open-vsx.org"],' \ | ||
/usr/share/codium/resources/app/product.json || true | ||
|
||
%triggerin -- codium | ||
sed -i -e 's/^[[:blank:]]*"serviceUrl":.*/ "serviceUrl": "https:\/\/marketplace.visualstudio.com\/_apis\/public\/gallery",/' \ | ||
-e '/^[[:blank:]]*"cacheUrl/d' \ | ||
-e '/^[[:blank:]]*"serviceUrl/a\ "cacheUrl": "https:\/\/vscode.blob.core.windows.net\/gallery\/index",' \ | ||
-e 's/^[[:blank:]]*"itemUrl":.*/ "itemUrl": "https:\/\/marketplace.visualstudio.com\/items"/' \ | ||
-e '/^[[:blank:]]*"linkProtectionTrustedDomains/d' \ | ||
/usr/share/codium/resources/app/product.json || true |