-
-
Notifications
You must be signed in to change notification settings - Fork 25
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
* add: opengamepadui * dont limit arc h (cherry picked from commit b5371d7) Co-authored-by: Cappy Ishihara <[email protected]>
- Loading branch information
1 parent
c99edf5
commit 1facc18
Showing
3 changed files
with
88 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,6 @@ | ||
project pkg { | ||
// arches = ["x86_64"] | ||
rpm { | ||
spec = "opengamepadui.spec" | ||
} | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,81 @@ | ||
Name: opengamepadui | ||
Version: 0.34.1 | ||
Release: 1%{?dist} | ||
Summary: Open source gamepad-native game launcher and overlay | ||
|
||
License: GPLv3 | ||
URL: https://github.com/ShadowBlip/OpenGamepadUI | ||
Packager: Cappy Ishihara <[email protected]> | ||
|
||
BuildRequires: godot | ||
BuildRequires: scons | ||
BuildRequires: make | ||
BuildRequires: gcc-c++ | ||
BuildRequires: pkgconfig | ||
BuildRequires: gcc | ||
BuildRequires: libXinerama-devel | ||
BuildRequires: libXi-devel | ||
BuildRequires: mesa-libGL-devel | ||
BuildRequires: alsa-lib-devel | ||
BuildRequires: pulseaudio-libs-devel | ||
BuildRequires: libevdev-devel | ||
BuildRequires: git | ||
BuildRequires: wget | ||
BuildRequires: unzip | ||
BuildRequires: dbus-devel | ||
BuildRequires: pkgconfig(xres) | ||
BuildRequires: pkgconfig(x11) | ||
BuildRequires: pkgconfig(xrandr) | ||
BuildRequires: pkgconfig(xcb) | ||
BuildRequires: pkgconfig(xext) | ||
BuildRequires: pkgconfig(xau) | ||
BuildRequires: pkgconfig(xtst) | ||
BuildRequires: pkgconfig(xdmcp) | ||
BuildRequires: systemd-rpm-macros | ||
|
||
Requires: godot-runner | ||
Recommends: inputplumber | ||
Recommends: powerstation | ||
|
||
%global build_dir %{name}-%{version} | ||
|
||
%description | ||
Open Gamepad UI is a free and open source game launcher and overlay written using the Godot Game Engine 4 designed with a gamepad native experience in mind. Its goal is to provide an open and extendable foundation to launch and play games. It also implements a gamepad input system that can allow you to | ||
remap gamepad input to mouse and keyboard inputs. | ||
|
||
%prep | ||
|
||
# We clone the repo from Git here because the build script requires | ||
# submodules to be present in the source directory. | ||
rm -rf %{build_dir} | ||
git clone %{url} %{build_dir} -b v%{version} | ||
cd %{build_dir} | ||
git checkout tags/v%{version} | ||
|
||
%build | ||
cd %{build_dir} | ||
make import | ||
%make_build | ||
|
||
|
||
%install | ||
cd %{build_dir} | ||
%make_install PREFIX=%{buildroot}%{_prefix} INSTALL_PREFIX=%{_prefix} | ||
|
||
|
||
%files | ||
%license %{build_dir}/LICENSE | ||
%doc %{build_dir}/docs/ | ||
%{_bindir}/opengamepadui | ||
%{_datadir}/opengamepadui/*.so | ||
%{_datadir}/opengamepadui/scripts/* | ||
%{_datadir}/opengamepadui/opengamepad-ui.* | ||
%{_datadir}/applications/opengamepadui.desktop | ||
%{_datadir}/icons/hicolor/scalable/apps/opengamepadui.svg | ||
%{_datadir}/polkit-1/actions/* | ||
%{_userunitdir}/* | ||
|
||
|
||
%changelog | ||
* Sun Oct 20 2024 Cappy Ishihara <[email protected]> | ||
- Initial Package |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1 @@ | ||
rpm.version(gh("ShadowBlip/OpenGamepadUI")); |