Skip to content

Commit

Permalink
Merge branch 'frawhide' into mado/rm/iosevka-fusion
Browse files Browse the repository at this point in the history
  • Loading branch information
madonuko committed Apr 15, 2024
2 parents 223d5c4 + 128412b commit 2126384
Show file tree
Hide file tree
Showing 67 changed files with 745 additions and 105 deletions.
1 change: 1 addition & 0 deletions .backportrc.json
Original file line number Diff line number Diff line change
@@ -1,6 +1,7 @@
{
"repoOwner": "terrapkg",
"repoName": "packages",
"resetAuthor": true,
"targetBranchChoices": ["f38", "f39", "f40", "frawhide"],
"branchLabelMapping": {
"^sync-(.+)$": "$1"
Expand Down
9 changes: 1 addition & 8 deletions .github/workflows/autobuild.yml
Original file line number Diff line number Diff line change
Expand Up @@ -40,7 +40,7 @@ jobs:
strategy:
matrix:
pkg: ${{ fromJson(needs.manifest.outputs.build_matrix) }}
version: ["39"]
version: ["rawhide"]
fail-fast: false
runs-on: ${{ matrix.pkg.arch == 'aarch64' && 'ARM64' || 'ubuntu-latest' }}
container:
Expand All @@ -54,13 +54,6 @@ jobs:
- name: Set up git repository
run: git config --global --add safe.directory "$GITHUB_WORKSPACE"

- name: Cache buildroot
id: br-cache
uses: actions/cache@v4
with:
path: /var/cache
key: ${{ runner.os }}-br-${{ matrix.version }}-${{ matrix.pkg.arch }}

- name: Include custom build template instead of package default
run: |
cp -v anda/terra/mock-configs/terra.tpl /etc/mock/templates/terra.tpl
Expand Down
13 changes: 13 additions & 0 deletions .github/workflows/sync.yml
Original file line number Diff line number Diff line change
Expand Up @@ -8,7 +8,20 @@ jobs:
backport:
name: Backport/sync PR
runs-on: ubuntu-latest
if: github.event.pull_request.merged
steps:
- name: Install SSH signing key
run: |
mkdir -p ${{ runner.temp }}
echo "${{ secrets.SSH_SIGNING_KEY }}" > ${{ runner.temp }}/signing_key
chmod 0700 ${{ runner.temp }}/signing_key
- name: Setup Raboneko Signing
run: |
git config --global gpg.format "ssh"
git config --global user.signingkey "${{ runner.temp }}/signing_key"
git config --global commit.gpgsign true
- name: Backport Action
uses: sorenlouv/[email protected]
with:
Expand Down
4 changes: 2 additions & 2 deletions .github/workflows/update-nightly.yml
Original file line number Diff line number Diff line change
Expand Up @@ -17,11 +17,12 @@ jobs:
fetch-depth: 0
ssh-key: ${{ secrets.SSH_AUTHENTICATION_KEY }}

- name: Install SSH signing key
- name: Install SSH signing key & Set up git repository
run: |
mkdir -p ${{ runner.temp }}
echo "${{ secrets.SSH_SIGNING_KEY }}" > ${{ runner.temp }}/signing_key
chmod 0700 ${{ runner.temp }}/signing_key
git config --global --add safe.directory "$GITHUB_WORKSPACE"
- name: Run Nightly Update
run: anda update -vv --filters nightly=1
Expand All @@ -30,7 +31,6 @@ jobs:

- name: Save
run: |
git config --global --add safe.directory "*"
if [[ `git status --porcelain` ]]; then
git config user.name "Raboneko"
git config user.email "[email protected]"
Expand Down
4 changes: 2 additions & 2 deletions .github/workflows/update.yml
Original file line number Diff line number Diff line change
Expand Up @@ -17,11 +17,12 @@ jobs:
fetch-depth: 0
ssh-key: ${{ secrets.SSH_AUTHENTICATION_KEY }}

- name: Install SSH signing key
- name: Install SSH signing key & Set up git repository
run: |
mkdir -p ${{ runner.temp }}
echo "${{ secrets.SSH_SIGNING_KEY }}" > ${{ runner.temp }}/signing_key
chmod 0700 ${{ runner.temp }}/signing_key
git config --global --add safe.directory "$GITHUB_WORKSPACE"
- name: Run Update
run: anda update -vv
Expand All @@ -31,7 +32,6 @@ jobs:

- name: Save
run: |
git config --global --add safe.directory "*"
if [[ `git status --porcelain` ]]; then
git config user.name "Raboneko"
git config user.email "[email protected]"
Expand Down
2 changes: 1 addition & 1 deletion anda/apps/anki-bin/anki-bin.spec
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
Name: anki-bin
Version: 24.04
Version: 24.04.1
Release: 1%?dist
Summary: Flashcard program for using space repetition learning (Installed with wheel)
License: AGPL-3.0-or-later AND GPL-3.0-or-later AND LGPL-3.0-or-later AND MIT AND BSD-3-Clause AND CC-BY-SA-3.0 AND CC-BY-3.0 AND Apache-2.0 AND CC-BY-2.5
Expand Down
2 changes: 1 addition & 1 deletion anda/apps/anki-qt5/anki-qt5.spec
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
Name: anki-qt5
Version: 24.04
Version: 24.04.1
Release: 1%?dist
Summary: Flashcard program for using space repetition learning
License: AGPL-3.0-or-later AND GPL-3.0-or-later AND LGPL-3.0-or-later AND MIT AND BSD-3-Clause AND CC-BY-SA-3.0 AND CC-BY-3.0 AND Apache-2.0 AND CC-BY-2.5
Expand Down
2 changes: 1 addition & 1 deletion anda/apps/anki/anki.spec
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
Name: anki
Version: 24.04
Version: 24.04.1
Release: 1%?dist
Summary: Flashcard program for using space repetition learning
License: AGPL-3.0-or-later AND GPL-3.0-or-later AND LGPL-3.0-or-later AND MIT AND BSD-3-Clause AND CC-BY-SA-3.0 AND CC-BY-3.0 AND Apache-2.0 AND CC-BY-2.5
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -6,7 +6,7 @@
%global __provides_exclude_from %{_datadir}/%{name}/.*\\.so

Name: discord-canary-openasar
Version: 0.0.328
Version: 0.0.349
Release: 1%?dist
Summary: A snappier Discord rewrite with features like further customization and theming
License: MIT AND https://discord.com/terms
Expand Down
2 changes: 1 addition & 1 deletion anda/apps/discord-canary/discord-canary.spec
Original file line number Diff line number Diff line change
Expand Up @@ -6,7 +6,7 @@
%global __provides_exclude_from %{_datadir}/%{name}/.*\\.so

Name: discord-canary
Version: 0.0.328
Version: 0.0.349
Release: 1%?dist
Summary: Free Voice and Text Chat for Gamers
URL: discord.com
Expand Down
2 changes: 1 addition & 1 deletion anda/apps/discord-openasar/discord-openasar.spec
Original file line number Diff line number Diff line change
Expand Up @@ -6,7 +6,7 @@
%global __provides_exclude_from %{_datadir}/%{name}/.*\\.so

Name: discord-openasar
Version: 0.0.47
Version: 0.0.49
Release: 1%?dist
Summary: A snappier Discord rewrite with features like further customization and theming
License: MIT AND https://discord.com/terms
Expand Down
2 changes: 1 addition & 1 deletion anda/apps/discord-ptb-openasar/discord-ptb-openasar.spec
Original file line number Diff line number Diff line change
Expand Up @@ -6,7 +6,7 @@
%global __provides_exclude_from %{_datadir}/%{name}/.*\\.so

Name: discord-ptb-openasar
Version: 0.0.76
Version: 0.0.79
Release: 1%?dist
Summary: A snappier Discord rewrite with features like further customization and theming
License: MIT AND https://discord.com/terms
Expand Down
2 changes: 1 addition & 1 deletion anda/apps/discord-ptb/discord-ptb.spec
Original file line number Diff line number Diff line change
Expand Up @@ -6,7 +6,7 @@
%global __provides_exclude_from %{_datadir}/%{name}/.*\\.so

Name: discord-ptb
Version: 0.0.76
Version: 0.0.79
Release: 1%?dist
Summary: Free Voice and Text Chat for Gamers.
URL: https://discord.com
Expand Down
2 changes: 1 addition & 1 deletion anda/apps/discord/discord.spec
Original file line number Diff line number Diff line change
Expand Up @@ -6,7 +6,7 @@
%global __provides_exclude_from %{_datadir}/%{name}/.*\\.so

Name: discord
Version: 0.0.47
Version: 0.0.49
Release: 1%?dist
Summary: Free Voice and Text Chat for Gamers
URL: https://discord.com
Expand Down
4 changes: 2 additions & 2 deletions anda/apps/mpv/mpv-nightly.spec
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
%global commit 4ce4bf1795e6dfd6f1ddf07fb348ce5d191ab1dc
%global commit 919a042833202817492d1744e087836b6b02f63f
%global shortcommit %(c=%{commit}; echo ${c:0:7})
%global commit_date 20240404
%global commit_date 20240415
%global ver v0.37.0

Name: mpv-nightly
Expand Down
2 changes: 1 addition & 1 deletion anda/apps/voicevox/voicevox.spec
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
%global nodev 18.13.0
%global npmv 8.19.3
%global ver 0.18.0
%global ver 0.18.1
%define debug_package %nil
%global _build_id_links none

Expand Down
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
%global forgeurl https://github.com/KDE/latte-dock/

%global commit b4b16f61f1d69c994701f149e54335c40b9b201d
%global commit 3365b2c4009b7b0c99413f2e6ec5c20ba061544b
%global shortcommit %(c=%{commit}; echo ${c:0:7})
%global commit_date %(date '+%Y%m%d')
%global snapshot_info %{commit_date}.%{shortcommit}
Expand Down
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
%global forgeurl https://gitlab.com/ubports/development/core/lomiri-app-launch
%global commit 0011f74e9377fcde3166374b05301444131ac0e5
%global commit 11bddd982b3643aacdf052cf339ae1ca1873fbb2
%forgemeta

Name: lomiri-app-launch
Expand Down
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
%global forgeurl https://gitlab.com/ubports/development/core/lomiri-system-settings
%global commit a38142e39a6e9b9312e79dbcf5fad11daa1d1b04
%global commit 35a882b40ef100739a4f083a1b6fcdc7c5ebef57
%forgemeta

Name: lomiri-system-settings
Expand Down
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
%define _ubuntu_rel 1ubuntu2
%define _ubuntu_rel 1ubuntu3

Name: unity-session
Summary: Lightdm profile for Unity 7
Expand Down
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
Name: ayatana-indicator-notifications
Summary: Ayatana Indicator Notifications Applet
Version: 23.10.0
Release: 1%{?dist}
Version: 23.10.1
Release: 1%?dist
License: GPL-3.0
URL: https://github.com/AyatanaIndicators/ayatana-indicator-notifications
Source0: %{url}/archive/refs/tags/%{version}.tar.gz
Expand Down
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
Name: ayatana-indicator-sound
Summary: Ayatana Indicator Sound Applet
Version: 23.10.3
Release: 1%{?dist}
Version: 24.4.0
Release: 1%?dist
License: GPLv3
URL: https://github.com/AyatanaIndicators/ayatana-indicator-sound
Source0: %{url}/archive/refs/tags/%{version}.tar.gz
Expand Down
2 changes: 1 addition & 1 deletion anda/devs/codium/codium.spec
Original file line number Diff line number Diff line change
Expand Up @@ -12,7 +12,7 @@
%endif

Name: codium
Version: 1.87.2.24072
Version: 1.88.1.24104
Release: 1%?dist
Summary: Code editing. Redefined.
License: MIT
Expand Down
2 changes: 1 addition & 1 deletion anda/docker/containerd/containerd.spec
Original file line number Diff line number Diff line change
Expand Up @@ -7,7 +7,7 @@

# https://github.com/containerd/containerd
%global goipath github.com/containerd/containerd
Version: 1.7.14
Version: 1.7.15

%gometa

Expand Down
2 changes: 1 addition & 1 deletion anda/fonts/nerd-fonts/nerd-fonts.spec
Original file line number Diff line number Diff line change
Expand Up @@ -4,7 +4,7 @@ Nerd Fonts is a project that patches developer targeted fonts with a high
number of glyphs (icons).}

Name: nerd-fonts
Version: 3.2.0
Version: 3.2.1
Release: 1%?dist
URL: https://nerdfonts.com/
Source0: https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v%version/readme.md
Expand Down
2 changes: 1 addition & 1 deletion anda/fonts/sarasa-gothic/sarasa-gothic-fonts.spec
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
Name: sarasa-gothic-fonts
Version: 1.0.9
Version: 1.0.10
Release: 1%?dist
URL: https://github.com/be5invis/Sarasa-Gothic
Source0: %url/releases/download/v%version/Sarasa-TTC-%version.7z
Expand Down
4 changes: 2 additions & 2 deletions anda/games/osu-lazer/osu-lazer.spec
Original file line number Diff line number Diff line change
@@ -1,9 +1,9 @@
%define osuresver 2024.404.0
%define osuresver 2024.410.0
%global debug_package %{nil}
%define __strip /bin/true

Name: osu-lazer
Version: 2024.312.1
Version: 2024.412.1
Release: 1%?dist
Summary: The future of osu! and the beginning of an open era! Commonly known by the codename osu!lazer. Pew pew.
ExclusiveArch: x86_64
Expand Down
4 changes: 2 additions & 2 deletions anda/games/prismlauncher-nightly/prismlauncher-nightly.spec
Original file line number Diff line number Diff line change
@@ -1,13 +1,13 @@
%global real_name prismlauncher
%global nice_name PrismLauncher

%global commit 90097f130963c77280aa88de794c6cb2bc5cc102
%global commit 1a994e8aedeafe0265f0e078d976d2a6d6919032
%global shortcommit %(c=%{commit}; echo ${c:0:7})
%global libnbtplusplus_commit a5e8fd52b8bf4ab5d5bcc042b2a247867589985f
%global quazip_commit 6117161af08e366c37499895b00ef62f93adc345
%global tomlplusplus_commit 7eb2ffcc09f8e9890dc0b77ff8ab00fc53b1f2b8

%global commit_date 20240403
%global commit_date 20240409
%global snapshot_info %{commit_date}.%{shortcommit}

%bcond_without qt6
Expand Down
Original file line number Diff line number Diff line change
@@ -1,13 +1,13 @@
%global real_name prismlauncher
%global nice_name PrismLauncher

%global commit 90097f130963c77280aa88de794c6cb2bc5cc102
%global commit 1a994e8aedeafe0265f0e078d976d2a6d6919032
%global shortcommit %(c=%{commit}; echo ${c:0:7})
%global libnbtplusplus_commit a5e8fd52b8bf4ab5d5bcc042b2a247867589985f
%global quazip_commit 6117161af08e366c37499895b00ef62f93adc345
%global tomlplusplus_commit 7eb2ffcc09f8e9890dc0b77ff8ab00fc53b1f2b8

%global commit_date 20240403
%global commit_date 20240409
%global snapshot_info %{commit_date}.%{shortcommit}

%bcond_with qt6
Expand Down
4 changes: 2 additions & 2 deletions anda/langs/crystal/crystal/crystal.spec
Original file line number Diff line number Diff line change
@@ -1,8 +1,8 @@
%define debug_package %nil

Name: crystal
Version: 1.11.2
Release: 1%{?dist}
Version: 1.12.1
Release: 1%?dist
Summary: The Crystal Programming Language
License: Apache-2.0
URL: https://crystal-lang.org/
Expand Down
2 changes: 1 addition & 1 deletion anda/langs/go/gendesk/golang-github-xyproto-gendesk.spec
Original file line number Diff line number Diff line change
Expand Up @@ -20,7 +20,7 @@ of information.}
%global godocs README.md

Name: %{goname}
Release: 2%{?dist}
Release: 1%{?dist}
Summary: Generate .desktop files and download .png icons

License: BSD-3-Clause
Expand Down
2 changes: 1 addition & 1 deletion anda/langs/groovy/groovy-docs/groovy-docs.spec
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
Name: groovy-docs
Version: 4.0.20
Version: 4.0.21
Release: 1%?dist
Summary: Documentation for the Groovy programming language
URL: https://groovy-lang.org/
Expand Down
2 changes: 1 addition & 1 deletion anda/langs/groovy/groovy.spec
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
Name: groovy
Version: 4.0.20
Version: 4.0.21
Release: 1%?dist
Summary: A multi-faceted language for the Java platform
BuildArch: noarch
Expand Down
4 changes: 2 additions & 2 deletions anda/langs/nim/nim-nightly/nim-nightly.spec
Original file line number Diff line number Diff line change
@@ -1,8 +1,8 @@
%global csrc_commit 561b417c65791cd8356b5f73620914ceff845d10
%global commit 9e1b170a09d2228214807a8c01fe37b874f77d58
%global commit bcc935ae6a2fe4748241c0f0f01df611981a94a8
%global shortcommit %(c=%{commit}; echo ${c:0:7})
%global ver 2.1.1
%global commit_date 20240404
%global commit_date 20240414
%global debug_package %nil

Name: nim-nighlty
Expand Down
2 changes: 1 addition & 1 deletion anda/langs/python/ruff/python3-ruff.spec
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
%define debug_package %{nil}

Name: python3-ruff
Version: 0.3.5
Version: 0.3.7
Release: 1%?dist
Summary: An extremely fast Python linter, written in Rust
License: MIT
Expand Down
4 changes: 2 additions & 2 deletions anda/langs/rust/felix/rust-felix.spec
Original file line number Diff line number Diff line change
Expand Up @@ -2,8 +2,8 @@
%global crate felix

Name: rust-felix
Version: 2.12.1
Release: 1%{?dist}
Version: 2.13.0
Release: 1%?dist
Summary: Tui file manager with vim-like key mapping

License: MIT
Expand Down
2 changes: 1 addition & 1 deletion anda/langs/rust/gitoxide/rust-gitoxide.spec
Original file line number Diff line number Diff line change
Expand Up @@ -4,7 +4,7 @@
%global crate gitoxide

Name: rust-gitoxide
Version: 0.33.0
Version: 0.35.0
Release: 1%?dist
Summary: Command-line application for interacting with git repositories

Expand Down
2 changes: 1 addition & 1 deletion anda/langs/rust/nushell/nushell.spec
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
Name: nushell
Version: 0.92.0
Version: 0.92.2
Release: 1%?dist
Summary: A new type of shell
License: MIT
Expand Down
Loading

0 comments on commit 2126384

Please sign in to comment.