Skip to content

Commit

Permalink
Merge branch 'f39' into mado/w39/spacedrive
Browse files Browse the repository at this point in the history
  • Loading branch information
madonuko authored Jun 27, 2024
2 parents c2d50ff + e1a4779 commit 6d54f13
Show file tree
Hide file tree
Showing 21 changed files with 137 additions and 352 deletions.
2 changes: 1 addition & 1 deletion anda/apps/anki-qt5/anki-qt5.spec
Original file line number Diff line number Diff line change
Expand Up @@ -22,7 +22,7 @@ Anki is based on a theory called spaced repetition.
%prep
git clone https://github.com/ankitects/anki .
git checkout %version
%patch1 -p1
%patch 1 -p1

# See https://aur.archlinux.org/cgit/aur.git/tree/PKGBUILD?h=anki-qt5

Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -6,7 +6,7 @@
%global __provides_exclude_from %{_datadir}/%{name}/.*\\.so

Name: discord-canary-openasar
Version: 0.0.433
Version: 0.0.438
Release: 1%?dist
Summary: A snappier Discord rewrite with features like further customization and theming
License: MIT AND https://discord.com/terms
Expand Down
2 changes: 1 addition & 1 deletion anda/apps/discord-canary/discord-canary.spec
Original file line number Diff line number Diff line change
Expand Up @@ -6,7 +6,7 @@
%global __provides_exclude_from %{_datadir}/%{name}/.*\\.so

Name: discord-canary
Version: 0.0.433
Version: 0.0.438
Release: 1%?dist
Summary: Free Voice and Text Chat for Gamers
URL: discord.com
Expand Down
2 changes: 1 addition & 1 deletion anda/apps/discord-openasar/discord-openasar.spec
Original file line number Diff line number Diff line change
Expand Up @@ -6,7 +6,7 @@
%global __provides_exclude_from %{_datadir}/%{name}/.*\\.so

Name: discord-openasar
Version: 0.0.57
Version: 0.0.58
Release: 1%?dist
Summary: A snappier Discord rewrite with features like further customization and theming
License: MIT AND https://discord.com/terms
Expand Down
2 changes: 1 addition & 1 deletion anda/apps/discord/discord.spec
Original file line number Diff line number Diff line change
Expand Up @@ -6,7 +6,7 @@
%global __provides_exclude_from %{_datadir}/%{name}/.*\\.so

Name: discord
Version: 0.0.57
Version: 0.0.58
Release: 1%?dist
Summary: Free Voice and Text Chat for Gamers
URL: https://discord.com
Expand Down
4 changes: 2 additions & 2 deletions anda/apps/envision/envision.spec
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
%global commit 495ffef93bc987d96aa5acb2920c5d581ca99ea9
%global commit_date 20240624
%global commit b594f75778961c281daca398011914e9ac14b753
%global commit_date 20240625
%global shortcommit %(c=%{commit}; echo ${c:0:7})

Name: envision
Expand Down
9 changes: 9 additions & 0 deletions anda/devs/zed/nightly/anda.hcl
Original file line number Diff line number Diff line change
@@ -0,0 +1,9 @@
project pkg {
rpm {
spec = "zed-nightly.spec"
}
labels {
nightly = 1
large = 1
}
}
9 changes: 9 additions & 0 deletions anda/devs/zed/nightly/update.rhai
Original file line number Diff line number Diff line change
@@ -0,0 +1,9 @@
if filters.contains("nightly") {
rpm.global("commit", gh_commit("zed-industries/zed"));
if rpm.changed() {
let v = find("(\\d+\\.\\d+\\d+\\.\\d+)", find("\nversion = \"(\\d+\\.\\d+\\d+\\.\\d+)\"\n", gh_rawfile("zed-industries/zed", "main", "crates/zed/Cargo.toml"), 1), 1);
rpm.global("ver", v);
rpm.global("commit_date", date());
rpm.release();
}
}
97 changes: 97 additions & 0 deletions anda/devs/zed/nightly/zed-nightly.spec
Original file line number Diff line number Diff line change
@@ -0,0 +1,97 @@
%global commit 0129d4e2506d5ec5e50ef0968382770b9abec390
%global shortcommit %(c=%{commit}; echo ${c:0:7})
%global commit_date 20240619
%global ver 0.142.0

%bcond_without check

# Exclude input files from mangling
%global __brp_mangle_shebangs_exclude_from ^/usr/src/.*$

%global crate zed
%global app_id dev.zed.Zed-Nightly

Name: zed-nightly
Version: %ver^%commit_date.%shortcommit
Release: 1%?dist
Summary: Zed is a high-performance, multiplayer code editor

License: MIT
URL: https://zed.dev/
Source0: https://github.com/zed-industries/zed/archive/%{commit}.zip

Conflicts: zed
Provides: zed

BuildRequires: cargo-rpm-macros >= 24
BuildRequires: anda-srpm-macros
BuildRequires: gcc
BuildRequires: g++
BuildRequires: clang
BuildRequires: mold
BuildRequires: alsa-lib-devel
BuildRequires: fontconfig-devel
BuildRequires: wayland-devel
BuildRequires: libxkbcommon-x11-devel
BuildRequires: openssl-devel
BuildRequires: libzstd-devel
BuildRequires: perl-FindBin
BuildRequires: perl-IPC-Cmd
BuildRequires: perl-File-Compare
BuildRequires: perl-File-Copy
BuildRequires: perl-lib
BuildRequires: vulkan-loader

%description
Code at the speed of thought - Zed is a high-performance, multiplayer code editor from the creators of Atom and Tree-sitter.

%prep
%autosetup -n %{crate}-%{commit} -p1
%cargo_prep_online

export DO_STARTUP_NOTIFY="true"
export APP_ID="%app_id"
export APP_ICON="%app_id"
export APP_NAME="Zed Nightly"
export APP_CLI="zed"
export ZED_UPDATE_EXPLANATION="Run dnf up to update Zed Nightly from Terra."
export ZED_RELEASE_CHANNEL=nightly
export BRANDING_LIGHT="#e9aa6a"
export BRANDING_DARK="#1a5fb4"

echo "StartupWMClass=$APP_ID" >> crates/zed/resources/zed.desktop.in
envsubst < "crates/zed/resources/zed.desktop.in" > $APP_ID.desktop # from https://aur.archlinux.org/cgit/aur.git/tree/PKGBUILD?h=zed-git#n52

envsubst < "crates/zed/resources/flatpak/zed.metainfo.xml.in" > $APP_ID.metainfo.xml

%build
export ZED_UPDATE_EXPLANATION="Run dnf up to update Zed Nightly from Terra."
echo "nightly" > crates/zed/RELEASE_CHANNEL

%cargo_build -- --package zed --package cli
script/generate-licenses

%install
install -Dm755 target/rpm/zed %{buildroot}%{_libexecdir}/zed-editor
install -Dm755 target/rpm/cli %{buildroot}%{_bindir}/zed

install -Dm644 %app_id.desktop %{buildroot}%{_datadir}/applications/%app_id.desktop
install -Dm644 crates/zed/resources/app-icon-nightly.png %{buildroot}%{_datadir}/pixmaps/%app_id.png

install -Dm644 %app_id.metainfo.xml %{buildroot}%{_metainfodir}/%app_id.metainfo.xml

%if %{with check}
%check
%cargo_test
%endif

%files
%{_libexecdir}/zed-editor
%{_bindir}/zed
%{_datadir}/applications/%app_id.desktop
%{_datadir}/pixmaps/%app_id.png
%{_metainfodir}/%app_id.metainfo.xml
%license assets/licenses.md

%changelog
%autochangelog
2 changes: 1 addition & 1 deletion anda/games/osu-lazer/osu-lazer.spec
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,7 @@
%define __strip /bin/true

Name: osu-lazer
Version: 2024.521.2
Version: 2024.625.2
Release: 1%?dist
Summary: The future of osu! and the beginning of an open era! Commonly known by the codename osu!lazer. Pew pew.
ExclusiveArch: x86_64
Expand Down
2 changes: 1 addition & 1 deletion anda/langs/python/protobuf/python3-protobuf.spec
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,7 @@

Name: python-%{pypi_name}
Version: 5.27.1
Release: 1%?dist
Release: 2%?dist
Summary: Protocol Buffers

License: BSD-3-Clause
Expand Down
2 changes: 1 addition & 1 deletion anda/langs/rust/nushell/nushell.spec
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
Name: nushell
Version: 0.94.2
Version: 0.95.0
Release: 1%?dist
Summary: A new type of shell
License: MIT
Expand Down
2 changes: 1 addition & 1 deletion anda/lib/libindicator/terra-libindicator.spec
Original file line number Diff line number Diff line change
Expand Up @@ -57,7 +57,7 @@ developing applications that use %{name}-gtk3.

%prep
%setup -q -c
%patch1 -p1 -b .orig
%patch 1 -p1 -b .orig
# Remove all IDO references
# This is only needed for tools/indicator-loader.c
sed -i '6d' ./Makefile.am
Expand Down
2 changes: 1 addition & 1 deletion anda/lib/openh264/anda.hcl
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
project pkg {
rpm {
spec = "openh264.spec"
spec = "openh264.spec"
}
}
Loading

0 comments on commit 6d54f13

Please sign in to comment.