-
-
Notifications
You must be signed in to change notification settings - Fork 25
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
feat(armcord): rename to legcord (#2256)
(cherry picked from commit 1cb0bac)
- Loading branch information
Showing
12 changed files
with
117 additions
and
105 deletions.
There are no files selected for viewing
This file was deleted.
Oops, something went wrong.
This file was deleted.
Oops, something went wrong.
This file was deleted.
Oops, something went wrong.
This file was deleted.
Oops, something went wrong.
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,5 @@ | ||
project pkg { | ||
rpm { | ||
spec = "legcord-bin.spec" | ||
} | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,85 @@ | ||
%define debug_package %nil | ||
%global _build_id_links none | ||
|
||
%ifarch x86_64 | ||
%global src LegCord-%version-linux-x64 | ||
%elifarch aarch64 | ||
%global src LegCord-%version-linux-arm64 | ||
%elifarch armv7l | ||
%global src LegCord-%version-linux-armv7l | ||
%endif | ||
|
||
# Exclude private libraries | ||
%global __requires_exclude libffmpeg.so | ||
%global __provides_exclude_from %{_datadir}/armcord/.*\\.so | ||
|
||
Name: legcord-bin | ||
Version: 1.0.2 | ||
Release: 2%?dist | ||
License: OSL-3.0 | ||
Summary: Custom lightweight Discord client designed to enhance your experience | ||
URL: https://github.com/LegCord/LegCord | ||
Group: Applications/Internet | ||
Source0: %url/releases/download/v%version/%src.zip | ||
Source1: legcord.png | ||
Source2: https://raw.githubusercontent.com/LegCord/LegCord/v%version/README.md | ||
Requires: electron xdg-utils | ||
BuildRequires: unzip | ||
ExclusiveArch: x86_64 aarch64 armv7l | ||
Conflicts: legcord | ||
BuildRequires: add-determinism | ||
|
||
%description | ||
LegCord is a custom client designed to enhance your Discord experience | ||
while keeping everything lightweight. | ||
|
||
%prep | ||
mkdir legcord | ||
cd legcord | ||
unzip %SOURCE0 | ||
|
||
cat <<EOF > .legcord.desktop | ||
[Desktop Entry] | ||
Name=LegCord | ||
Comment=%summary | ||
GenericName=Internet Messenger | ||
Type=Application | ||
Exec=%_bindir/legcord | ||
Icon=legcord | ||
Categories=Network;InstantMessaging; | ||
StartupWMClass=legcord | ||
Keywords=discord;armcord;legcord;vencord;shelter;electron; | ||
EOF | ||
|
||
%build | ||
|
||
%install | ||
cd legcord | ||
mkdir -p %buildroot%_bindir %buildroot%_datadir/applications %buildroot%_datadir/pixmaps %buildroot%_datadir/legcord %buildroot%_docdir/%name | ||
cp -a * %buildroot%_datadir/legcord/ | ||
ln -s %_datadir/legcord/legcord %buildroot%_bindir/legcord | ||
chmod +x -R %buildroot%_datadir/legcord/* | ||
chmod 755 %buildroot%_datadir/legcord/legcord | ||
install -Dm644 .legcord.desktop %buildroot%_datadir/applications/LegCord.desktop | ||
install -Dm644 %SOURCE1 %buildroot%_datadir/pixmaps/legcord.png | ||
install -Dm644 %SOURCE2 %buildroot%_docdir/%name/ | ||
|
||
%files | ||
%doc README.md | ||
%_datadir/legcord | ||
%_bindir/legcord | ||
%_datadir/applications/LegCord.desktop | ||
%_datadir/pixmaps/legcord.png | ||
|
||
%changelog | ||
* Mon Oct 21 2024 madonuko <[email protected]> - 1.0.2-2 | ||
- Rename to LegCord. | ||
|
||
* Sat Jun 17 2023 madonuko <[email protected]> - 3.2.0-2 | ||
- Remove libnotify dependency. | ||
- Fix desktop entry. | ||
- Set as noarch package because there are not binary files. | ||
- Use /usr/share/ instead of /opt/ | ||
|
||
* Sat May 6 2023 madonuko <[email protected]> - 3.1.7-1 | ||
- Initial package |
File renamed without changes
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1 @@ | ||
rpm.version(gh("LegCord/LegCord")); |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,6 +1,6 @@ | ||
project pkg { | ||
arches = ["x86_64"] | ||
rpm { | ||
spec = "armcord.spec" | ||
spec = "legcord.spec" | ||
} | ||
} |
File renamed without changes.
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,39 +1,41 @@ | ||
%define debug_package %nil | ||
|
||
Name: armcord | ||
Name: legcord | ||
Version: 1.0.2 | ||
Release: 1%?dist | ||
Release: 2%?dist | ||
License: OSL-3.0 | ||
Summary: Custom lightweight Discord client designed to enhance your experience | ||
URL: https://github.com/ArmCord/ArmCord | ||
URL: https://github.com/LegCord/LegCord | ||
Group: Applications/Internet | ||
Source1: launch.sh | ||
Packager: madonuko <[email protected]> | ||
Requires: electron xdg-utils | ||
BuildRequires: git-core add-determinism pnpm | ||
Conflicts: armcord-bin | ||
Provides: armcord | ||
Obsoletes: armcord | ||
Conflicts: legcord-bin | ||
BuildArch: noarch | ||
|
||
%description | ||
ArmCord is a custom client designed to enhance your Discord experience | ||
legcord is a custom client designed to enhance your Discord experience | ||
while keeping everything lightweight. | ||
|
||
%prep | ||
rm -rf * | ||
git clone %url . | ||
git checkout v%version | ||
|
||
cat <<EOF > armcord.desktop | ||
cat <<EOF > legcord.desktop | ||
[Desktop Entry] | ||
Name=ArmCord | ||
Name=LegCord | ||
Comment=%summary | ||
GenericName=Internet Messenger | ||
Type=Application | ||
Exec=/usr/bin/armcord | ||
Icon=armcord | ||
Exec=/usr/bin/legcord | ||
Icon=legcord | ||
Categories=Network;InstantMessaging; | ||
StartupWMClass=armcord | ||
Keywords=discord;armcord;vencord;shelter;electron; | ||
StartupWMClass=legcord | ||
Keywords=discord;armcord;legcord;vencord;shelter;electron; | ||
EOF | ||
|
||
|
||
|
@@ -43,21 +45,24 @@ pnpm run packageQuick | |
|
||
|
||
%install | ||
install -Dm644 dist/*-unpacked/resources/app.asar %buildroot/usr/share/armcord/app.asar | ||
install -Dm644 dist/*-unpacked/resources/app.asar %buildroot/usr/share/legcord/app.asar | ||
|
||
install -Dm755 %SOURCE1 %buildroot/usr/bin/armcord | ||
install -Dm644 armcord.desktop %buildroot/usr/share/applications/ArmCord.desktop | ||
install -Dm644 build/icon.png %buildroot/usr/share/pixmaps/armcord.png | ||
install -Dm755 %SOURCE1 %buildroot/usr/bin/legcord | ||
install -Dm644 legcord.desktop %buildroot/usr/share/applications/LegCord.desktop | ||
install -Dm644 build/icon.png %buildroot/usr/share/pixmaps/legcord.png | ||
|
||
%files | ||
%doc README.md | ||
%license license.txt | ||
/usr/bin/armcord | ||
/usr/share/applications/ArmCord.desktop | ||
/usr/share/pixmaps/armcord.png | ||
/usr/share/armcord/app.asar | ||
/usr/bin/legcord | ||
/usr/share/applications/LegCord.desktop | ||
/usr/share/pixmaps/legcord.png | ||
/usr/share/legcord/app.asar | ||
|
||
%changelog | ||
* Mon Oct 21 2024 madonuko <[email protected]> - 1.0.2-2 | ||
- Rename to LegCord. | ||
|
||
* Mon Aug 26 2024 madonuko <[email protected]> - 3.3.0-1 | ||
- Update to license.txt | ||
|
||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1 @@ | ||
rpm.version(gh("LegCord/LegCord")); |