-
-
Notifications
You must be signed in to change notification settings - Fork 25
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
* add: albius * update.rhai (cherry picked from commit 8e1ff8b)
- Loading branch information
Showing
3 changed files
with
44 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,38 @@ | ||
%define debug_package %nil | ||
%global commit 688ca6ae29de89174794a48be61ecd0fb1111c96 | ||
%global commit_date 20240430 | ||
%global shortcommit %(c=%{commit}; echo ${c:0:7}) | ||
|
||
Name: albius | ||
Version: %date.%shortcommit | ||
Release: 1%?dist | ||
Summary: A Linux installer backend with support for SquashFS and OCI installations | ||
License: GPL-3.0 | ||
URL: https://github.com/Vanilla-OS/Albius | ||
Source0: %url/archive/%commit/albius-%commit.tar.gz | ||
BuildRequires: go anda-srpm-macros btrfs-progs-devel pkgconfig(devmapper) pkgconfig(gpgme) lvm2 gcc | ||
|
||
%description | ||
Albius is a Linux installer backend originally designed for Vanilla OS, | ||
but capable of handling any Linux distribution that uses either Squashfs | ||
or OCI images for distributing the base system. Albius is written entirely | ||
in Go and uses a recipe system (see "recipes" subsection) for describing | ||
operations, mountpoints and options. | ||
|
||
%prep | ||
%autosetup -n Albius-%commit | ||
go mod download | ||
|
||
%build | ||
mkdir -p build/bin | ||
go build -ldflags "-B 0x$(head -c20 /dev/urandom|od -An -tx1|tr -d ' \n') -s -w" -buildmode=pie -o build/bin/albius . | ||
|
||
%install | ||
mkdir -p %{buildroot}%{_bindir}/ | ||
install -pm755 build/bin/albius %{buildroot}%{_bindir}/ | ||
|
||
%files | ||
%_bindir/albius | ||
|
||
%changelog | ||
%autochangelog |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,5 @@ | ||
project pkg { | ||
rpm { | ||
spec = "albius.spec" | ||
} | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1 @@ | ||
rpm.version(gh("Vanilla-OS/Albius")); |