-
-
Notifications
You must be signed in to change notification settings - Fork 25
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
chore(sync): frawhide -> f39 (#1808)
- Loading branch information
Showing
35 changed files
with
3,019 additions
and
28 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -2,4 +2,7 @@ project pkg { | |
rpm { | ||
spec = "envision.spec" | ||
} | ||
labels { | ||
nightly = 1 | ||
} | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,5 @@ | ||
project pkg { | ||
rpm { | ||
spec = "komikku.spec" | ||
} | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,109 @@ | ||
%global appname Komikku | ||
%global uuid info.febvre.%{appname} | ||
%global gtk4_version 4.14.4 | ||
%global libadwaita_version 1.5.1 | ||
%global pure_protobuf_version 2.0.0 | ||
|
||
Name: komikku | ||
Version: 1.51.1 | ||
%forgemeta | ||
Release: %autorelease | ||
Summary: A manga reader for GNOME | ||
|
||
BuildArch: noarch | ||
|
||
License: GPL-3.0-or-later | ||
URL: https://valos.gitlab.io/Komikku | ||
Source0: https://codeberg.org/valos/%{appname}/archive/v%{version}.tar.gz#/%{name}-v%{version}.tar.gz | ||
|
||
BuildRequires: desktop-file-utils | ||
BuildRequires: intltool | ||
BuildRequires: libappstream-glib | ||
BuildRequires: meson >= 0.59.0 | ||
BuildRequires: python3-devel >= 3.8 | ||
BuildRequires: blueprint-compiler | ||
|
||
BuildRequires: pkgconfig(gobject-introspection-1.0) >= 1.35.9 | ||
BuildRequires: pkgconfig(gtk4) >= %{gtk4_version} | ||
BuildRequires: pkgconfig(libadwaita-1) >= %{libadwaita_version} | ||
|
||
Requires: hicolor-icon-theme | ||
Requires: gtk4 >= %{gtk4_version} | ||
Requires: libadwaita >= %{libadwaita_version} | ||
Requires: libnotify | ||
Requires: webkitgtk6.0 | ||
Requires: python3-beautifulsoup4 | ||
Requires: python3-brotli | ||
Requires: python3-colorthief | ||
Requires: python3-dateparser %dnl >= 1.1.4 | https://bugzilla.redhat.com/show_bug.cgi?id=2115204 | ||
Requires: python3-emoji | ||
Requires: python3-gobject | ||
Requires: python3-keyring >= 21.6.0 | ||
Requires: python3-lxml | ||
Requires: python3-natsort | ||
Requires: python3-file-magic | ||
Requires: python3-piexif | ||
Requires: python3-pillow | ||
Requires: python3-pillow-heif | ||
Requires: python3-pure-protobuf >= %{pure_protobuf_version} | ||
Requires: python3-rarfile | ||
Requires: python3-requests | ||
Requires: python3-unidecode | ||
|
||
%description | ||
Komikku is a manga reader for GNOME. It focuses on providing a clean, intuitive | ||
and adaptive interface. | ||
|
||
Keys features | ||
|
||
* Online reading from dozens of servers | ||
* Offline reading of downloaded comics | ||
* Categories to organize your library | ||
* RTL, LTR, Vertical and Webtoon reading modes | ||
* Several types of navigation: | ||
* Keyboard arrow keys | ||
* Right and left navigation layout via mouse click or tapping | ||
(touchpad/touch screen) | ||
* Mouse wheel | ||
* 2-fingers swipe gesture (touchpad) | ||
* Swipe gesture (touch screen) | ||
* Automatic update of comics | ||
* Automatic download of new chapters | ||
* Reading history | ||
* Light and dark themes | ||
|
||
%prep | ||
%autosetup -n %{name} -p1 | ||
|
||
|
||
%build | ||
%meson | ||
%meson_build | ||
|
||
|
||
%install | ||
%meson_install | ||
%find_lang %{name} | ||
|
||
|
||
%check | ||
appstream-util validate-relax --nonet %{buildroot}%{_metainfodir}/*.xml | ||
desktop-file-validate %{buildroot}%{_datadir}/applications/*.desktop | ||
|
||
|
||
%files -f %{name}.lang | ||
%license LICENSE | ||
%doc README.md | ||
%{_bindir}/%{name} | ||
%{_datadir}/%{name}/ | ||
%{_datadir}/applications/*.desktop | ||
%{_datadir}/glib-2.0/schemas/*.gschema.xml | ||
%{_datadir}/icons/hicolor/scalable/*/*.svg | ||
%{_datadir}/icons/hicolor/symbolic/*/*.svg | ||
%{_metainfodir}/*.xml | ||
%{python3_sitelib}/%{name}/ | ||
|
||
|
||
%changelog | ||
* Thu Jul 11 2024 Trung Lê <[email protected]> - 1.51.1-0 | ||
- Initial RPM package |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,3 @@ | ||
let latest_tag = get("https://codeberg.org/api/v1/repos/valos/Komikku/tags").json_arr()[0].name; | ||
let new_version = find("([\\.\\d]+)", latest_tag, 1); | ||
rpm.version(new_version); |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,8 @@ | ||
project pkg { | ||
rpm { | ||
spec = "flow-control-nightly.spec" | ||
} | ||
labels { | ||
nightly = 1 | ||
} | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,30 @@ | ||
%global commit 3400554f57b770760cb4cb58f15963399d13848e | ||
%global shortcommit %(c=%{commit}; echo ${c:0:7}) | ||
%global commit_date 20240801 | ||
|
||
Name: flow-control-nightly | ||
Version: %commit_date.%shortcommit | ||
Release: 1%?dist | ||
Summary: A programmer's text editor | ||
License: MIT | ||
URL: https://github.com/neurocyte/flow | ||
Source0: %url/archive/%commit.tar.gz | ||
BuildRequires: zig | ||
Provides: flow = %version-%release | ||
|
||
%description | ||
%summary. | ||
|
||
%prep | ||
%autosetup -n flow-%commit | ||
|
||
%build | ||
zig build -Doptimize=ReleaseFast --release=fast | ||
|
||
%install | ||
install -Dpm755 zig-out/bin/flow %buildroot%_bindir/flow | ||
|
||
%files | ||
%doc README.md help.md | ||
%license LICENSE | ||
%_bindir/flow |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,7 @@ | ||
if filters.contains("nightly") { | ||
rpm.global("commit", gh_commit("neurocyte/flow")); | ||
if rpm.changed() { | ||
rpm.release(); | ||
rpm.global("commit_date", date()); | ||
} | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,5 @@ | ||
project pkg { | ||
rpm { | ||
spec = "tracy.spec" | ||
} | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,77 @@ | ||
%global _desc Tracy is a real time, nanosecond resolution, remote telemetry, hybrid frame and sampling profiler for games and other applications. | ||
|
||
Name: tracy | ||
Version: 0.11.0 | ||
Release: 1%?dist | ||
Summary: A real time, nanosecond resolution, remote telemetry, hybrid frame and sampling profiler for games and other applications. | ||
License: BSD-3-Clause | ||
URL: https://github.com/wolfpld/tracy | ||
Source0: https://github.com/wolfpld/tracy/archive/refs/tags/v%version.tar.gz | ||
BuildRequires: pkgconfig(egl) pkgconfig(glfw3) pkgconfig(freetype2) pkgconfig(dbus-1) pkgconfig(libunwind) pkgconfig(libdebuginfod) pkgconfig(tbb) pkgconfig(wayland-client) pkgconfig(wayland-protocols) pkgconfig(xkbcommon) pkgconfig(capstone) | ||
BuildRequires: cmake gcc gcc-c++ meson | ||
|
||
%description | ||
%_desc | ||
|
||
%package devel | ||
Summary: Development files for the tracy package | ||
|
||
%description devel | ||
%_desc | ||
This package contains the development files for the tracy package. | ||
|
||
%prep | ||
%autosetup -p1 | ||
|
||
%build | ||
%meson | ||
%meson_build | ||
|
||
for project in capture csvexport import-chrome import-fuchsia update profiler | ||
do | ||
pushd $project | ||
%cmake -DDOWNLOAD_CAPSTONE=0 | ||
%cmake_build | ||
popd | ||
done | ||
|
||
%install | ||
%meson_install | ||
|
||
# NOTE: the subprojects don't have install targets so we do it manually | ||
install -Dm755 capture/%__cmake_builddir/tracy-capture %buildroot%_bindir/tracy-capture | ||
install -Dm755 csvexport/%__cmake_builddir/tracy-csvexport %buildroot%_bindir/tracy-csvexport | ||
install -Dm755 import-chrome/%__cmake_builddir/tracy-import-chrome %buildroot%_bindir/tracy-import-chrome | ||
install -Dm755 import-fuchsia/%__cmake_builddir/tracy-import-fuchsia %buildroot%_bindir/tracy-import-fuchsia | ||
install -Dm755 update/%__cmake_builddir/tracy-update %buildroot%_bindir/tracy-update | ||
install -Dm755 profiler/%__cmake_builddir/tracy-profiler %buildroot%_bindir/tracy | ||
|
||
install -Dm644 extra/desktop/tracy.desktop %buildroot%_datadir/applications/tracy.desktop | ||
install -Dm644 icon/icon.svg %buildroot%_iconsdir/hicolor/scalable/apps/tracy.svg | ||
install -Dm644 extra/desktop/application-tracy.xml %buildroot%_datadir/mime/packages/application-tracy.xml | ||
install -Dm644 icon/application-tracy.svg %buildroot%_iconsdir/hicolor/scalable/apps/application-tracy.svg | ||
|
||
%files | ||
%license LICENSE | ||
%doc README.* | ||
%_bindir/tracy | ||
%_bindir/tracy-capture | ||
%_bindir/tracy-csvexport | ||
%_bindir/tracy-import-chrome | ||
%_bindir/tracy-import-fuchsia | ||
%_bindir/tracy-update | ||
%_libdir/libtracy.so | ||
%_datadir/applications/tracy.desktop | ||
%_datadir/mime/packages/application-tracy.xml | ||
%_iconsdir/hicolor/scalable/apps/tracy.svg | ||
%_iconsdir/hicolor/scalable/apps/application-tracy.svg | ||
|
||
%files devel | ||
%_libdir/pkgconfig/tracy.pc | ||
%_includedir/common | ||
%_includedir/tracy | ||
%_includedir/client | ||
|
||
%changelog | ||
* Wed Jul 24 2024 Owen Zimmerman <[email protected]> - 0.11-1 | ||
- Initial package. |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1 @@ | ||
rpm.version(gh("wolfpld/tracy")); |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Oops, something went wrong.