Skip to content

Commit

Permalink
fix: oxipng
Browse files Browse the repository at this point in the history
  • Loading branch information
madonuko committed Oct 30, 2023
1 parent faee562 commit 7a8b007
Show file tree
Hide file tree
Showing 2 changed files with 82 additions and 24 deletions.
25 changes: 25 additions & 0 deletions anda/rust/oxipng/oxipng-fix-metadata-auto.diff
Original file line number Diff line number Diff line change
@@ -0,0 +1,25 @@
--- oxipng-9.0.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ oxipng-9.0.0/Cargo.toml 2023-10-30T06:36:01.294365+00:00
@@ -116,7 +116,6 @@
[features]
binary = [
"clap",
- "glob",
"env_logger",
]
default = [
@@ -133,13 +132,10 @@
]
sanity-checks = ["image"]

-[target."cfg(windows)".dependencies.glob]
-version = "0.3.1"
-optional = true
-
[badges.maintenance]
status = "actively-developed"

[badges.travis-ci]
branch = "master"
repository = "shssoichiro/oxipng"
+
81 changes: 57 additions & 24 deletions anda/rust/oxipng/rust-oxipng.spec
Original file line number Diff line number Diff line change
@@ -1,32 +1,39 @@
# Generated by rust2rpm 23
# Generated by rust2rpm 25
%bcond_without check

%global crate oxipng

Name: rust-oxipng
Version: 9.0.0
Release: 1%{?dist}
Release: %autorelease
Summary: Lossless PNG compression optimizer

License: MIT
URL: https://crates.io/crates/oxipng
Source: %{crates_source}
# Automatically generated patch to strip dependencies and normalize metadata
Patch: oxipng-fix-metadata-auto.diff

BuildRequires: anda-srpm-macros rust-packaging >= 21
BuildRequires: anda-srpm-macros cargo-rpm-macros >= 24

%global _description %{expand:
Lossless PNG compression optimizer.}
A lossless PNG compression optimizer.}

%description %{_description}

%package -n %{crate}
Summary: %{summary}
# FIXME: paste output of %%cargo_license_summary here
License: # FIXME
# LICENSE.dependencies contains a full license breakdown

%description -n %{crate} %{_description}

%files -n %{crate}
%license LICENSE
%license LICENSE.dependencies
%doc CHANGELOG.md
%doc MANUAL.txt
%doc README.md
%{_bindir}/oxipng

Expand All @@ -42,6 +49,7 @@ use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/MANUAL.txt
%doc %{crate_instdir}/README.md
%{crate_instdir}/

Expand Down Expand Up @@ -81,6 +89,30 @@ use the "clap" feature of the "%{crate}" crate.
%files -n %{name}+clap-devel
%ghost %{crate_instdir}/Cargo.toml

%package -n %{name}+crossbeam-channel-devel
Summary: %{summary}
BuildArch: noarch

%description -n %{name}+crossbeam-channel-devel %{_description}

This package contains library source intended for building other packages which
use the "crossbeam-channel" feature of the "%{crate}" crate.

%files -n %{name}+crossbeam-channel-devel
%ghost %{crate_instdir}/Cargo.toml

%package -n %{name}+env_logger-devel
Summary: %{summary}
BuildArch: noarch

%description -n %{name}+env_logger-devel %{_description}

This package contains library source intended for building other packages which
use the "env_logger" feature of the "%{crate}" crate.

%files -n %{name}+env_logger-devel
%ghost %{crate_instdir}/Cargo.toml

%package -n %{name}+filetime-devel
Summary: %{summary}
BuildArch: noarch
Expand All @@ -105,52 +137,52 @@ use the "freestanding" feature of the "%{crate}" crate.
%files -n %{name}+freestanding-devel
%ghost %{crate_instdir}/Cargo.toml

%package -n %{name}+parallel-devel
%package -n %{name}+image-devel
Summary: %{summary}
BuildArch: noarch

%description -n %{name}+parallel-devel %{_description}
%description -n %{name}+image-devel %{_description}

This package contains library source intended for building other packages which
use the "parallel" feature of the "%{crate}" crate.
use the "image" feature of the "%{crate}" crate.

%files -n %{name}+parallel-devel
%files -n %{name}+image-devel
%ghost %{crate_instdir}/Cargo.toml

%package -n %{name}+rayon-devel
%package -n %{name}+parallel-devel
Summary: %{summary}
BuildArch: noarch

%description -n %{name}+rayon-devel %{_description}
%description -n %{name}+parallel-devel %{_description}

This package contains library source intended for building other packages which
use the "rayon" feature of the "%{crate}" crate.
use the "parallel" feature of the "%{crate}" crate.

%files -n %{name}+rayon-devel
%files -n %{name}+parallel-devel
%ghost %{crate_instdir}/Cargo.toml

%package -n %{name}+stderrlog-devel
%package -n %{name}+rayon-devel
Summary: %{summary}
BuildArch: noarch

%description -n %{name}+stderrlog-devel %{_description}
%description -n %{name}+rayon-devel %{_description}

This package contains library source intended for building other packages which
use the "stderrlog" feature of the "%{crate}" crate.
use the "rayon" feature of the "%{crate}" crate.

%files -n %{name}+stderrlog-devel
%files -n %{name}+rayon-devel
%ghost %{crate_instdir}/Cargo.toml

%package -n %{name}+wild-devel
%package -n %{name}+sanity-checks-devel
Summary: %{summary}
BuildArch: noarch

%description -n %{name}+wild-devel %{_description}
%description -n %{name}+sanity-checks-devel %{_description}

This package contains library source intended for building other packages which
use the "wild" feature of the "%{crate}" crate.
use the "sanity-checks" feature of the "%{crate}" crate.

%files -n %{name}+wild-devel
%files -n %{name}+sanity-checks-devel
%ghost %{crate_instdir}/Cargo.toml

%package -n %{name}+zopfli-devel
Expand All @@ -166,15 +198,16 @@ use the "zopfli" feature of the "%{crate}" crate.
%ghost %{crate_instdir}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%autosetup -n %{crate}-%{version} -p1
%cargo_prep_online

%build
%(echo "%{cargo_build}" | sed "s@--profile rpm@--profile release@g" | sed "s@-j @@")
%cargo_build
%{cargo_license_summary}
%{cargo_license} > LICENSE.dependencies

%install
export CARGO_INSTALL_ROOT=%buildroot%_prefix
cargo install --path .
%cargo_install

%if %{with check}
%check
Expand Down

0 comments on commit 7a8b007

Please sign in to comment.