-
-
Notifications
You must be signed in to change notification settings - Fork 25
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
- Loading branch information
Showing
28 changed files
with
378 additions
and
65 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
4 changes: 2 additions & 2 deletions
4
anda/games/prismlauncher-qt5-nightly/prismlauncher-qt5-nightly.spec
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,11 +1,12 @@ | ||
%global csrc_commit 561b417c65791cd8356b5f73620914ceff845d10 | ||
%global commit 78c834dd76f273d8813247647531005a1f7db1a6 | ||
%global commit 33902d9dbb65fbfdfbd6e3b2a34c6e19eccb762f | ||
%global shortcommit %(c=%{commit}; echo ${c:0:7}) | ||
%global ver 2.1.1 | ||
%global commit_date 20240312 | ||
%global commit_date 20240322 | ||
%global debug_package %nil | ||
|
||
Name: nim-nighlty | ||
Version: %ver^%commit_date.%commit | ||
Version: %ver^%commit_date.%shortcommit | ||
Release: 1%?dist | ||
Summary: Imperative, multi-paradigm, compiled programming language | ||
License: MIT and BSD | ||
|
@@ -36,6 +37,7 @@ order of priority). | |
This package provides various tools, which help Nim programmers. | ||
|
||
|
||
%ifarch x86_64 | ||
%package doc | ||
Summary: Documentation for Nim programming language | ||
BuildArch: noarch | ||
|
@@ -46,12 +48,15 @@ order of priority). | |
|
||
This package provides documentation and reference manual for the language | ||
and its standard library. | ||
%endif | ||
|
||
|
||
%prep | ||
%autosetup -n Nim-%commit | ||
# hack | ||
cp /usr/bin/mold /usr/bin/ld | ||
|
||
|
||
%build | ||
export CFLAGS="${CFLAGS} -Ofast" | ||
export CXXFLAGS="${CXXFLAGS} -Ofast" | ||
|
@@ -66,13 +71,18 @@ nimBuildCsourcesIfNeeded CFLAGS="${CFLAGS} -Ic_code -w -O3 -fno-strict-aliasing | |
nim c --noNimblePath --skipUserCfg --skipParentCfg --hints:off -d:danger koch.nim | ||
koch boot -d:release -d:nimStrictMode --lib:lib | ||
|
||
%ifarch x86_64 | ||
koch docs & | ||
%endif | ||
(cd lib; nim c --app:lib -d:danger -d:createNimRtl -t:-fPIE -l:-pie nimrtl.nim) & | ||
koch tools --skipUserCfg --skipParentCfg --hints:off -d:release -t:-fPIE -l:-pie & | ||
nim c -d:danger -t:-fPIE -l:-pie nimsuggest/nimsuggest.nim & | ||
wait | ||
|
||
%ifarch x86_64 | ||
sed -i '/<link.*fonts.googleapis.com/d' doc/html/*.html | ||
%endif | ||
|
||
|
||
%install | ||
export PATH="$(pwd):$(pwd)/bin:${PATH}" | ||
|
@@ -82,24 +92,28 @@ mold -run bin/nim cc -d:nimCallDepthLimit=10000 -r tools/niminst/niminst --var:v | |
|
||
sh ./install.sh %buildroot/usr/bin | ||
|
||
mkdir -p %buildroot/%_bindir %buildroot/%_datadir/bash-completion/completions | ||
mkdir -p %buildroot/%_bindir %buildroot/%_datadir/bash-completion/completions %buildroot/usr/lib/nim | ||
install -Dpm755 bin/nim{grep,suggest,pretty} %buildroot/%_bindir | ||
install -Dpm644 tools/nim.bash-completion %buildroot/%_datadir/bash-completion/completions/nim | ||
install -Dpm644 dist/nimble/nimble.bash-completion %buildroot/%_datadir/bash-completion/completions/nimble | ||
install -Dpm644 -t%buildroot/%_mandir/man1 %SOURCE1 %SOURCE2 %SOURCE3 %SOURCE4 | ||
|
||
mkdir -p %buildroot/%_docdir/%name/html %buildroot/usr/lib/nim | ||
%ifarch x86_64 | ||
mkdir -p %buildroot/%_docdir/%name/html | ||
cp -a doc/html/*.html %buildroot/%_docdir/%name/html/ | ||
cp tools/dochack/dochack.js %buildroot/%_docdir/%name/ | ||
%endif | ||
|
||
cp -r lib/* %buildroot%_prefix/lib/nim/ | ||
cp -a compiler %buildroot%_prefix/lib/nim/ | ||
install -Dm644 nim.nimble %buildroot%_prefix/lib/nim/compiler | ||
install -Dm644 config/* -t %buildroot/etc/nim | ||
install -d %buildroot%_includedir || true | ||
cp -a %buildroot%_prefix/lib/nim/lib/*.h %buildroot%_includedir || true | ||
ln -s %_prefix/lib/nim %buildroot%_prefix/lib/nim/lib || true | ||
rm -rf %buildroot/nim || true | ||
rm %buildroot%_bindir/*.bat || true | ||
|
||
#check | ||
# export PATH=$PATH:$(realpath ./bin) | ||
# for cat in manyloc gc threads nimble-all lib io async rodfiles debugger examples dll flags | ||
# do | ||
# ./koch tests --pedantic category $cat -d:nimCoroutines || (echo "$cat test category failed" && exit 1) | ||
# done | ||
|
||
%files | ||
%license copying.txt dist/nimble/license.txt | ||
|
@@ -108,16 +122,17 @@ cp -r lib/* %buildroot%_prefix/lib/nim/ | |
%_mandir/man1/nim{,ble}.1* | ||
%_datadir/bash-completion/completions/nim{,ble} | ||
%_prefix/lib/nim/ | ||
%_sysconfdir/nim/ | ||
|
||
%files tools | ||
%license copying.txt | ||
%_bindir/nim{grep,suggest,pretty} | ||
%_mandir/man1/nim{grep,suggest}.1* | ||
|
||
%ifarch x86_64 | ||
%files doc | ||
%doc %_docdir/%name | ||
|
||
%endif | ||
|
||
%changelog | ||
* Mon Jan 9 2023 windowsboy111 <[email protected]> - 1.9.3^fcc383d89994241f1b73fe4f85ef38528c135e2e-1 | ||
- Initial Package. | ||
%autochangelog |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
4 changes: 2 additions & 2 deletions
4
anda/langs/vala/vala-language-server-nightly/vala-language-server-nightly.spec
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -2,4 +2,7 @@ project pkg { | |
rpm { | ||
spec = "pqmarble.spec" | ||
} | ||
labels { | ||
nightly = "1" | ||
} | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Oops, something went wrong.