Skip to content

Commit

Permalink
chore(sync): f39 -> f40
Browse files Browse the repository at this point in the history
  • Loading branch information
madonuko committed Mar 25, 2024
1 parent d694528 commit 7e845ee
Show file tree
Hide file tree
Showing 28 changed files with 378 additions and 65 deletions.
5 changes: 2 additions & 3 deletions anda/apps/feishin/feishin.spec
Original file line number Diff line number Diff line change
Expand Up @@ -38,9 +38,8 @@ Keywords=Music;Jellyfin;Audio;Stream;Sonixd
EOF

%build
npm i --legacy-peer-deps update-browserslist-db@latest
npm audit fix --force
npx update-browserslist-db@latest
npm install --legacy-peer-deps
npm run postinstall
npm run build
%ifarch x86_64

Expand Down
4 changes: 2 additions & 2 deletions anda/apps/mpv/mpv-nightly.spec
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
%global commit 3e42139e138a8cbb67a756dab2d6eaeb2a115223
%global commit a46ce9e28cd97f7280c085649a79f85aa1d0fe70
%global shortcommit %(c=%{commit}; echo ${c:0:7})
%global commit_date 20240227
%global commit_date 20240325
%global ver v0.37.0

Name: mpv-nightly
Expand Down
4 changes: 2 additions & 2 deletions anda/games/prismlauncher-nightly/prismlauncher-nightly.spec
Original file line number Diff line number Diff line change
@@ -1,13 +1,13 @@
%global real_name prismlauncher
%global nice_name PrismLauncher

%global commit 3b0564f098c49be2fd3082928c91440c73df4d80
%global commit df0280f52b68f4352d8da711136609c16ce4db7b
%global shortcommit %(c=%{commit}; echo ${c:0:7})
%global libnbtplusplus_commit a5e8fd52b8bf4ab5d5bcc042b2a247867589985f
%global quazip_commit 6117161af08e366c37499895b00ef62f93adc345
%global tomlplusplus_commit 7eb2ffcc09f8e9890dc0b77ff8ab00fc53b1f2b8

%global commit_date 20240311
%global commit_date 20240325
%global snapshot_info %{commit_date}.%{shortcommit}

%bcond_without qt6
Expand Down
Original file line number Diff line number Diff line change
@@ -1,13 +1,13 @@
%global real_name prismlauncher
%global nice_name PrismLauncher

%global commit 3b0564f098c49be2fd3082928c91440c73df4d80
%global commit df0280f52b68f4352d8da711136609c16ce4db7b
%global shortcommit %(c=%{commit}; echo ${c:0:7})
%global libnbtplusplus_commit a5e8fd52b8bf4ab5d5bcc042b2a247867589985f
%global quazip_commit 6117161af08e366c37499895b00ef62f93adc345
%global tomlplusplus_commit 7eb2ffcc09f8e9890dc0b77ff8ab00fc53b1f2b8

%global commit_date 20240311
%global commit_date 20240325
%global snapshot_info %{commit_date}.%{shortcommit}

%bcond_with qt6
Expand Down
43 changes: 29 additions & 14 deletions anda/langs/nim/nim-nightly/nim-nightly.spec
Original file line number Diff line number Diff line change
@@ -1,11 +1,12 @@
%global csrc_commit 561b417c65791cd8356b5f73620914ceff845d10
%global commit 78c834dd76f273d8813247647531005a1f7db1a6
%global commit 33902d9dbb65fbfdfbd6e3b2a34c6e19eccb762f
%global shortcommit %(c=%{commit}; echo ${c:0:7})
%global ver 2.1.1
%global commit_date 20240312
%global commit_date 20240322
%global debug_package %nil

Name: nim-nighlty
Version: %ver^%commit_date.%commit
Version: %ver^%commit_date.%shortcommit
Release: 1%?dist
Summary: Imperative, multi-paradigm, compiled programming language
License: MIT and BSD
Expand Down Expand Up @@ -36,6 +37,7 @@ order of priority).
This package provides various tools, which help Nim programmers.


%ifarch x86_64
%package doc
Summary: Documentation for Nim programming language
BuildArch: noarch
Expand All @@ -46,12 +48,15 @@ order of priority).

This package provides documentation and reference manual for the language
and its standard library.
%endif


%prep
%autosetup -n Nim-%commit
# hack
cp /usr/bin/mold /usr/bin/ld


%build
export CFLAGS="${CFLAGS} -Ofast"
export CXXFLAGS="${CXXFLAGS} -Ofast"
Expand All @@ -66,13 +71,18 @@ nimBuildCsourcesIfNeeded CFLAGS="${CFLAGS} -Ic_code -w -O3 -fno-strict-aliasing
nim c --noNimblePath --skipUserCfg --skipParentCfg --hints:off -d:danger koch.nim
koch boot -d:release -d:nimStrictMode --lib:lib

%ifarch x86_64
koch docs &
%endif
(cd lib; nim c --app:lib -d:danger -d:createNimRtl -t:-fPIE -l:-pie nimrtl.nim) &
koch tools --skipUserCfg --skipParentCfg --hints:off -d:release -t:-fPIE -l:-pie &
nim c -d:danger -t:-fPIE -l:-pie nimsuggest/nimsuggest.nim &
wait

%ifarch x86_64
sed -i '/<link.*fonts.googleapis.com/d' doc/html/*.html
%endif


%install
export PATH="$(pwd):$(pwd)/bin:${PATH}"
Expand All @@ -82,24 +92,28 @@ mold -run bin/nim cc -d:nimCallDepthLimit=10000 -r tools/niminst/niminst --var:v

sh ./install.sh %buildroot/usr/bin

mkdir -p %buildroot/%_bindir %buildroot/%_datadir/bash-completion/completions
mkdir -p %buildroot/%_bindir %buildroot/%_datadir/bash-completion/completions %buildroot/usr/lib/nim
install -Dpm755 bin/nim{grep,suggest,pretty} %buildroot/%_bindir
install -Dpm644 tools/nim.bash-completion %buildroot/%_datadir/bash-completion/completions/nim
install -Dpm644 dist/nimble/nimble.bash-completion %buildroot/%_datadir/bash-completion/completions/nimble
install -Dpm644 -t%buildroot/%_mandir/man1 %SOURCE1 %SOURCE2 %SOURCE3 %SOURCE4

mkdir -p %buildroot/%_docdir/%name/html %buildroot/usr/lib/nim
%ifarch x86_64
mkdir -p %buildroot/%_docdir/%name/html
cp -a doc/html/*.html %buildroot/%_docdir/%name/html/
cp tools/dochack/dochack.js %buildroot/%_docdir/%name/
%endif

cp -r lib/* %buildroot%_prefix/lib/nim/
cp -a compiler %buildroot%_prefix/lib/nim/
install -Dm644 nim.nimble %buildroot%_prefix/lib/nim/compiler
install -Dm644 config/* -t %buildroot/etc/nim
install -d %buildroot%_includedir || true
cp -a %buildroot%_prefix/lib/nim/lib/*.h %buildroot%_includedir || true
ln -s %_prefix/lib/nim %buildroot%_prefix/lib/nim/lib || true
rm -rf %buildroot/nim || true
rm %buildroot%_bindir/*.bat || true

#check
# export PATH=$PATH:$(realpath ./bin)
# for cat in manyloc gc threads nimble-all lib io async rodfiles debugger examples dll flags
# do
# ./koch tests --pedantic category $cat -d:nimCoroutines || (echo "$cat test category failed" && exit 1)
# done

%files
%license copying.txt dist/nimble/license.txt
Expand All @@ -108,16 +122,17 @@ cp -r lib/* %buildroot%_prefix/lib/nim/
%_mandir/man1/nim{,ble}.1*
%_datadir/bash-completion/completions/nim{,ble}
%_prefix/lib/nim/
%_sysconfdir/nim/

%files tools
%license copying.txt
%_bindir/nim{grep,suggest,pretty}
%_mandir/man1/nim{grep,suggest}.1*

%ifarch x86_64
%files doc
%doc %_docdir/%name

%endif

%changelog
* Mon Jan 9 2023 windowsboy111 <[email protected]> - 1.9.3^fcc383d89994241f1b73fe4f85ef38528c135e2e-1
- Initial Package.
%autochangelog
45 changes: 23 additions & 22 deletions anda/langs/nim/nim/nim.spec
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,7 @@

Name: nim
Version: 2.0.2
Release: 2%{?dist}
Release: 3%{?dist}
Summary: Imperative, multi-paradigm, compiled programming language
License: MIT and BSD
URL: https://nim-lang.org
Expand All @@ -13,8 +13,7 @@ Source2: nimgrep.1
Source3: nimble.1
Source4: nimsuggest.1
BuildRequires: gcc mold git gcc-c++ nodejs openssl-devel pkgconfig(bash-completion) gc-devel pcre-devel
Requires: redhat-rpm-config gcc
Conflicts: choosenim
Requires: gcc


%description
Expand All @@ -32,7 +31,7 @@ order of priority).

This package provides various tools, which help Nim programmers.


%ifarch x86_64
%package doc
Summary: Documentation for Nim programming language
BuildArch: noarch
Expand All @@ -43,10 +42,13 @@ order of priority).

This package provides documentation and reference manual for the language
and its standard library.
%endif


%prep
%autosetup -n nim-%{version}


%build
export CFLAGS="${CFLAGS} -Ofast"
export CXXFLAGS="${CXXFLAGS} -Ofast"
Expand All @@ -58,20 +60,24 @@ export PATH="$(pwd):$(pwd)/bin:${PATH}"
mold -run nim c -d:danger koch.nim
mold -run koch boot -d:useLinenoise -t:-fPIE -l:-pie -d:release -d:nativeStacktrace -d:useGnuReadline

%ifarch x86_64
mold -run koch docs &
%endif
(cd lib && nim c --app:lib -d:createNimRtl -d:release nimrtl.nim) &
mold -run koch tools -t:-fPIE -l:-pie &
mold -run nim c -t:-fPIE -l:-pie -d:release nimsuggest/nimsuggest.nim &
wait

%ifarch x86_64
sed -i '/<link.*fonts.googleapis.com/d' doc/html/*.html
%endif


%install
export PATH="$(pwd):$(pwd)/bin:${PATH}"
sh install.sh %{buildroot}usr/bin

mkdir -p %buildroot{%_bindir,%_docdir/%name/html,%_prefix/lib/nim}
mkdir -p %buildroot{%_bindir,%_prefix/lib/nim}
install -Dp -m755 bin/nim{,ble,grep,suggest,pretty} %buildroot/%_bindir
install -Dp -m644 dist/nimble/nimble.bash-completion %{buildroot}%{bashcompdir}/nimble
install -Dp -m644 -t%{buildroot}%{_mandir}/man1 %SOURCE1 %SOURCE2 %SOURCE3 %SOURCE4
Expand All @@ -83,34 +89,27 @@ for comp in tools/*.zsh-completion; do
install -Dm644 $comp %zshcompdir/_$(basename "${comp/.zsh-completion}")
done

%ifarch x86_64
mkdir -p %buildroot%_docdir/%name/html
cp -a doc/html/*.html %buildroot%_docdir/%name/html/
cp tools/dochack/dochack.js %{buildroot}%{_docdir}/%{name}/
cp -a lib %buildroot%_prefix/lib/nim
ln -s %_datadir/nim/doc %buildroot%_prefix/lib/nim/doc
%endif

cp -a lib %buildroot%_prefix/lib/
mv %buildroot%_prefix/lib/{lib,nim}
cp -a compiler %buildroot%_prefix/lib/nim
install -Dm644 nim.nimble %buildroot%_prefix/lib/nim/compiler
ls **
ls %buildroot%_prefix/lib/nim/*
install -m755 lib/libnimrtl.so %buildroot%_prefix/lib/libnimrtl.so

install -m755 lib/libnimrtl.so %buildroot%_prefix/lib/libnimrtl.so # compiler needs
install -Dm644 config/* -t %buildroot/etc/nim
install -Dm755 bin/* -t %buildroot%_bindir

install -d %buildroot%_includedir
cp -a %buildroot%_prefix/lib/nim/lib/*.h %buildroot%_includedir

ln -s %_datadir/nim/doc %buildroot%_prefix/lib/nim/doc

ln -s %_prefix/lib/nim %buildroot%_prefix/lib/nim/lib

ln -s %_prefix/lib/nim %buildroot%_prefix/lib/nim/lib # compiler needs lib from here
ln -s %_prefix/lib/nim/system.nim %_prefix/lib/system.nim # nimsuggest bug
rm -rf %buildroot/nim || true
rm %buildroot%_bindir/*.bat || true

%check
# export PATH=$PATH:$(realpath ./bin)
# for cat in manyloc gc threads nimble-all lib io async rodfiles debugger examples dll flags
# do
# ./koch tests --pedantic category $cat -d:nimCoroutines || (echo "$cat test category failed" && exit 1)
# done

%files
%license copying.txt dist/nimble/license.txt
Expand All @@ -133,8 +132,10 @@ rm %buildroot%_bindir/*.bat || true
%{_bindir}/nim{grep,suggest,pretty}
%{_mandir}/man1/nim{grep,suggest}.1*

%ifarch x86_64
%files doc
%doc %{_docdir}/nim
%endif

%changelog
%autochangelog
Original file line number Diff line number Diff line change
@@ -1,9 +1,9 @@
%global real_name vala-language-server

%global commit 3b5fe941bea6ecd5c8fcb84930c40b8582eea165
%global commit 0b020298aa3dafacd2f6633533ca91fba5698340
%global shortcommit %(c=%{commit}; echo ${c:0:7})

%global commit_date 240218
%global commit_date 20240323
%global snapshot_info %{commit_date}.%{shortcommit}
%global verrel 0.48.7

Expand Down
2 changes: 1 addition & 1 deletion anda/langs/vala/vala-lint-nightly/vala-lint-nightly.spec
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,7 @@
%global commit 8ae2bb65fe66458263d94711ae4ddd978faece00
%global shortcommit %(c=%{commit}; echo ${c:0:7})

%global commit_date 240218
%global commit_date 20240218
%global snapshot_info %{commit_date}.%{shortcommit}

Name: vala-lint-nightly
Expand Down
2 changes: 1 addition & 1 deletion anda/langs/vala/vala-nightly/vala-nightly.spec
Original file line number Diff line number Diff line change
Expand Up @@ -7,7 +7,7 @@
%global shortcommit %(c=%{commit}; echo ${c:0:7})
%global repo https://gitlab.gnome.org/GNOME/%{real_name}.git

%global commit_date 240218
%global commit_date 20240218
%global snapshot_info %{commit_date}.%{shortcommit}

Name: vala-nightly
Expand Down
13 changes: 13 additions & 0 deletions anda/langs/vala/vala-panel-appmenu/vala-panel-appmenu.spec
Original file line number Diff line number Diff line change
Expand Up @@ -21,6 +21,7 @@ BuildRequires: vala
BuildRequires: systemd-rpm-macros
BuildRequires: pkgconfig(libxfce4panel-2.0)
BuildRequires: pkgconfig(gtk+-2.0)
BuildRequires: java-devel
BuildRequires: pkgconfig(gtk+-3.0)
BuildRequires: pkgconfig(libxfconf-0)
BuildRequires: pkgconfig(budgie-1.0)
Expand Down Expand Up @@ -82,6 +83,13 @@ Summary: Gtk3MenuShell D-Bus exporter
%description -n vala-panel-appmenu-gtk-module
GTK (2, 3) module that exports GtkMenuShells over D-Bus.


%package -n vala-panel-appmenu-jayatana-module
Summary: Vala appmenu support for Java Swing applications

%description -n vala-panel-appmenu-jayatana-module
Vala appmenu support for Java Swing applications.

%prep
%forgeautosetup

Expand Down Expand Up @@ -123,6 +131,11 @@ GTK (2, 3) module that exports GtkMenuShells over D-Bus.
%{_libdir}/gtk-3.0/modules/libappmenu-gtk-module.so
%{_datadir}/glib-2.0/schemas/org.appmenu.gtk-module.gschema.xml

%files -n vala-panel-appmenu-jayatana-module
%{_datadir}/java/*.jar
%dir %{_libdir}/jayatana
%{_libdir}/jayatana/*.so

%files -n xfce4-vala-panel-appmenu-plugin
%{_libdir}/xfce4/panel/plugins/libappmenu-xfce.so
%{_datadir}/xfce4/panel/plugins/appmenu.desktop
Expand Down
4 changes: 0 additions & 4 deletions anda/lib/apparmor/apparmor.spec
Original file line number Diff line number Diff line change
Expand Up @@ -139,10 +139,6 @@ changehat abilities exposed through libapparmor.
%prep
%autosetup -p1 -n %{name}-%{version}

ver="%(echo %version | sed 's@~alpha@a@')"
sed -i "s/@VERSION@/$ver/g" libraries/libapparmor/swig/python/setup.py.in
sed -i 's/${PYTHON} ${PYSETUP} install --prefix=${PYPREFIX} --root=${DESTDIR} --version=${VERSION}/${PYTHON} ${PYSETUP} install --prefix=${PYPREFIX} --root=${DESTDIR} --version="'$ver'"/' ./utils/Makefile

%build
export PYTHON=%{__python3}
export PYTHON_VERSION=3
Expand Down
3 changes: 3 additions & 0 deletions anda/lib/pqmarble/anda.hcl
Original file line number Diff line number Diff line change
Expand Up @@ -2,4 +2,7 @@ project pkg {
rpm {
spec = "pqmarble.spec"
}
labels {
nightly = "1"
}
}
4 changes: 3 additions & 1 deletion anda/lib/pqmarble/pqmarble.spec
Original file line number Diff line number Diff line change
@@ -1,8 +1,10 @@
%global commit f240b2ec7d5cdacb8fdcc553703420dc5101ffdb
%global shortcommit %(c=%{commit}; echo ${c:0:7})
%global commit_date 20240310
%global ver 2.0.0

Name: pqmarble
Version: %ver^%commit
Version: %ver^%commit_date.%shortcommit
Release: 1%{?dist}
Summary: My GTK library
License: GPL-3.0
Expand Down
Loading

0 comments on commit 7e845ee

Please sign in to comment.