Skip to content

Commit

Permalink
Merge branch 'main' into f38
Browse files Browse the repository at this point in the history
  • Loading branch information
madonuko committed Apr 2, 2023
2 parents 454fc71 + 870abef commit 7ea3f85
Show file tree
Hide file tree
Showing 173 changed files with 1,041 additions and 362 deletions.
8 changes: 8 additions & 0 deletions .github/workflows/autobuild.yml
Original file line number Diff line number Diff line change
Expand Up @@ -66,6 +66,14 @@ jobs:
options: --cap-add=SYS_ADMIN --privileged
steps:
- uses: terrapkg/anda-build@main
if: github.event_name == 'pull_request'
with:
name: "${{ matrix.pkg.pkg }}"
mockConfig: anda-${{ matrix.version }}-${{ matrix.pkg.arch }}
andaRepo: https://github.com/terrapkg/subatomic-repos/raw/main/terra${{ matrix.version }}.repo

- uses: terrapkg/anda-build@main
if: github.event_name != 'pull_request'
with:
name: "${{ matrix.pkg.pkg }}"
mockConfig: anda-${{ matrix.version }}-${{ matrix.pkg.arch }}
Expand Down
19 changes: 9 additions & 10 deletions .github/workflows/sync.yml
Original file line number Diff line number Diff line change
Expand Up @@ -8,19 +8,19 @@ on:

jobs:
sync:
if: github.event.pull_request.merged == true
if: github.event.pull_request.merged == true && !contains(github.event.pull_request.labels.*.name, 'nosync')
runs-on: ubuntu-latest
steps:
- name: Install SSH key
run: |
mkdir -p ${{ runner.temp }}
echo "${{ secrets.SSH_SIGNING_KEY }}" > ${{ runner.temp }}/signing_key
chmod 0700 ${{ runner.temp }}/signing_key
- name: Checkout
uses: actions/checkout@v3
with:
fetch-depth: 0
ssh-key: ${{ secrets.SSH_AUTHENTICATION_KEY }}
- name: Install SSH key
run: |
mkdir -p ${{ runner.temp }}
echo "${{ secrets.SSH_SIGNING_KEY }}" > ${{ runner.temp }}/signing_key
chmod 0700 ${{ runner.temp }}/signing_key
- name: Setup Git
run: |
git config --global --add safe.directory "$GITHUB_WORKSPACE"
Expand All @@ -29,11 +29,10 @@ jobs:
git config gpg.format "ssh"
git config user.signingkey "${{ runner.temp }}/signing_key"
- name: Download patches
run: |
curl https://github.com/terrapkg/packages/pull/${{ github.event.pull_request.number }}.patch > pr.patch
run: curl https://github.com/terrapkg/packages/pull/${{ github.event.pull_request.number }}.patch > pr.patch
- name: Apply patches
run: |
git checkout f38
git am --keep-cr --signoff < pr.patch
git am -S --keep-cr --signoff < pr.patch
- name: Push
run: git push origin -u --all
run: git push -u origin --all
4 changes: 2 additions & 2 deletions anda/apps/anki-bin/anki-bin.spec
Original file line number Diff line number Diff line change
@@ -1,8 +1,8 @@
Name: anki-bin
Version: 2.1.60
Version: 2.1.61
Release: 1%{?dist}
Summary: Flashcard program for using space repetition learning (Installed with wheel)
License: AGPLv3+ and GPLv3+ and LGPLv3 and MIT and BSD and ASL 2.0 and CC-BY-SA and CC-BY
License: AGPL-3.0-or-later AND GPL-3.0-or-later AND LGPL-3.0-or-later AND MIT AND BSD-3-Clause AND CC-BY-SA-3.0 AND CC-BY-3.0 AND Apache-2.0 AND CC-BY-2.5
URL: https://apps.ankiweb.net/
BuildRequires: python3-installer python3.11
Requires: hicolor-icon-theme python3-sqlalchemy python3-simplejson python3-matplotlib python3-decorator python3-markdown python3-send2trash
Expand Down
4 changes: 2 additions & 2 deletions anda/apps/anki-qt5/anki-qt5.spec
Original file line number Diff line number Diff line change
@@ -1,8 +1,8 @@
Name: anki-qt5
Version: 2.1.60
Version: 2.1.61
Release: 1%{?dist}
Summary: Flashcard program for using space repetition learning
License: AGPLv3+ and GPLv3+ and LGPLv3 and MIT and BSD and ASL 2.0 and CC-BY-SA and CC-BY
License: AGPL-3.0-or-later AND GPL-3.0-or-later AND LGPL-3.0-or-later AND MIT AND BSD-3-Clause AND CC-BY-SA-3.0 AND CC-BY-3.0 AND Apache-2.0 AND CC-BY-2.5
URL: https://apps.ankiweb.net/
BuildRequires: python3-devel python3-setuptools python3-waitress python3-protobuf python3-pysocks
BuildRequires: python3-distro python3-flask-cors python3-jsonschema python3-send2trash python3-certifi python3-simplejson python3-pyqt5-sip
Expand Down
6 changes: 3 additions & 3 deletions anda/apps/anki/anki.spec
Original file line number Diff line number Diff line change
@@ -1,8 +1,8 @@
Name: anki
Version: 2.1.60
Version: 2.1.61
Release: 1%{?dist}
Summary: Flashcard program for using space repetition learning
License: AGPLv3+ and GPLv3+ and LGPLv3 and MIT and BSD and ASL 2.0 and CC-BY-SA and CC-BY
License: AGPL-3.0-or-later AND GPL-3.0-or-later AND LGPL-3.0-or-later AND MIT AND BSD-3-Clause AND CC-BY-SA-3.0 AND CC-BY-3.0 AND Apache-2.0 AND CC-BY-2.5
URL: https://apps.ankiweb.net/
BuildRequires: python3-devel python3-setuptools python3-waitress python3-protobuf python3-pysocks
BuildRequires: python3-distro python3-flask-cors python3-jsonschema python3-send2trash python3-certifi python3-simplejson
Expand Down Expand Up @@ -62,5 +62,5 @@ chmod 755 %{buildroot}%{_bindir}/anki


%changelog
* Tue Jan 3 2023 windowsboy111 <[email protected]>
* Tue Jan 3 2023 windowsboy111 <[email protected]> - 2.1.60
- Initial package
2 changes: 1 addition & 1 deletion anda/apps/authy/authy.spec
Original file line number Diff line number Diff line change
Expand Up @@ -2,7 +2,7 @@ Name: authy
Version: 2.2.3
Release: 1%{?dist}
Summary: Two factor authentication desktop application
License: Unknown
License: Unlicense
URL: https://authy.com/
Source0: https://api.snapcraft.io/api/v1/snaps/download/H8ZpNgIoPyvmkgxOWw5MSzsXK1wRZiHn_18.snap
Requires: gtk3
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -4,7 +4,7 @@ Name: discord-canary-openasar
Version: 0.0.150
Release: 1%{?dist}
Summary: OpenAsar is a rewrite of part of Discord's desktop code, making it snappier and include more features like further customization and theming
License: MIT and https://discord.com/terms
License: MIT AND https://discord.com/terms
URL: https://github.com/GooseMod/OpenAsar
Source0: https://dl-canary.discordapp.net/apps/linux/%{version}/discord-canary-%{version}.tar.gz
Source1: %{url}/releases/download/nightly/app.asar
Expand Down
4 changes: 2 additions & 2 deletions anda/apps/discord-openasar/discord-openasar.spec
Original file line number Diff line number Diff line change
@@ -1,10 +1,10 @@
%define debug_package %{nil}

Name: discord-openasar
Version: 0.0.25
Version: 0.0.26
Release: 1%{?dist}
Summary: OpenAsar is a rewrite of part of Discord's desktop code, making it snappier and include more features like further customization and theming
License: MIT and https://discord.com/terms
License: MIT AND https://discord.com/terms
URL: https://github.com/GooseMod/OpenAsar
Source0: https://dl.discordapp.net/apps/linux/%{version}/discord-%{version}.tar.gz
Source1: %{url}/releases/download/nightly/app.asar
Expand Down
2 changes: 1 addition & 1 deletion anda/apps/discord-ptb-openasar/discord-ptb-openasar.spec
Original file line number Diff line number Diff line change
Expand Up @@ -4,7 +4,7 @@ Name: discord-ptb-openasar
Version: 0.0.41
Release: 1%{?dist}
Summary: OpenAsar is a rewrite of part of Discord's desktop code, making it snappier and include more features like further customization and theming
License: MIT and https://discord.com/terms
License: MIT AND https://discord.com/terms
URL: https://github.com/GooseMod/OpenAsar
Source0: https://dl-ptb.discordapp.net/apps/linux/%{version}/discord-ptb-%{version}.tar.gz
Source1: %{url}/releases/download/nightly/app.asar
Expand Down
2 changes: 1 addition & 1 deletion anda/apps/discord/discord.spec
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
%define debug_package %{nil}

Name: discord
Version: 0.0.25
Version: 0.0.26
Release: 1%{?dist}
Summary: Free Voice and Text Chat for Gamers.
URL: discord.com
Expand Down
4 changes: 2 additions & 2 deletions anda/apps/vala-panel-appmenu/vala-panel-appmenu.spec
Original file line number Diff line number Diff line change
Expand Up @@ -5,7 +5,7 @@
Name: vala-panel-appmenu
Version: 0.7.6
Release: %autorelease
License: LGPL-3.0+
License: LGPL-3.0-or-later
Summary: This package provides Application Menu plugin for vala-panel
URL: %{forgeurl}
Source: %{forgesource}
Expand All @@ -31,7 +31,7 @@ BuildRequires: pkgconfig(x11)
BuildRequires: pkgconfig(dbusmenu-glib-0.4)
BuildRequires: pkgconfig(vala-panel)
BuildRequires: pkgconfig(libmatepanelapplet-4.0)
Provides: vala-panel-appmenu-plugin
Provides: vala-panel-appmenu-plugin = %{version}
Requires: unity-gtk3-module
Requires: unity-gtk2-module
Requires: bamf-daemon
Expand Down
2 changes: 1 addition & 1 deletion anda/apps/vala-panel/vala-panel.spec
Original file line number Diff line number Diff line change
Expand Up @@ -6,7 +6,7 @@
Name: vala-panel
Version: 0.5.0
Release: %autorelease
License: LGPL-3.0+
License: LGPL-3.0-or-later
Summary: This package provides Application Menu plugin for vala-panel
URL: %{forgeurl}
Source: %{forgesource}
Expand Down
2 changes: 1 addition & 1 deletion anda/audio/distrho/distrho.spec
Original file line number Diff line number Diff line change
Expand Up @@ -9,7 +9,7 @@ Version: 0
Release: 0.1.%{rel_tag}%{?dist}
Summary: Linux audio plugins ports
URL: https://distrho.sourceforge.io/ports.php
License: GPLv2 and GPLv3 and MIT
License: GPL-2.0 AND GPL-3.0 AND MIT

Source0: https://github.com/DISTRHO/DISTRHO-Ports/archive/refs/tags/2021-03-15.tar.gz

Expand Down
2 changes: 1 addition & 1 deletion anda/dart/dart.spec
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
%define debug_package %{nil}

Name: dart
Version: 2.19.5
Version: 2.19.6
Release: 1%{?dist}
Summary: The Dart Language
License: BSD-3-Clause
Expand Down
2 changes: 1 addition & 1 deletion anda/desktops/budgie/budgie-extras/budgie-extras.spec
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,7 @@ Name: budgie-extras
Version: 1.6.0
Release: 1%{?dist}

License: GPLv3
License: GPL-3.0
Summary: Additional Budgie Desktop enhancements for user experience
URL: https://ubuntubudgie.org/

Expand Down
6 changes: 3 additions & 3 deletions anda/desktops/compiz9/compiz9.spec
Original file line number Diff line number Diff line change
Expand Up @@ -6,7 +6,7 @@ Version: 0.9.14.2
Release: %autorelease
Summary: OpenGL window and compositing manager 0.9.X.X series

License: GPLv2+ AND LGPLv2+ AND MIT
License: GPL-2.0-or-later AND LGPL-2.0-or-later AND MIT
URL: https://launchpad.net/compiz
Source0: http://archive.ubuntu.com/ubuntu/pool/universe/c/compiz/compiz_%{version}+%{_ubuntu_rel}.tar.xz
Patch0: https://raw.githubusercontent.com/cat-master21/unityDE-specs/main/patches/compiz-cmake-install-path.patch
Expand Down Expand Up @@ -57,8 +57,8 @@ Requires: metacity
Requires: glx-utils

%package devel
Summary: Development files for %{name}
Requires: %{name}%{?_isa} = %{version}-%{release}
Summary: Development files for %{name}
Requires: %{name}%{?_isa} = %{version}-%{release}

%description devel
This package contains the development files for %{name}.
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -5,7 +5,7 @@ Name: elementary-calculator
Summary: Calculator app designed for elementary
Version: 2.0.1
Release: %autorelease
License: GPLv3+
License: GPL-3.0-or-later

URL: https://github.com/elementary/%{srcname}
Source0: %{url}/archive/%{version}/%{srcname}-%{version}.tar.gz
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -7,7 +7,7 @@ Name: elementary-calendar
Summary: Desktop calendar app designed for elementary
Version: 6.1.2
Release: 1%{?dist}
License: GPLv3+
License: GPL-3.0-or-later

URL: https://github.com/elementary/calendar
Source0: %{url}/archive/%{version}/%{srcname}-%{version}.tar.gz
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -5,7 +5,7 @@ Name: elementary-camera
Summary: Camera app designed for elementary
Version: 6.2.1
Release: 1%{?dist}
License: GPLv3
License: GPL-3.0

URL: https://github.com/elementary/camera
Source0: %{url}/archive/%{version}/%{srcname}-%{version}.tar.gz
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -5,7 +5,7 @@ Name: elementary-capnet-assist
Summary: Captive Portal Assistant for elementary
Version: 2.4.3
Release: 2%{?dist}
License: GPLv3+
License: GPL-3.0-or-later

URL: https://github.com/elementary/capnet-assist
Source0: %{url}/archive/%{version}/%{srcname}-%{version}.tar.gz
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -7,7 +7,7 @@ Name: elementary-code
Summary: Code editor from elementary
Version: 7.0.0
Release: 2%{?dist}
License: GPLv3
License: GPL-3.0

URL: https://github.com/elementary/%{srcname}
Source0: %{url}/archive/%{version}/%{srcname}-%{version}.tar.gz
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -7,7 +7,7 @@ Name: elementary-files
Summary: File manager from elementary
Version: 6.3.0
Release: 1%{?dist}
License: GPLv3
License: GPL-3.0

URL: https://github.com/elementary/%{srcname}
Source0: %{url}/archive/%{version}/%{srcname}-%{version}.tar.gz
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -5,7 +5,7 @@ Name: elementary-greeter
Summary: LightDM Login Screen for the elementary desktop
Version: 6.1.1
Release: %autorelease
License: GPLv3
License: GPL-3.0

URL: https://github.com/elementary/greeter
Source0: %{url}/archive/%{version}/%{srcname}-%{version}.tar.gz
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -5,7 +5,7 @@ Name: elementary-icon-theme
Summary: Icons from the Elementary Project
Version: 7.2.0
Release: 1%{?dist}
License: GPLv3+
License: GPL-3.0-or-later

URL: https://github.com/elementary/icons
Source0: %{url}/archive/%{version}/%{srcname}-%{version}.tar.gz
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -12,7 +12,7 @@ Name: elementary-music
Summary: Music player and library from elementary
Version: 7.0.1
Release: 2%{?dist}
License: LGPLv2+
License: LGPL-2.0-or-later

URL: https://github.com/elementary/%{srcname}
Source0: %{url}/archive/%{version}/%{srcname}-%{version}.tar.gz
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -7,7 +7,7 @@ Version: 6.0.3
Release: 1%{?dist}
Summary: GTK Notification server for Pantheon

License: GPLv3
License: GPL-3.0
URL: https://github.com/elementary/%{srcname}
Source0: %{url}/archive/refs/tags/%{version}.tar.gz

Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -5,7 +5,7 @@ Name: elementary-onboarding
Summary: Onboarding app for new users
Version: 7.0.1
Release: %autorelease
License: GPLv3+
License: GPL-3.0-or-later

URL: https://github.com/elementary/onboarding
Source0: %{url}/archive/%{version}/%{srcname}-%{version}.tar.gz
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -7,7 +7,7 @@ Name: elementary-photos
Summary: Photo manager and viewer from elementary
Version: 2.8.0
Release: %autorelease
License: LGPLv2+
License: LGPL-2.0-or-later

URL: https://github.com/elementary/photos
Source0: %{url}/archive/%{version}/%{srcname}-%{version}.tar.gz
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -5,7 +5,7 @@ Name: elementary-print
Summary: Simple shim for printing support via Contractor
Version: 0.1.3
Release: 9%{?dist}
License: GPLv3+
License: GPL-3.0-or-later

URL: https://github.com/elementary/%{srcname}
Source0: %{url}/archive/%{version}/%{name}-%{version}.tar.gz
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -5,7 +5,7 @@ Name: elementary-screenshot-tool
Summary: Screenshot tool designed for elementary
Version: 6.0.3
Release: 1%{?dist}
License: LGPLv3
License: LGPL-3.0

URL: https://github.com/elementary/screenshot
Source0: %{url}/archive/%{version}/%{srcname}-%{version}.tar.gz
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -6,7 +6,7 @@ Name: elementary-settings-daemon
Version: 1.2.0
Release: 2%{?dist}
Summary: Settings Daemon and Portal for Pantheon
License: GPLv3+
License: GPL-3.0-or-later

URL: https://github.com/elementary/settings-daemon
Source0: %{url}/archive/%{version}/%{srcname}-%{version}.tar.gz
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -5,7 +5,7 @@ Name: elementary-shortcut-overlay
Summary: Native, OS-wide shortcut overlay
Version: 2.0.1
Release: %autorelease
License: GPLv3
License: GPL-3.0

URL: https://github.com/elementary/shortcut-overlay
Source0: %{url}/archive/%{version}/%{srcname}-%{version}.tar.gz
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -5,7 +5,7 @@ Name: elementary-sideload
Summary: Sideload flatpaks on Pantheon
Version: 6.1.0
Release: %autorelease
License: GPLv3+
License: GPL-3.0-or-later

URL: https://github.com/elementary/sideload
Source0: %{url}/archive/%{version}/%{srcname}-%{version}.tar.gz
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -4,7 +4,7 @@ Name: elementary-sound-theme
Summary: Set of system sounds for elementary
Version: 1.1.0
Release: %autorelease
License: Unlicense and CC-BY
License: Unlicense AND CC-BY-4.0

# Unlicense:
# - audio-volume-change
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -5,7 +5,7 @@ Name: elementary-terminal
Summary: The terminal of the 21st century
Version: 6.1.1
Release: 1%{?dist}
License: LGPLv3
License: LGPL-3.0

URL: https://github.com/elementary/%{srcname}
Source0: %{url}/archive/%{version}/%{srcname}-%{version}.tar.gz
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -5,7 +5,7 @@ Name: elementary-theme
Summary: elementary GTK+ Stylesheet
Version: 7.1.0
Release: 1%{?dist}
License: GPLv3
License: GPL-3.0

URL: https://github.com/elementary/stylesheet
Source0: %{url}/archive/%{version}/%{srcname}-%{version}.tar.gz
Expand Down
Loading

0 comments on commit 7ea3f85

Please sign in to comment.