-
-
Notifications
You must be signed in to change notification settings - Fork 25
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
- Loading branch information
Showing
3 changed files
with
54 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,8 @@ | ||
project pkg { | ||
rpm { | ||
spec = "stardust-protostar.spec" | ||
} | ||
labels { | ||
nightly = 1 | ||
} | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,39 @@ | ||
%global commit 39499a061af74c3a2d5e1e46e4ad21aca5727219 | ||
%global commit_date 20240719 | ||
%global shortcommit %(c=%{commit}; echo ${c:0:7}) | ||
# Exclude input files from mangling | ||
%global __brp_mangle_shebangs_exclude_from ^/usr/src/.*$ | ||
|
||
Name: stardust-protostar | ||
Version: %commit_date.%shortcommit | ||
Release: 1%?dist | ||
Summary: Tools you can easily snap together to get non-spatial input into stardust. | ||
URL: https://github.com/StardustXR/protostar | ||
Source0: %url/archive/%commit/protostar-%commit.tar.gz | ||
License: MIT | ||
BuildRequires: cargo cmake anda-srpm-macros cargo-rpm-macros mold libudev-devel g++ libinput-devel libxkbcommon-x11-devel | ||
Requires: libgcc glibc | ||
|
||
Provides: protostar | ||
Packager: Owen Zimmerman <[email protected]> | ||
|
||
%description | ||
Tools you can easily snap together to get non-spatial input into stardust. | ||
|
||
%prep | ||
%autosetup -n protostar-%commit | ||
%cargo_prep_online | ||
|
||
%build | ||
|
||
%install | ||
%cargo_install | ||
|
||
%files | ||
%_bindir/protostar | ||
%license LICENSE | ||
%doc README.md | ||
|
||
%changelog | ||
* Mon Sep 9 2024 Owen-sz <[email protected]> | ||
- Package StardustXR protostar |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,7 @@ | ||
if filters.contains("nightly") { | ||
rpm.global("commit", gh_commit("StardustXR/protostar")); | ||
if rpm.changed() { | ||
rpm.release(); | ||
rpm.global("commit_date", date()); | ||
} | ||
} |