-
-
Notifications
You must be signed in to change notification settings - Fork 25
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
chore(sync): frawhide -> f39 (#1348)
- Loading branch information
Showing
29 changed files
with
616 additions
and
24 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,38 @@ | ||
%define debug_package %nil | ||
%global commit 688ca6ae29de89174794a48be61ecd0fb1111c96 | ||
%global commit_date 20240430 | ||
%global shortcommit %(c=%{commit}; echo ${c:0:7}) | ||
|
||
Name: albius | ||
Version: %date.%shortcommit | ||
Release: 1%?dist | ||
Summary: A Linux installer backend with support for SquashFS and OCI installations | ||
License: GPL-3.0 | ||
URL: https://github.com/Vanilla-OS/Albius | ||
Source0: %url/archive/%commit/albius-%commit.tar.gz | ||
BuildRequires: go anda-srpm-macros btrfs-progs-devel pkgconfig(devmapper) pkgconfig(gpgme) lvm2 gcc | ||
|
||
%description | ||
Albius is a Linux installer backend originally designed for Vanilla OS, | ||
but capable of handling any Linux distribution that uses either Squashfs | ||
or OCI images for distributing the base system. Albius is written entirely | ||
in Go and uses a recipe system (see "recipes" subsection) for describing | ||
operations, mountpoints and options. | ||
|
||
%prep | ||
%autosetup -n Albius-%commit | ||
go mod download | ||
|
||
%build | ||
mkdir -p build/bin | ||
go build -ldflags "-B 0x$(head -c20 /dev/urandom|od -An -tx1|tr -d ' \n') -s -w" -buildmode=pie -o build/bin/albius . | ||
|
||
%install | ||
mkdir -p %{buildroot}%{_bindir}/ | ||
install -pm755 build/bin/albius %{buildroot}%{_bindir}/ | ||
|
||
%files | ||
%_bindir/albius | ||
|
||
%changelog | ||
%autochangelog |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,5 @@ | ||
project pkg { | ||
rpm { | ||
spec = "albius.spec" | ||
} | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1 @@ | ||
rpm.version(gh("Vanilla-OS/Albius")); |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
4 changes: 2 additions & 2 deletions
4
anda/langs/vala/vala-language-server-nightly/vala-language-server-nightly.spec
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,5 @@ | ||
project pkg { | ||
rpm { | ||
spec = "openh264.spec" | ||
} | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,201 @@ | ||
#!/bin/sh | ||
|
||
# Process a gst-plugins-bad tarball to remove | ||
# unwanted GStreamer plugins. | ||
# | ||
# This script here is taken from Fedora gstreamer1-plugins-bad-free repo, with | ||
# only change being openh264 addition. | ||
# | ||
# See https://bugzilla.redhat.com/show_bug.cgi?id=532470 | ||
# for details | ||
# | ||
# Bastien Nocera <[email protected]> - 2010 | ||
# | ||
|
||
SOURCE="$1" | ||
NEW_SOURCE=`echo $SOURCE | sed 's/bad-/bad-openh264-/'` | ||
DIRECTORY=`echo $SOURCE | sed 's/\.tar\.xz//'` | ||
|
||
ALLOWED=" | ||
aacparse | ||
accurip | ||
adpcmdec | ||
adpcmenc | ||
aiff | ||
aiffparse | ||
amrparse | ||
asfmux | ||
audiobuffersplit | ||
audiofxbad | ||
audiolatency | ||
audiomixer | ||
audiomixmatrix | ||
audioparsers | ||
audiovisualizers | ||
autoconvert | ||
bayer | ||
camerabin | ||
camerabin2 | ||
cdxaparse | ||
codecalpha | ||
codectimestamper | ||
coloreffects | ||
colorspace | ||
compositor | ||
dataurisrc | ||
dccp | ||
debugutils | ||
dtmf | ||
dvbsubenc | ||
faceoverlay | ||
festival | ||
fieldanalysis | ||
freeverb | ||
freeze | ||
frei0r | ||
gaudieffects | ||
gdp | ||
geometrictransform | ||
h264parse | ||
hdvparse | ||
hls | ||
id3tag | ||
inter | ||
interlace | ||
invtelecine | ||
ivfparse | ||
ivtc | ||
jpegformat | ||
jp2kdecimator | ||
legacyresample | ||
librfb | ||
liveadder | ||
midi | ||
mve | ||
mpegdemux | ||
mpeg4videoparse | ||
mpegpsmux | ||
mpegtsdemux | ||
mpegtsmux | ||
mpegvideoparse | ||
mxf | ||
netsim | ||
nsf | ||
nuvdemux | ||
onvif | ||
openh264 | ||
patchdetect | ||
pcapparse | ||
pnm | ||
proxy | ||
qtmux | ||
rawparse | ||
removesilence | ||
rist | ||
rtmp2 | ||
rtp | ||
rtpmux | ||
rtpvp8 | ||
scaletempo | ||
sdi | ||
sdp | ||
segmentclip | ||
selector | ||
smooth | ||
speed | ||
stereo | ||
subenc | ||
switchbin | ||
timecode | ||
transcode | ||
tta | ||
valve | ||
videofilters | ||
videoframe_audiolevel | ||
videomaxrate | ||
videomeasure | ||
videoparsers | ||
videosignal | ||
vmnc | ||
yadif | ||
y4m | ||
" | ||
|
||
NOT_ALLOWED=" | ||
dvbsuboverlay | ||
dvdspu | ||
real | ||
siren | ||
" | ||
|
||
error() | ||
{ | ||
MESSAGE=$1 | ||
echo $MESSAGE | ||
exit 1 | ||
} | ||
|
||
check_allowed() | ||
{ | ||
MODULE=$1 | ||
for i in $ALLOWED ; do | ||
if test x$MODULE = x$i ; then | ||
return 0; | ||
fi | ||
done | ||
# Ignore errors coming from ext/ directory | ||
# they require external libraries so are ineffective anyway | ||
return 1; | ||
} | ||
|
||
check_not_allowed() | ||
{ | ||
MODULE=$1 | ||
for i in $NOT_ALLOWED ; do | ||
if test x$MODULE = x$i ; then | ||
return 0; | ||
fi | ||
done | ||
return 1; | ||
} | ||
|
||
rm -rf $DIRECTORY | ||
tar xJf $SOURCE || error "Cannot unpack $SOURCE" | ||
pushd $DIRECTORY > /dev/null || error "Cannot open directory \"$DIRECTORY\"" | ||
|
||
unknown="" | ||
for subdir in gst ext sys; do | ||
for dir in $subdir/* ; do | ||
# Don't touch non-directories | ||
if ! [ -d $dir ] ; then | ||
continue; | ||
fi | ||
MODULE=`basename $dir` | ||
if ( check_not_allowed $MODULE ) ; then | ||
echo "**** Removing $MODULE ****" | ||
echo "Removing directory $dir" | ||
rm -r $dir || error "Cannot remove $dir" | ||
echo | ||
elif test $subdir = ext || test $subdir = sys; then | ||
# Ignore library or system non-blacklisted plugins | ||
continue; | ||
elif ! ( check_allowed $MODULE ) ; then | ||
echo "Unknown module in $dir" | ||
unknown="$unknown $dir" | ||
fi | ||
done | ||
done | ||
|
||
echo | ||
|
||
if test "x$unknown" != "x"; then | ||
echo -n "Aborting due to unkown modules: " | ||
echo "$unknown" | sed "s/ /\n /g" | ||
exit 1 | ||
fi | ||
|
||
popd > /dev/null | ||
|
||
tar cJf $NEW_SOURCE $DIRECTORY | ||
echo "$NEW_SOURCE is ready to use" | ||
|
Oops, something went wrong.