Skip to content

Commit

Permalink
feat: multilib for x86 (#1549)
Browse files Browse the repository at this point in the history
* feat: multilib for x86

* feat: Build i686 for x86 targets if multilib
  • Loading branch information
korewaChino authored Jul 19, 2024
1 parent e50a00c commit e8e0461
Show file tree
Hide file tree
Showing 5 changed files with 35 additions and 1 deletion.
5 changes: 5 additions & 0 deletions .github/workflows/autobuild.yml
Original file line number Diff line number Diff line change
Expand Up @@ -60,6 +60,11 @@ jobs:
- name: Build with Andaman
run: anda build ${{ matrix.pkg.pkg }} --package rpm -c anda/terra/mock-configs/terra-${{ matrix.version }}-${{ matrix.pkg.arch }}.cfg

- name: Build with Andaman (alternate arch)
if: |
matrix.pkg.arch == 'x86_64' && matrix.pkg.labels['multilib']
run: anda build ${{ matrix.pkg.pkg }} --package rpm -c anda/terra/mock-configs/terra-${{ matrix.version }}-i386.cfg

- name: Generating artifact name
id: art
Expand Down
5 changes: 5 additions & 0 deletions anda/terra/mock-configs/terra-39-i386.cfg
Original file line number Diff line number Diff line change
@@ -0,0 +1,5 @@
config_opts['releasever'] = '39'
config_opts['target_arch'] = 'i686'
config_opts['legal_host_arches'] = ('i386', 'i586', 'i686', 'x86_64')

include('templates/terra.tpl')
5 changes: 5 additions & 0 deletions anda/terra/mock-configs/terra-40-i386.cfg
Original file line number Diff line number Diff line change
@@ -0,0 +1,5 @@
config_opts['releasever'] = '40'
config_opts['target_arch'] = 'i686'
config_opts['legal_host_arches'] = ('i386', 'i586', 'i686', 'x86_64')

include('templates/terra.tpl')
16 changes: 15 additions & 1 deletion anda/terra/mock-configs/terra-mock-configs.spec
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
Name: terra-mock-configs
Version: 10
Version: 11
Release: 1%{?dist}
Summary: Mock configs for Terra repos

Expand All @@ -10,6 +10,11 @@ Source3: terra-39-x86_64.cfg
Source4: terra-39-aarch64.cfg
Source5: terra-40-x86_64.cfg
Source6: terra-40-aarch64.cfg
Source7: terra-40-i386.cfg
Source8: terra-39-i386.cfg
Source9: terra-rawhide-x86_64.cfg
Source10: terra-rawhide-aarch64.cfg
Source11: terra-rawhide-i386.cfg


BuildRequires: mock-core-configs
Expand All @@ -35,15 +40,24 @@ cp -v %{SOURCE3} %{buildroot}%{_sysconfdir}/mock/
cp -v %{SOURCE4} %{buildroot}%{_sysconfdir}/mock/
cp -v %{SOURCE5} %{buildroot}%{_sysconfdir}/mock/
cp -v %{SOURCE6} %{buildroot}%{_sysconfdir}/mock/
cp -v %{SOURCE7} %{buildroot}%{_sysconfdir}/mock/
cp -v %{SOURCE8} %{buildroot}%{_sysconfdir}/mock/
cp -v %{SOURCE9} %{buildroot}%{_sysconfdir}/mock/
cp -v %{SOURCE10} %{buildroot}%{_sysconfdir}/mock/
cp -v %{SOURCE11} %{buildroot}%{_sysconfdir}/mock/


%files
%config %{_sysconfdir}/mock/templates/terra.tpl
%config %{_sysconfdir}/mock/terra-*-x86_64.cfg
%config %{_sysconfdir}/mock/terra-*-aarch64.cfg
%config %{_sysconfdir}/mock/terra-*-i386.cfg


%changelog
* Wed Jul 18 2024 Cappy Ishihara <[email protected]> - 11-1
- Include multilib mock files for x86-based systems (backwards compatibility)

* Wed Jul 10 2024 madonuko <[email protected]> - 10-1
- Include mock files for Terra 40
- Remove mock files for Terra 38
Expand Down
5 changes: 5 additions & 0 deletions anda/terra/mock-configs/terra-rawhide-i386.cfg
Original file line number Diff line number Diff line change
@@ -0,0 +1,5 @@
config_opts['releasever'] = 'rawhide'
config_opts['target_arch'] = 'i686'
config_opts['legal_host_arches'] = ('i386', 'i586', 'i686', 'x86_64')

include('templates/terra.tpl')

0 comments on commit e8e0461

Please sign in to comment.