-
-
Notifications
You must be signed in to change notification settings - Fork 25
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
* add: `wineasio` * oops, remove the blob * make package exclusive to x86_64 * fix exclusive (cherry picked from commit 7dea510) Co-authored-by: Cappy Ishihara <[email protected]>
- Loading branch information
1 parent
a9e8338
commit f18bf66
Showing
3 changed files
with
81 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,6 @@ | ||
project pkg { | ||
arches = ["x86_64"] | ||
rpm { | ||
spec = "wineasio.spec" | ||
} | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1 @@ | ||
rpm.global("tag", gh("wineasio/wineasio")) |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,74 @@ | ||
Name: wineasio | ||
|
||
%global tag v1.2.0 | ||
# macro to remove the v from version | ||
%global version_tag %(echo %{tag} | sed 's/^v//') | ||
%global forgeurl https://github.com/wineasio/%{name} | ||
|
||
|
||
# While this package should have debug headers, we have build issues with them | ||
|
||
%define debug_package %{nil} | ||
|
||
Version: %{version_tag} | ||
Release: %autorelease | ||
Summary: Wine ASIO driver | ||
|
||
License: GPL-2.0-or-later AND LGPL-2.1-or-later | ||
URL: %{forgeurl} | ||
Source: %{forgeurl}/releases/download/%{tag}/wineasio-%{version_tag}.tar.gz | ||
|
||
BuildRequires: make | ||
BuildRequires: pkgconfig | ||
BuildRequires: pkgconfig(alsa) | ||
BuildRequires: gcc-c++ | ||
BuildRequires: gcc | ||
BuildRequires: pkgconfig(jack) | ||
BuildRequires: wine-devel | ||
ExclusiveArch: x86_64 | ||
|
||
%description | ||
WineASIO provides an ASIO to JACK driver for WINE. | ||
ASIO is the most common Windows low-latency driver, so is commonly used in audio workstation programs. | ||
|
||
You can, for example, use with FLStudio under GNU/Linux systems (together with JACK). | ||
|
||
%prep | ||
%autosetup | ||
|
||
%build | ||
|
||
# remove all cflags because it builds just fine without them, causes issues with asm when the default ones are | ||
# present though | ||
|
||
export CFLAGS="" | ||
|
||
make clean | ||
make 64 | ||
|
||
|
||
%install | ||
install -Dm755 build64/wineasio64.dll.so %{buildroot}%{_libdir}/wine/%{_arch}-unix/wineasio64.dll.so | ||
install -Dm755 build64/wineasio64.dll %{buildroot}%{_libdir}/wine/%{_arch}-windows/wineasio64.dll | ||
install -Dm755 wineasio-register %{buildroot}%{_bindir}/wineasio-register | ||
|
||
pushd gui | ||
|
||
%make_install | ||
|
||
popd | ||
|
||
%files | ||
%license COPYING.LIB COPYING.GUI | ||
%doc README.md | ||
|
||
%{_libdir}/wine/%{_arch}-unix/wineasio64.dll.so | ||
%{_libdir}/wine/%{_arch}-windows/wineasio64.dll | ||
%{_bindir}/wineasio-register | ||
%{_bindir}/wineasio-settings | ||
%{_datadir}/wineasio/ | ||
|
||
|
||
%changelog | ||
* Thu Apr 11 2024 Cappy Ishihara <[email protected]> | ||
- Initial Release |