Skip to content

Commit

Permalink
add: wineasio (#1084) (#1086)
Browse files Browse the repository at this point in the history
* add: `wineasio`

* oops, remove the blob

* make package exclusive to x86_64

* fix exclusive

(cherry picked from commit 7dea510)

Co-authored-by: Cappy Ishihara <[email protected]>
  • Loading branch information
raboneko and korewaChino authored Apr 11, 2024
1 parent a9e8338 commit f18bf66
Show file tree
Hide file tree
Showing 3 changed files with 81 additions and 0 deletions.
6 changes: 6 additions & 0 deletions anda/system/wineasio/anda.hcl
Original file line number Diff line number Diff line change
@@ -0,0 +1,6 @@
project pkg {
arches = ["x86_64"]
rpm {
spec = "wineasio.spec"
}
}
1 change: 1 addition & 0 deletions anda/system/wineasio/update.rhai
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
rpm.global("tag", gh("wineasio/wineasio"))
74 changes: 74 additions & 0 deletions anda/system/wineasio/wineasio.spec
Original file line number Diff line number Diff line change
@@ -0,0 +1,74 @@
Name: wineasio

%global tag v1.2.0
# macro to remove the v from version
%global version_tag %(echo %{tag} | sed 's/^v//')
%global forgeurl https://github.com/wineasio/%{name}


# While this package should have debug headers, we have build issues with them

%define debug_package %{nil}

Version: %{version_tag}
Release: %autorelease
Summary: Wine ASIO driver

License: GPL-2.0-or-later AND LGPL-2.1-or-later
URL: %{forgeurl}
Source: %{forgeurl}/releases/download/%{tag}/wineasio-%{version_tag}.tar.gz

BuildRequires: make
BuildRequires: pkgconfig
BuildRequires: pkgconfig(alsa)
BuildRequires: gcc-c++
BuildRequires: gcc
BuildRequires: pkgconfig(jack)
BuildRequires: wine-devel
ExclusiveArch: x86_64

%description
WineASIO provides an ASIO to JACK driver for WINE.
ASIO is the most common Windows low-latency driver, so is commonly used in audio workstation programs.

You can, for example, use with FLStudio under GNU/Linux systems (together with JACK).

%prep
%autosetup

%build

# remove all cflags because it builds just fine without them, causes issues with asm when the default ones are
# present though

export CFLAGS=""

make clean
make 64


%install
install -Dm755 build64/wineasio64.dll.so %{buildroot}%{_libdir}/wine/%{_arch}-unix/wineasio64.dll.so
install -Dm755 build64/wineasio64.dll %{buildroot}%{_libdir}/wine/%{_arch}-windows/wineasio64.dll
install -Dm755 wineasio-register %{buildroot}%{_bindir}/wineasio-register

pushd gui

%make_install

popd

%files
%license COPYING.LIB COPYING.GUI
%doc README.md

%{_libdir}/wine/%{_arch}-unix/wineasio64.dll.so
%{_libdir}/wine/%{_arch}-windows/wineasio64.dll
%{_bindir}/wineasio-register
%{_bindir}/wineasio-settings
%{_datadir}/wineasio/


%changelog
* Thu Apr 11 2024 Cappy Ishihara <[email protected]>
- Initial Release

0 comments on commit f18bf66

Please sign in to comment.