-
Notifications
You must be signed in to change notification settings - Fork 5
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
zephyr-kernel-src-3.3.0: fix build with gcc-13
Configuration error: | -- Configuring done (4.9s) | CMake Error in CMakeLists.txt: | Target "zephyr_interface" contains relative path in its | INTERFACE_INCLUDE_DIRECTORIES: | | "include-fixed" With GCC-13, limits.h and syslimits.h header files are always being installed to include folder. https://gcc.gnu.org/git/gitweb.cgi?p=gcc.git;h=be9dd80f933480 Signed-off-by: Naveen Saini <[email protected]>
- Loading branch information
Showing
2 changed files
with
41 additions
and
0 deletions.
There are no files selected for viewing
40 changes: 40 additions & 0 deletions
40
...core/recipes-kernel/zephyr-kernel/files/0001-gcc-target.cmake-fix-build-with-gcc-13.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,40 @@ | ||
From 1fadb81a0ba1e6ba85445e8fb47916b7ff077170 Mon Sep 17 00:00:00 2001 | ||
From: Naveen Saini <[email protected]> | ||
Date: Mon, 29 May 2023 17:48:20 +0800 | ||
Subject: [PATCH] gcc/target.cmake: fix build with gcc-13 | ||
|
||
Configuration error: | ||
| -- Configuring done (4.9s) | ||
| CMake Error in CMakeLists.txt: | ||
| Target "zephyr_interface" contains relative path in its | ||
| INTERFACE_INCLUDE_DIRECTORIES: | ||
| | ||
| "include-fixed" | ||
|
||
With GCC-13, limits.h and syslimits.h header files | ||
are always being installed to include folder. | ||
https://gcc.gnu.org/git/gitweb.cgi?p=gcc.git;h=be9dd80f933480 | ||
|
||
Upstream-Status: Pending | ||
|
||
Signed-off-by: Naveen Saini <[email protected]> | ||
--- | ||
cmake/compiler/gcc/target.cmake | 2 +- | ||
1 file changed, 1 insertion(+), 1 deletion(-) | ||
|
||
diff --git a/cmake/compiler/gcc/target.cmake b/cmake/compiler/gcc/target.cmake | ||
index c970048297..b8a70b7919 100644 | ||
--- a/cmake/compiler/gcc/target.cmake | ||
+++ b/cmake/compiler/gcc/target.cmake | ||
@@ -34,7 +34,7 @@ if(NOT DEFINED NOSYSDEF_CFLAG) | ||
set(NOSYSDEF_CFLAG -undef) | ||
endif() | ||
|
||
-foreach(file_name include/stddef.h include-fixed/limits.h) | ||
+foreach(file_name include/stddef.h include/limits.h) | ||
execute_process( | ||
COMMAND ${CMAKE_C_COMPILER} --print-file-name=${file_name} | ||
OUTPUT_VARIABLE _OUTPUT | ||
-- | ||
2.34.1 | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters