Skip to content

Commit

Permalink
zephyr-kernel-src-3.3.0: fix build with gcc-13
Browse files Browse the repository at this point in the history
Configuration error:
| -- Configuring done (4.9s)
| CMake Error in CMakeLists.txt:
|   Target "zephyr_interface" contains relative path in its
|   INTERFACE_INCLUDE_DIRECTORIES:
|
|     "include-fixed"

With GCC-13, limits.h and syslimits.h header files
are always being installed to include folder.
https://gcc.gnu.org/git/gitweb.cgi?p=gcc.git;h=be9dd80f933480

Signed-off-by: Naveen Saini <[email protected]>
  • Loading branch information
saininav committed May 30, 2023
1 parent b0173e0 commit f4fd80c
Show file tree
Hide file tree
Showing 2 changed files with 41 additions and 0 deletions.
Original file line number Diff line number Diff line change
@@ -0,0 +1,40 @@
From 1fadb81a0ba1e6ba85445e8fb47916b7ff077170 Mon Sep 17 00:00:00 2001
From: Naveen Saini <[email protected]>
Date: Mon, 29 May 2023 17:48:20 +0800
Subject: [PATCH] gcc/target.cmake: fix build with gcc-13

Configuration error:
| -- Configuring done (4.9s)
| CMake Error in CMakeLists.txt:
| Target "zephyr_interface" contains relative path in its
| INTERFACE_INCLUDE_DIRECTORIES:
|
| "include-fixed"

With GCC-13, limits.h and syslimits.h header files
are always being installed to include folder.
https://gcc.gnu.org/git/gitweb.cgi?p=gcc.git;h=be9dd80f933480

Upstream-Status: Pending

Signed-off-by: Naveen Saini <[email protected]>
---
cmake/compiler/gcc/target.cmake | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/cmake/compiler/gcc/target.cmake b/cmake/compiler/gcc/target.cmake
index c970048297..b8a70b7919 100644
--- a/cmake/compiler/gcc/target.cmake
+++ b/cmake/compiler/gcc/target.cmake
@@ -34,7 +34,7 @@ if(NOT DEFINED NOSYSDEF_CFLAG)
set(NOSYSDEF_CFLAG -undef)
endif()

-foreach(file_name include/stddef.h include-fixed/limits.h)
+foreach(file_name include/stddef.h include/limits.h)
execute_process(
COMMAND ${CMAKE_C_COMPILER} --print-file-name=${file_name}
OUTPUT_VARIABLE _OUTPUT
--
2.34.1

Original file line number Diff line number Diff line change
Expand Up @@ -117,6 +117,7 @@ SRC_URI_ZEPHYR_THRIFT ?= "git://github.com/zephyrproject-rtos/thrift;protocol=ht
SRC_URI_PATCHES ?= "\
file://0001-3.3-x86-fix-efi-binary-generation-issue-in-cross-compila.patch;patchdir=zephyr \
file://0002-3.3-toolchain-gcc-Fix-separator-between-directives-on-sa.patch;patchdir=zephyr \
file://0001-gcc-target.cmake-fix-build-with-gcc-13.patch;patchdir=zephyr \
"

SRC_URI = "\
Expand Down

0 comments on commit f4fd80c

Please sign in to comment.